Bavarian Soundwerks
Results 1 to 10 of 10

Thread: headunit wiring

  1. #1
    Join Date
    Apr 2019
    Location
    Norway
    Posts
    141
    My Cars
    94 325is coupe

    headunit wiring

    im running new speaker wires to aftermarket amp and headunit. does anyone know which wires from radio harness i need to connect? prolly only 4 or 5 wires as im not using oem speaker harness? e36.
    Last edited by turbokid15; 10-14-2022 at 05:55 PM.

  2. #2
    Join Date
    Sep 2005
    Location
    Peoria, AZ
    Posts
    7,632
    My Cars
    03 zhp, 97 e36m3, 04 zhp
    You'd need constant and switched 12V, ground and remote control for your aftermarket radio:

    http://wedophones.com/Manuals/BMW/

  3. #3
    Join Date
    Sep 2008
    Location
    West London/Heathrow - UK
    Posts
    7,171
    My Cars
    03 530dT - Ex Police Car
    Hi,

    Given the seemingly limited knowledge and experience you have from your question, I'd suggest you find a local 12V electrionics or electrician to fit and connect the head unit, amplifier and speakers properly and most importantly, safely. For instance, have you got the correct guage wiring for the amplifier? have you got the right fuses and circuit breakers connected correctly too? same for the head unit power ? do you know exactly which wires in the car's harness are the correct ones to use on the new head unit wiring? Wiring diagrams are out there, but a previous owner may have spliced in other cables with different colour covers so you'll need to test and check before hand.

    I'm not saying this to deter you, but inexperience with 12V electronics install can and has led to fire's in cars and when the insurance have foud it was down to faulty wiring done by the owner, they've then not paid out.

    Get it all fitted by a local reputable installer !

    Cheers, Dennis!

  4. #4
    Join Date
    Apr 2019
    Location
    Norway
    Posts
    141
    My Cars
    94 325is coupe
    thx, yup inexperienced on audio, but done some research before i installed it. only headunit to go now and can try to see if it works.

    placed the amp in same location as the stock amp, and grounded of the chassis close to the amp. will try to upload a pic to see if its ok setup. i did all new speaker wires, away from any powerwires, and trid to keep connections clean and well routed with correct gauge and fuse location besides battery.

  5. #5
    Join Date
    Apr 2019
    Location
    Norway
    Posts
    141
    My Cars
    94 325is coupe
    Quote Originally Posted by Mless5 View Post
    You'd need constant and switched 12V, ground and remote control for your aftermarket radio:

    http://wedophones.com/Manuals/BMW/
    awesome thx. only need to buy headunit now lol. been looking at Pioneer DEH S720DABAN, but out of stock everywhere.

    attached pics for my install. is location of amp and ground ok? :P
    Attached Images Attached Images
    Last edited by turbokid15; 10-15-2022 at 01:09 PM.

  6. #6
    Join Date
    Jul 2011
    Location
    Arlington, VA
    Posts
    9,772
    My Cars
    2018 BMW M240i
    Yes, you should be fine.

  7. #7
    Join Date
    Apr 2019
    Location
    Norway
    Posts
    141
    My Cars
    94 325is coupe
    thx boys, its appreciated.

    also i have another question; is there any good ground points in the trunk for the amp? maybe shock tower?

  8. #8
    Join Date
    Jul 2011
    Location
    Arlington, VA
    Posts
    9,772
    My Cars
    2018 BMW M240i
    Check the left side of the trunk just aft the of the inner fender. There should be an audio ground lug there.

  9. #9
    Join Date
    Apr 2019
    Location
    Norway
    Posts
    141
    My Cars
    94 325is coupe
    awesome, will check that out, thx.

  10. #10
    Join Date
    Apr 2019
    Location
    Norway
    Posts
    141
    My Cars
    94 325is coupe
    edit: i got sound now, but not from the tweeters. possibly low voltage from battery make the amp go into some kind of safe mode?

    ------------------------------------------------------

    so i finally got my headunit and connected everything - but got no sound.

    amp and headunit turns on and is playing.

    wires seems to be good.

    my radio harness adapter has a 12v memory wire (yellow and red), to which i connected the yellow wire from my headunit. hopefully that is correct?

    also there is an orange illumination wire on the adapter that im not using.
    Last edited by turbokid15; 10-26-2022 at 02:24 PM.

Similar Threads

  1. Ugh... I'm a n00b... headunit wiring help
    By Hugo in forum Car Audio & Electronics sponsored by Bavsound
    Replies: 26
    Last Post: 05-08-2007, 11:14 AM
  2. Got a new headunit, wiring suggestions.(long post)
    By jmejiaa in forum Car Audio & Electronics sponsored by Bavsound
    Replies: 0
    Last Post: 09-28-2006, 01:01 AM
  3. e36 headunit wiring help
    By racer00000 in forum Car Audio & Electronics sponsored by Bavsound
    Replies: 2
    Last Post: 08-06-2006, 02:46 PM
  4. E30 Headunit Wiring for Greymarket 323i?
    By rem83 in forum 1983 - 1991 (E30)
    Replies: 2
    Last Post: 07-29-2005, 10:24 AM
  5. Aftermarket headunit wire harness adaptors?
    By Drea///M3 in forum Car Audio & Electronics sponsored by Bavsound
    Replies: 4
    Last Post: 07-21-2003, 03:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •