Results 1 to 5 of 5

Thread: E60 Bouncing rpm rough Idle severe power loss

  1. #1
    Join Date
    Sep 2018
    Location
    vero beach, fl
    Posts
    5
    My Cars
    2007 525i

    E60 Bouncing rpm rough Idle severe power loss

    Hello I have a 2007 6 speed manual 525i E60 N52 with 69k miles. Starts fine, then a rough idle surges up to around 12-1500 rpms then it slowly settles.. after it settles it almost stalls but "bounces off of 500 rpms up to around 7-800 over and over.. weird part is at this point when I attempt to rev the engine it maxes out around 2000k rpms if I have the pedal on the floor.. If I attempt to drive it, it does the same thing and maxes out around 20 mph.. never going much above 2000 rpms... Last scanner broke and I'm currently waiting for another code reader to arrive in the mail so Im wondering if anyone has any experience or ideas.. recent parts Ive installed (within 10k miles) vanos solenoids, ccv valve kit, all spark plugs and ignition coils off the top of my head..
    Finally received my scan tool here are a list of fault codes.. some probably aren't relevant to the post..
    2A38- DME: valvetronic, monitoring, sluggish movement
    2A3F- DME: valvetronic, actuator motor: power supply
    2E8E- BSD, message: intelligent battery sensor (IBS) missing..
    E584- KBM: K-CAN line fault
    A554-Instrument Cluster: No Message (telephone)
    E104-KOMBI: K-CANline fault
    9CB9- LM: Battery exhausted....
    Thanks for any input here.

  2. #2
    MauiM3Mania's Avatar
    MauiM3Mania is offline Observer/Master Skeptic Moderator
    Join Date
    Jan 2002
    Location
    Central Pacific
    Posts
    10,440
    My Cars
    88M3 99M3 04M3 ITBx16
    Moved post to the model specific discussion area.
    Sat/Sun| 04M3 TiAg 69k slick-top 3 pedal
    Auto -X | 99M3 61k S50B32 284 euro 6Spd 3.91
    On The Market
    Project | 88M3 AW 43k miles


    WTB: 3.5" Eurosport/Conforti CAI

    Forum Rules

    New Member Info

  3. #3
    Join Date
    Sep 2018
    Location
    vero beach, fl
    Posts
    5
    My Cars
    2007 525i
    10-4

  4. #4
    Join Date
    Jun 2005
    Location
    Concord, NH
    Posts
    24,665
    My Cars
    08 E90M3; 99 E36M3 Turbo
    Could this be contaminated or failing vanos solenoids?

  5. #5
    Join Date
    Mar 2014
    Location
    Crown Point, IN USA
    Posts
    52
    My Cars
    99 & 10 528i
    Interesting. Very similar to my issue, but not the same codes. https://www.bimmerforums.com/forum/s...where-to-start
    No, i have not resolved the issue yet.

Similar Threads

  1. 1993 750il rough idle / possible power loss
    By thesheikh in forum 1988 - 1994 (E32)
    Replies: 21
    Last Post: 06-28-2022, 08:38 PM
  2. Replies: 62
    Last Post: 02-15-2019, 07:11 PM
  3. Rough idle n power loss. No codes
    By Jaynkay1 in forum 1996 - 2003 (E39)
    Replies: 1
    Last Post: 07-29-2012, 01:09 AM
  4. Rough Idle and power loss after idle for 60s
    By johannmuller in forum 1996 - 2003 (E39)
    Replies: 3
    Last Post: 09-13-2011, 06:20 AM
  5. Need help diagnosing severe power loss @ 5000 rpm
    By RenaissanceMan in forum 1991 - 1999 (E36)
    Replies: 1
    Last Post: 01-05-2006, 09:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •