Results 1 to 6 of 6

Thread: E36 (March of 1998) NEW to INPA and need HELP with P0500 diagnosis

  1. #1
    Join Date
    Nov 2021
    Location
    Worcester, MA
    Posts
    4
    My Cars
    1998 323ic, 2011 328ix

    E36 (March of 1998) NEW to INPA and need HELP with P0500 diagnosis

    Hello,

    I am new to coding though I have a 1998 323ic and a 2011 328ix. I have a fresh Windows 7 x64 with INPA/NCS Expert installed and a new eBay K+DCAN cable. I can connect, though choosing the correct engine of the three M52 options will give me intermittent errors, but I am able to capture this error which I am trying to diagnose. My other scanners can only tell me P0500 Vehicle Speed Sensor A (which means nothing) and Road Speed Signal D6 (also worthless to me). I've replaced both left side wheel sensors (both miserable jobs taking hours to drill out frozen sensors. Anyway, here's my error and any help would be greatly appreciated.

    214 Signal Geschwindigkeit
    Error frequency : 1 Logistic counter: 40
    Motordrehzahl 2816.00 1/min Last 354.06 mg/Hub digitaler F-Code 1 3.00 [1] Batteriespannung 13.87 V aufgetreten vor (rel. BZ) 15.10 h
    Signal nicht plausibel CARB-Fehler Fehler nach Entprellung gespeichert Fehler momentan vorhanden statischer Fehler
    Errorcode: D6 78 01 28 58 41 03 88 8E B0

    I think the last line above is where the standard OBDII code is coming from, but it doesn't tell me which wheel sensor is bad, or if the entire ABS module is bad. I have no ABS dash lights. I do have the setup for DSC+T from the factory, but, it doesn't work. The button on my center console does nothing. My speedo, odometer and cruise control all work. My fuel efficiency meter does not (well, it tries to when I start from a stop but only a slight movement).

    Thank You all!

  2. #2
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    11,227
    My Cars
    32 Cylinders
    Does the signal from the differential speed sensor make it to the dme?
    -Abel

    - E36 328is ~210-220whp: Lots of Mods.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg
    - 1999 S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 270hp/430ft-lbs
    - 2019 M2 Competition, self-tuned, 550hp

  3. #3
    Join Date
    Nov 2021
    Location
    Worcester, MA
    Posts
    4
    My Cars
    1998 323ic, 2011 328ix
    @Abel - Thanks for the reply. I presume so since it's my understanding that the speedo gets it's signal from the diff sensor. Unless I am mistaken? Quick test to confirm would be to disconnect wire and see if speedo still works.

  4. #4
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    11,227
    My Cars
    32 Cylinders
    Wiring diagram says that vehicle speed on 328is comes from right rear sensor.

    Differential sensor works if your speedo is working, yes.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg
    - 1999 S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 270hp/430ft-lbs
    - 2019 M2 Competition, self-tuned, 550hp

  5. #5
    Join Date
    Nov 2021
    Location
    Worcester, MA
    Posts
    4
    My Cars
    1998 323ic, 2011 328ix

    323ic wheel speed sensor P0500 (Road Speed Signal D6/Vehicle Speed Sensor A)

    Quote Originally Posted by 328 Power 04 View Post
    Wiring diagram says that vehicle speed on 328is comes from right rear sensor.
    When I get a chance I'll try to swap left (new) and right, though, if the left one is any indication of what to expect on the right, I'm in for a battle. Wish me luck.

    Thank you for the reply!

  6. #6
    Join Date
    Nov 2021
    Location
    Worcester, MA
    Posts
    4
    My Cars
    1998 323ic, 2011 328ix

    Update on P0500 ASC/DSC ABS Wheel Speed Sensor fun

    Quote Originally Posted by wormtownhero View Post
    When I get a chance I'll try to swap left (new) and right, though, if the left one is any indication of what to expect on the right, I'm in for a battle. Wish me luck.

    Thank you for the reply!
    Right rear wheel speed sensor has been replaced. Thus far only the passenger/right front is original.

    So, I was also replacing my dash cluster bulbs and found that both the ABS and DSC bulbs were burnt out so I replaced them and now I see the lamps are now lit. I reset my DTC codes and I will see if the P0500 comes back. Did a quick test of my brakes and I skidded under hard braking so ABS is not working at all. Also, immediately after my hard stop, the tranny slammed into gear. Might need a fluid service?

    Thanks again for all who have replied. Any new suggestions, please let me know!

Similar Threads

  1. Leaving E36 forum.Pics of new Ride.Thanks for your help
    By BiMmEr JoN in forum 1991 - 1999 (E36)
    Replies: 18
    Last Post: 02-21-2004, 03:16 AM
  2. 1998 M3 with 14K miles, need help with appraisal please!
    By lopatag in forum 1992 - 1999 M3 (E36)
    Replies: 19
    Last Post: 10-16-2003, 01:18 AM
  3. new set of rims : need help
    By donchichi in forum 1983 - 1991 (E30)
    Replies: 0
    Last Post: 09-28-2003, 01:11 AM
  4. Put new HeadGasket now leaking?Need Help!!!
    By LUIS in forum 1992 - 1999 M3 (E36)
    Replies: 9
    Last Post: 08-04-2003, 04:09 PM
  5. new owner!! now i need help
    By Canatro in forum 1983 - 1991 (E30)
    Replies: 2
    Last Post: 07-16-2002, 02:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •