Results 1 to 14 of 14

Thread: P1525 Code Help

  1. #1
    Join Date
    Dec 2014
    Location
    Dallas
    Posts
    32
    My Cars
    1998 M3 Sedan

    P1525 Code Help

    I searched on this forum about this code. This is on a 98 M3 (S52). I removed my vanos solenoid and tested it by applying 12v and ground. The pin popped out as it should. Cycled it several times. Looks like this is working.

    Is the next thing to test the Cam Position Sensor?

  2. #2
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    4,283
    My Cars
    EXOTICS
    Remove and clean it.
    If It was a faulty CPS it would display a code for it.
    Last edited by MIKYZZ4; 04-13-2021 at 10:39 PM.

  3. #3
    Join Date
    Feb 2002
    Location
    Orlando, FL
    Posts
    8,873
    My Cars
    Turbo 97 E36 M3, 99 M3
    Check your oil level. Your oil pressure could be low and causing an issue with activating the VANOS. Clear the code and see if it comes back.
    1997 Arctic Silver/Black M3
    CES Stage IV (651rwhp/615rwtq @ 24 psi)

    1999 Techno Violet/Dove M3
    Auto/Convertible and staying stock!

  4. #4
    Join Date
    Dec 2014
    Location
    Dallas
    Posts
    32
    My Cars
    1998 M3 Sedan
    BMWManiac was correct. I was low on oil. End of dipstick was dry. Soon as I added a qt. The CEL went away. I am at overdue for oil change. Plan on getting one done this Friday.

  5. #5
    Join Date
    Feb 2002
    Location
    Orlando, FL
    Posts
    8,873
    My Cars
    Turbo 97 E36 M3, 99 M3
    Quote Originally Posted by blkmz3 View Post
    BMWManiac was correct. I was low on oil. End of dipstick was dry. Soon as I added a qt. The CEL went away. I am at overdue for oil change. Plan on getting one done this Friday.
    Yah! What do i win?
    1997 Arctic Silver/Black M3
    CES Stage IV (651rwhp/615rwtq @ 24 psi)

    1999 Techno Violet/Dove M3
    Auto/Convertible and staying stock!

  6. #6
    Join Date
    Dec 2014
    Location
    Dallas
    Posts
    32
    My Cars
    1998 M3 Sedan
    Can venmo/zelle a few bucks lol. What oil weight do you run? BTW I have an arctic silver sedan

    I currently run Mobil 0W40 but thinking about doing Liqui Moly 5w40.

  7. #7
    Join Date
    Feb 2002
    Location
    Orlando, FL
    Posts
    8,873
    My Cars
    Turbo 97 E36 M3, 99 M3
    Quote Originally Posted by blkmz3 View Post
    Can venmo/zelle a few bucks lol. What oil weight do you run? BTW I have an arctic silver sedan

    I currently run Mobil 0W40 but thinking about doing Liqui Moly 5w40.
    No worries, glad I can help. I run Rotella T6 (5w40) since I live in Florida. I think you're fine with those....
    1997 Arctic Silver/Black M3
    CES Stage IV (651rwhp/615rwtq @ 24 psi)

    1999 Techno Violet/Dove M3
    Auto/Convertible and staying stock!

  8. #8
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    4,283
    My Cars
    EXOTICS
    My usual fill is Castrol 5W40 Full Synthetic European Formula.
    IIRC, it was rated better than Mobile1.

  9. #9
    Join Date
    Dec 2014
    Location
    Dallas
    Posts
    32
    My Cars
    1998 M3 Sedan
    So I was low on oil again after the last oil change. This time I got both P1519 and P1525. I topped off the oil. The CEL went off for a day but came back. It has been on for a few days now. I do not have any loss of low end torque or any Cam Position Sensor codes. Mileage hasn't been affected.

    Should I go and replace the VANOS solenoid? Why are these so expensive new? $586 are they serious? Am I looking at a vanos rebuild?

  10. #10
    Join Date
    Jul 2012
    Location
    Atlanta, Georgia
    Posts
    831
    My Cars
    ∞FX37,M3a/4,94 332
    You might want to remove the camshaft position sensor, slice open a small section to see if the wires inside look similar to this.
    Screen Shot 2021-10-25 at 8.15.31 PM.jpg
    [IMG][/IMG]

  11. #11
    Join Date
    Jan 2006
    Location
    Oakhurst, CA
    Posts
    6,079
    My Cars
    96 M3 97 M3 98 M3 99 M3
    Camshaft position sensor code does not have to pop for the sensor to be screwed up. What AJLM34A posted is common with every original cam sensor still installed in an engine nowadays.

    You must use a Genuine BMW replacement. Do not use anything advertised as OE or OEM unless it specifically states Genuine BMW. This sensor is known to be defective with ALL other brands.

  12. #12
    Join Date
    Dec 2014
    Location
    Dallas
    Posts
    32
    My Cars
    1998 M3 Sedan
    So I'm about done with this car. May be the last straw this time. Need to find a daily driver.

    I installed a reman VANOS solenoid from Dr. VANOS which addressed the P1519 and P1525. Few days ago my transmission light went on and threw a P0740. I have the 5spd Auto. I'm at almost 150k so I had planned to do the transmission fluid soon. I researched and that code is related to the TCC solenoid (lock-up). The light went off the same day and I kept driving it to work.

    This morning I stop by Chik Fil A. After I get my food and try to start the car. The car sputters and shuts down. It cranks but would not start. No CELs. It didn't seem to be a low battery issue. I checked the fuses for any blown ones but didn't see any. I disconnected the neg battery and tried to start the car but no luck. I'm thinking either fuel related or possibly crank position sensor or cam position sensor. Something is not letting the engine get fuel. Called the tow truck and got it back to the house. It was fun getting the car out in a busy Chik Fil A drive-thru parking lot.

    I've done a lot of repairs since I got this car and I cannot go a month without something else popping up.

  13. #13
    Join Date
    Dec 2014
    Location
    Dallas
    Posts
    32
    My Cars
    1998 M3 Sedan
    *Update

    After doing some troubleshooting, it was my fuel pump. I checked the fuse and relay. Then I checked for voltage at the fuel pump connector. It was getting 12v. I put in a new fuel pump. Car started.

  14. #14
    Join Date
    Jun 2012
    Location
    San Antonio, TX
    Posts
    264
    My Cars
    1995 BMW M3 Coupe
    Thanks for the update.


    -rb

Similar Threads

  1. VANOS P1519 & P1525 code help
    By Estoril4dr in forum 1992 - 1999 M3 (E36)
    Replies: 9
    Last Post: 04-24-2012, 07:07 PM
  2. check engine code.p1519 & p1525..please help
    By bmwbeau in forum 1991 - 1999 (E36)
    Replies: 3
    Last Post: 06-20-2010, 03:53 AM
  3. M3 check engine codes help: p1519 & p1525
    By bmwbeau in forum 1992 - 1999 M3 (E36)
    Replies: 2
    Last Post: 03-21-2010, 11:03 PM
  4. Stock Raido Code Help
    By cleoent in forum Car Audio & Electronics sponsored by Bavsound
    Replies: 9
    Last Post: 01-24-2002, 03:10 AM
  5. stock radio code help
    By cleoent in forum Car Audio & Electronics sponsored by Bavsound
    Replies: 1
    Last Post: 01-19-2002, 04:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •