Results 1 to 4 of 4

Thread: Mysterious CEL

  1. #1
    Join Date
    Dec 2020
    Location
    Los Angeles, CA
    Posts
    5
    My Cars
    2013 ActiveHybrid 5

    Question Mysterious CEL

    Hi Everyone.

    First post on the forums after lurking for a while.

    I own a 2013 ActiveHybrid 5. She has been good to me for years. Though a mysterious CEL has come on and my normal mechanics have no idea.

    The generic code is P018B. Which lead to a fuel pressure sensor fault. Advanced scanning showed it was "19401A Fuel tank temperature-pressure sensor, plausibility pressure too high"

    They replaced the fuel pressure sensor and cleared the error. The replacement sensor was already calibrated.

    A few days later, the code came back and continues to comes back anywhere from 80 to 300 miles after being cleared.

    They have no idea what to do next as there are no other indications on the car and it's modules.

    Has anyone encountered this error code before in their car?

    Mine is basically an electrified version of the 535i.

    Kind regards

    -Z

  2. #2
    Join Date
    Jan 2016
    Location
    Ca
    Posts
    6,981
    My Cars
    2001 525it
    The I would find a shop that uses the ista bmw diagnostic computer and see what happens

  3. #3
    Join Date
    Dec 2020
    Location
    Los Angeles, CA
    Posts
    5
    My Cars
    2013 ActiveHybrid 5
    Ended up downloading ISTA+ and buying a new cable.

    I also got a new gas cap. Will try that first and if doesn't work. I'll do an ISTA sensor calibration test.

    I'm collecting the car today from the shop. Just had the oil filter housing gasket changed as it has a very minor leak and I dont want it getting worse.

    IMG_2099.jpg

  4. #4
    Join Date
    May 2022
    Location
    Indiana
    Posts
    1
    My Cars
    2013 AH3
    Did you ever get this resolved? I just got the same code on my 2013 active hybrid 3

Similar Threads

  1. Rough Idle, CEL mystery
    By straight six m3 in forum 1991 - 1999 (E36)
    Replies: 3
    Last Post: 06-28-2014, 09:27 AM
  2. 2001 E39 530i CEL Mystery - Repost from broken thread
    By AntrhaciteE39 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 9
    Last Post: 05-03-2013, 09:01 PM
  3. 2001 530i CEL Mystery
    By AntrhaciteE39 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 3
    Last Post: 04-30-2013, 12:59 PM
  4. Got a CEL mystery
    By WontPassMe in forum 1992 - 1999 M3 (E36)
    Replies: 4
    Last Post: 12-03-2011, 02:47 AM
  5. CEL light on... the elusive P1188 and P1189 mystery...
    By jemarin71 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 24
    Last Post: 07-13-2008, 08:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •