Results 1 to 9 of 9

Thread: Z4 2006 top unlatches...but doesnt

  1. #1
    Join Date
    Oct 2020
    Location
    Florida USA
    Posts
    3
    My Cars
    BMW Z4 2006 3.0

    Z4 2006 top unlatches...but doesnt

    Hey im having some top problems on my BMW z4 3.0. When i press the convertible button, the latch motor unlatches (or sounds like it) but the top is still stuck on the windshield. I hold the button for about 30 seconds until it finally comes up and the top goes down automatically. Also when coming up the top starts to stop and lag, but still ends up going up all the way automatically(no manual assist) and lands hard if i don't help it get back on the windshield slowly. My biggest problem is the unlatching, im sure the lagging probably is the hydraulic motor but why does it take forever to come off the windshield?

  2. #2
    Join Date
    Mar 2011
    Location
    Southwest, Ohio
    Posts
    210
    My Cars
    2007 Z4 3.0Si
    Quote Originally Posted by bimmerkevin View Post
    Hey im having some top problems on my BMW z4 3.0. When i press the convertible button, the latch motor unlatches (or sounds like it) but the top is still stuck on the windshield. I hold the button for about 30 seconds until it finally comes up and the top goes down automatically. Also when coming up the top starts to stop and lag, but still ends up going up all the way automatically(no manual assist) and lands hard if i don't help it get back on the windshield slowly. My biggest problem is the unlatching, im sure the lagging probably is the hydraulic motor but why does it take forever to come off the windshield?
    Maybe lube up the mechanisms?
    I was informed by one of the members on this forum to use 3in1 multi purpose lubricant on all the swivel points on my soft top.
    Picked up a bottle with telescoping tip at my local Walmart for a few dollars.

  3. #3
    Join Date
    Oct 2020
    Location
    Florida USA
    Posts
    3
    My Cars
    BMW Z4 2006 3.0
    Quote Originally Posted by cdsweet View Post
    Maybe lube up the mechanisms?
    I was informed by one of the members on this forum to use 3in1 multi purpose lubricant on all the swivel points on my soft top.
    Picked up a bottle with telescoping tip at my local Walmart for a few dollars.
    I will try that tonight, what do you mean by swivel points? do you mean where the latches go in the windshield?

  4. #4
    Join Date
    Mar 2012
    Location
    CT
    Posts
    35
    My Cars
    Z4
    Have you try manually pulling the bowden cable and see if there is free movement after it unlatches.. you may have other issues.. if the motor isn't relocated.. you wont be able to tell if the pump has fluid or not.

  5. #5
    Join Date
    Oct 2012
    Location
    Victoria BC Canada
    Posts
    279
    My Cars
    2004 Z4, 1700 Nomad MC
    Yes... lube the rollers where it latches on to the top of the windshield... They need to roll freely. Donít use WD40... itís a penetrating oil not a lubricating oil.


    Sent from my iPhone using Tapatalk

  6. #6
    Join Date
    Oct 2020
    Location
    Florida USA
    Posts
    3
    My Cars
    BMW Z4 2006 3.0
    Sorry to sound uninformed, is the bowden cable the red cable in the front of the trunk? It is not relocated, im thinking it may be low on fluid or leaking somewhere. When we put grease on the swivel points it felt a lil wet like something leaked.

    - - - Updated - - -

    I just did that but it still takes a while to come down, i think its low on hydrolic fluid but i dont think that would make the top have latching problems

    - - - Updated - - -

    https://youtu.be/sT0kk6k-2vg


    Here is a link to how it looks. you can see hes holding the button for about 15 seconds before it starts going down. Then going up it lags a little half way up

  7. #7
    Join Date
    Sep 2018
    Location
    Mechanicsburg, PA USA
    Posts
    64
    My Cars
    2003 2.5 BMW Z4
    Once your top came off the frame of the windshield it came down in less than 10 seconds. Conversely, it also closed in less than 10 seconds. I would say that your motor/Pump, fluid level and hinge lifters are all fine.

    However, you more than likely have the same issue as this posting which causes issues releasing the top from the frame :https://www.bimmerforums.com/forum/s...vertible-motor


    Please see attached video https://www.youtube.com/watch?v=otCbHnwZ-Ig
    Last edited by JAS1169; 10-17-2020 at 03:54 PM.

  8. #8
    Join Date
    Oct 2012
    Location
    Victoria BC Canada
    Posts
    279
    My Cars
    2004 Z4, 1700 Nomad MC
    While it may be the plastic gear... lube the latching rollers. If they donít roll freely, they produce a tremendous amount of resistance.

    Lube them anyway as a maintenance item.


    Sent from my iPhone using Tapatalk

  9. #9
    Join Date
    Mar 2012
    Location
    CT
    Posts
    35
    My Cars
    Z4
    Theres no way to know if you're low in fluid till you pull it out. From the trunk is the easiest. Mine spools for a while before releasing when there is air in the line. Only happen after a motor swap. After fluid is right level and air is purged, it does not have delay

Similar Threads

  1. 2006 Z4 soft top won't come up: center latch when down
    By larrycad in forum E85,E86 Common Problems and DIY Fixes
    Replies: 0
    Last Post: 07-21-2018, 09:26 AM
  2. 2006 Z4 soft top replacement
    By chandan in forum General BMW and Automotive Discussion sponsored by Intercity Lines
    Replies: 2
    Last Post: 08-28-2015, 03:16 PM
  3. Replies: 20
    Last Post: 07-14-2015, 05:01 PM
  4. 03 Z4 Convertible Top Won't Go Down But Unlatches
    By mrqez4 in forum 2002 - 2008 Z4 (E85, E86)
    Replies: 2
    Last Post: 07-14-2011, 09:08 AM
  5. '06 Z4 Convertible Top Problem - Refuses to unlatch
    By sagdast in forum 2002 - 2008 Z4 (E85, E86)
    Replies: 2
    Last Post: 10-21-2007, 04:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •