Results 1 to 4 of 4

Thread: Green 540i MSport Build Thread (EDC + OEM)

  1. #1
    Join Date
    May 2019
    Location
    boston
    Posts
    13
    My Cars
    1995 540i M, 1990 325ix

    Green 540i MSport Build Thread (EDC + OEM)

    Hey folks. Thought Id start a build thread for my new to me Oxford Green 1995 M-Sport. Pretty good shape, almost no rust. Engine runs like a dream. The main things Ill be working on in the near future is getting the EDC back up and running + some paint and interior revitalization. Never done one of these so go easy on me!
    Attached Images Attached Images

  2. #2
    Join Date
    May 2019
    Location
    boston
    Posts
    13
    My Cars
    1995 540i M, 1990 325ix
    Did the accumulators today. Picked up a new set of Febi made in ermany ones from Bimmerworld. The ones on there ones were 16 years and 50k miles old and had blown nitro bladders.

    I got a good look at the rear EDC shocks while I was in there. Overall look quite solid with no wetness or drips near the solenoids. One thing that did worry me was a funky seal on the drivers side shock. Could this be the solenoid error root?

    Not a hard job but not super pleasant due to tight clearances and pentosin drips. Haven’t put a lot of miles on it but not seeing much of a difference in feel of the car. On to the next checklist item I suppose.

    EF0C3262-4ABB-48AA-BB11-CA10CB20174F.jpg2831C7DF-BAE4-4CA5-ACB9-AA4EB9AE6FBE.jpg9EF12A3A-69F6-4E82-9EF4-00F84DFDFF1C.jpg0A8B3484-331F-4A27-8D3D-83E35E55CF33.jpg
    Attached Images Attached Images

  3. #3
    Join Date
    Aug 2019
    Location
    Seattle, WA
    Posts
    232
    My Cars
    1995 BMW 540i 6-speed
    Sweet! Glad you started one. Looking forward to tuning in.


    Sent from my iPhone using Tapatalk

  4. #4
    Join Date
    May 2019
    Location
    boston
    Posts
    13
    My Cars
    1995 540i M, 1990 325ix
    So I've started to get a bunch of random CCM errors (ESD Regelt, Brake Light, ASC, etc.) that don't seem to correspond to anything. According to Shogun and others http://twrite.org/shogunnew/diagnosis/ccm.html, this seems to be symptom of a failing CCM. I'm going to take a look at repairing the unit I have but it looks significantly different than what most of the write-ups reference.


    The unit I have is part 61351388097 (for '95 3.8 M5 / 4.0 M-Sport) and has a blue box whereas standard E34/E32's seem to use 61351388098 with a black box. I'm wondering about the interoperability for these two PN's. Does anyone have a 3.8 or M-sport with Nurburgring package and has used 61351388098? Or has anyone switched between CCM's on another platform?

    IMG_1534.jpg

Similar Threads

  1. Uber's 540i/6 Build Thread
    By Uber Soldat in forum 1988 - 1996 (E34)
    Replies: 35
    Last Post: 05-02-2019, 05:01 AM
  2. MSport Build Thread
    By BruinBimmer in forum 1988 - 1996 (E34)
    Replies: 108
    Last Post: 03-30-2015, 01:27 PM
  3. Jamesthebikeguy's 2000 540i/6 Build thread
    By jamesthebikeguy in forum 1996 - 2003 (E39)
    Replies: 139
    Last Post: 02-02-2015, 10:39 PM
  4. Grant500's 1995 E34 540i/6 Build Thread
    By Grant500 in forum 1988 - 1996 (E34)
    Replies: 279
    Last Post: 09-22-2014, 01:39 AM
  5. Mike's Official 1995 Calypso E34 540i/6 build thread
    By MikE34x540i in forum 1988 - 1996 (E34)
    Replies: 13
    Last Post: 09-30-2013, 02:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •