Results 1 to 5 of 5

Thread: Leaking air suspension, not bad airbags

  1. #1
    Join Date
    Dec 2008
    Location
    Avondale Arizona
    Posts
    183
    My Cars
    540iT 840Ci 850i 6-Spd

    Leaking air suspension, not bad airbags

    I have a 2000 540iT touring with air bag rear suspension, and about 30 minutes after running, the back of the car sits right down with the wheels right up in the wheel wells. I have had this issue before with other Touring BMW's, and always fixed it with new air bags, but on this car, new air bags didn't fix the problem.
    I exposed all the air line plumbing and sprayed soapy water onto all of them, even the lines going into the pump and the large pipes going to the two reservoirs under the car, and I cannot find any leaks, either with the pump running or the car turned off.
    I tried to look through the other postings on this site, but couldn't find any mention of the problem. Does anyone have any suggestions?

  2. #2
    Join Date
    Apr 2017
    Location
    London, UK
    Posts
    125
    My Cars
    E30 Turbo, E39 530d Tour
    Quote Originally Posted by Rich8 View Post
    I have a 2000 540iT touring with air bag rear suspension, and about 30 minutes after running, the back of the car sits right down with the wheels right up in the wheel wells. I have had this issue before with other Touring BMW's, and always fixed it with new air bags, but on this car, new air bags didn't fix the problem.
    I exposed all the air line plumbing and sprayed soapy water onto all of them, even the lines going into the pump and the large pipes going to the two reservoirs under the car, and I cannot find any leaks, either with the pump running or the car turned off.
    I tried to look through the other postings on this site, but couldn't find any mention of the problem. Does anyone have any suggestions?
    Is there an issue with the pump expelling all the air back into the tank? A malfunction of the electrics rather than the bags, assuming the bags still go back up and therefore arenít loosing pressure?


    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Dec 2006
    Location
    West of Boston, MA
    Posts
    463
    My Cars
    2001 BMW 540iT/6
    I reckon the pump has to have a one way valve somewhere too no?


    Sent from my iPhone using Tapatalk

  4. #4
    Join Date
    May 2018
    Location
    Florida
    Posts
    194
    My Cars
    '99 E39 528iT
    When i bought my car the SLS was inactive. The air springs were both completely shot and the compressor looked as though it had been submerged in water for some time. I installed new air springs, compressor and shocks. When i replaced the compressor, I noticed the solenoid orings were warn, but installed them anyway. The initial power up and I still didnt have any air... Until after i did a hard reset with the car. It holds air for about three days, then starts going down. I do have new solenoid with orings waiting to go in. Hopefully that resolves my issue.

  5. #5
    Join Date
    Dec 2006
    Location
    West of Boston, MA
    Posts
    463
    My Cars
    2001 BMW 540iT/6
    I think youíre on to something...


    Sent from my iPhone using Tapatalk

Similar Threads

  1. 2001 X5 3.0 Air Suspension - broken or not?
    By cjphoto in forum 1999+ X5, X6 (E53, E70, E71, F15, F16)
    Replies: 2
    Last Post: 10-02-2016, 01:31 PM
  2. Replies: 6
    Last Post: 07-27-2016, 01:07 AM
  3. Touring sitting slightly crooked, bad air suspension?
    By dannyzabolotny in forum E39 Touring / Wagon
    Replies: 20
    Last Post: 07-21-2016, 12:03 AM
  4. Obvious Leak in Touring Air Suspension - Where to Look First?
    By BimmerM3inGA in forum 1996 - 2003 (E39)
    Replies: 12
    Last Post: 05-31-2011, 12:06 AM
  5. Slow leak in air suspension
    By KirkWolf in forum 1996 - 2003 (E39)
    Replies: 2
    Last Post: 01-03-2011, 12:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •