Results 1 to 2 of 2

Thread: R53 cruise control not working after transaxle swap

  1. #1
    Join Date
    Apr 2010
    Location
    Tavernier, Florida
    Posts
    1,221
    My Cars
    '99 2.8&Mcoupe, '03 Mini

    R53 cruise control not working after transaxle swap

    I had a bearing go south in my '03 Cooper S 6 speed. I swapped in a a 6 speed from an '05 R53. Now the cruise control won't set the speed. The green light activates, but the car won't engage when setting the speed.
    I suspect the slightly different gear ratio is the cause, but is there an easy work-around or coding that will get the cruise control operating?
    -Donny

  2. #2
    Join Date
    Jan 2016
    Location
    Ca
    Posts
    4,490
    My Cars
    2001 525it
    I don't think gear ratio would have anything to do with it it's probably monitored thru wheel speed and engine inputs, I would scan the car for faults or some thing is not plugged in right

Similar Threads

  1. Replies: 16
    Last Post: 03-11-2013, 09:22 PM
  2. Cruise control not working after 5 speed swap
    By 88e30vert in forum 1983 - 1991 (E30)
    Replies: 7
    Last Post: 10-01-2012, 08:52 PM
  3. Traction Control not working after 5 speed swap
    By Dinglenutz in forum 1988 - 1996 (E34)
    Replies: 1
    Last Post: 09-25-2009, 05:33 PM
  4. MPG Gauge not working after Motor Swap - what to do?
    By Ahheck01 in forum 1991 - 1999 (E36)
    Replies: 16
    Last Post: 07-18-2006, 06:32 PM
  5. HELP! cruise control not working-speed sensor not working
    By BiMmEr JoN in forum 1991 - 1999 (E36)
    Replies: 4
    Last Post: 01-28-2004, 07:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •