Results 1 to 2 of 2

Thread: iDrive issue

  1. #1
    Join Date
    Jun 2017
    Location
    Ohio
    Posts
    1
    My Cars
    2009 BMW X5d

    iDrive issue

    So I have a strange iDrive CCC issue. Did an ISTA scan and everything is Green on the MOST bus except for the Sat module which I have bypassed.


    The menu lets me get into the nav and climate screen as well as the middle button push down for service info and settings. No Entertainment or Communication selection possible.


    This also only works with ignition on / no start.


    After starting, screen is locked. Only way to play radio is to use voice command and it will switch to the radio stations and then I can select stations.


    Any ideas?


    CCC ISTA scan shows no faults.

  2. #2
    Join Date
    Jan 2016
    Location
    Ca
    Posts
    3,287
    My Cars
    2001 525it
    Every thing goes thru the ccc so it could have an internal issue you would have to do more dx or take it to the hsop

Similar Threads

  1. idrive issues....
    By SchnellM3 in forum 1999+ X5, X6 (E53, E70, E71, F15, F16)
    Replies: 4
    Last Post: 12-21-2016, 11:03 PM
  2. E65 iDrive issue... I think...
    By bimmerguy406 in forum 2002 - 2008 (E65, E66)
    Replies: 5
    Last Post: 02-25-2013, 01:25 AM
  3. iDrive issue
    By 2k8 535 in forum 2004-2010 (E60,E61)
    Replies: 12
    Last Post: 11-16-2012, 04:46 AM
  4. 2004 E60 No Nav idrive issues / Crackle in Speakers
    By scotts007 in forum 2004-2010 (E60,E61)
    Replies: 1
    Last Post: 03-23-2012, 12:53 PM
  5. iDrive issues in 08 535i
    By ThEnder in forum 2004-2010 (E60,E61)
    Replies: 3
    Last Post: 12-20-2007, 07:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •