Results 1 to 5 of 5

Thread: Batt/ Possible Electrical Issue HELP!!!!

  1. #1
    Join Date
    Jul 2018
    Location
    Northern California
    Posts
    76
    My Cars
    2004 BMW 525I

    Batt/ Possible Electrical Issue HELP!!!!

    OK I have a 2004 BMW 525i and since buying the car i have had to deal with this issue, so the batt(according to a cig lighter charger with a digital volt read out on it) rarely goes higher than 13.6-8V while the car is running, im unsure if thats a sign of anything or not, but the issue i am having is that when i turn the car off if i use the inside dome lights, leave door/doors open for a bit too long, or anything else that would pull a lil power from batt like listing to radio, running fan/heater for anymore than 10mins if even that long without starting it for a few mins the batt will not completely die but will no have enough power to start the car. There hasnt been any codes or anything else pointing to the cause of the issue, from the lil i know and can tell the altenator is working fine its just that the batt will not hold a charge for very long if the car is drawing from it, however if i only arm/disarm the alarm and quickly open/close doors the batt will be fine for a day or two at least enought to start the car. I am not sure how old the batt is or anything else about it but im wondering what other people think about this issue along with any ideas on what i should try doing to fix the issue, i was thinking about going to buy a batt but just wanted to make sure that wont be a waste of $$ because it was fine. o also the last time i had it checked at autozone or some similar store for free they tp;d me the batt was fine however it didnt look like the guy checking it really knew too much about ehst he was doing lol.

    Anyone got any ideas?

  2. #2
    Join Date
    Mar 2008
    Location
    Coquitlam, BC, Canada
    Posts
    183
    My Cars
    2003 530i
    Your car is telling you it needs a new battery. Replace it before it leaves you stranded.

    Sent from my LG-H915 using Tapatalk


  3. #3
    Join Date
    Jul 2018
    Location
    Northern California
    Posts
    76
    My Cars
    2004 BMW 525I
    i got new one now need to do coding. i cant register it because i get a script processing error with inpa now an a voltae suppy wrror with ista, imgoing to try changing the coding of cas2 module to the right battery and see if that helps with being able to register it

  4. #4
    Join Date
    Jan 2016
    Location
    Ca
    Posts
    3,263
    My Cars
    2001 525it
    Just call up an independent shop and have them do it

  5. #5
    Join Date
    Jul 2018
    Location
    Northern California
    Posts
    76
    My Cars
    2004 BMW 525I
    im good ill learn how to do it myself like i have everything else on it, im currently in process of changing the headliner to black so i havent had chance to try an reinstall of inpa or ista

Similar Threads

  1. Ned help with some possible electrical issues
    By Redsoxfan801 in forum 1983 - 1991 (E30)
    Replies: 2
    Last Post: 04-19-2014, 04:44 PM
  2. Possible Electrical Issue? Need some help.
    By E36Nick in forum 1991 - 1999 (E36)
    Replies: 1
    Last Post: 01-18-2010, 11:19 PM
  3. 740iL electrical issues... HELP!
    By JLSjr in forum 1988 - 1994 (E32)
    Replies: 6
    Last Post: 01-30-2007, 07:17 PM
  4. Help!! Electrical Issue Help!!
    By PALELLA in forum 1992 - 1999 M3 (E36)
    Replies: 5
    Last Post: 05-07-2006, 11:39 PM
  5. Electrical issues - help with 325is.....
    By S.Lang in forum 1983 - 1991 (E30)
    Replies: 5
    Last Post: 09-03-2004, 04:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •