Results 1 to 2 of 2

Thread: Weird noise after valve cover gasket replacement

  1. #1
    Join Date
    Apr 2019
    Location
    Lehighton Pa
    Posts
    1
    My Cars
    2007 BMW X3

    Weird noise after valve cover gasket replacement

    So I just bought this car from a used car dealer and was told that everything is good to go and up to date. Not even a month and I notice I'm leaking oil from the valve cover gasket. I changed it and now I have a weird popping noise and a rough idle. When its in drive, it bucks and dies. Any clues what it could be? I checked every wire and every bolt. Everything is tight and connected

  2. #2
    Join Date
    Mar 2019
    Location
    ATLANTA GA
    Posts
    87
    My Cars
    456 X3s
    Quote Originally Posted by Fireman541 View Post
    So I just bought this car from a used car dealer and was told that everything is good to go and up to date. Not even a month and I notice I'm leaking oil from the valve cover gasket. I changed it and now I have a weird popping noise and a rough idle. When its in drive, it bucks and dies. Any clues what it could be? I checked every wire and every bolt. Everything is tight and connected
    what model, year, number of miles on the clock and did you get a pre-purchase inspection?
    New spark plugs?
    Clean idle control valve?
    Clean throttle body?
    Clean the MAF sensor?
    Is there a tare/rip in the rubber intake boot...
    i have found most BMW repair jobs can be exhausting...did you get fatigued and not make sure all connections were complete and secure.
    Finally, what codes does the scan tool you used reveal.

    Sent from my SM-J727T using Tapatalk

Similar Threads

  1. Need help. My X5 running really rough after valve cover gasket replacement.
    By jfclk33 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 7
    Last Post: 05-10-2013, 07:33 PM
  2. P1161 After Valve Cover Gasket Replacement
    By knite75 in forum 1996 - 2003 (E39)
    Replies: 14
    Last Post: 08-13-2012, 01:04 PM
  3. Replies: 15
    Last Post: 09-05-2011, 11:59 PM
  4. ABS and BRAKE Lighton after valve cover gasket replacement
    By devoulley in forum 1996 - 2003 (E39)
    Replies: 2
    Last Post: 02-17-2011, 07:21 PM
  5. Car won't start after valve cover gasket replaced
    By e39hamann in forum 1996 - 2003 (E39)
    Replies: 20
    Last Post: 05-21-2009, 01:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •