Results 1 to 9 of 9

Thread: New 6 series owner

  1. #1
    Join Date
    May 2012
    Location
    Gallipolis Ohio
    Posts
    136
    My Cars
    2007 650i coupe

    New 6 series owner

    Well, I'm back. Sold my 840 couple years ago and thought I wanted a Challenger so I bought a new SRT 392 6 speed Challenger. It was very fast and I liked it but I missed my BMW's so I sold the Challenger last week and picked up a 2007 650i. I drove it back home from Indiana (5 hours ) today. Drove super , runs good but it has one problem,, the idrive doesn't work. The screen comes on and I can switch between the modes( intertainment, nav, communications and climate ) but that's it the up and down motion works but not the rotary part and I have no sound, can't do anything basically. I have no experience with this i drive what so ever so please someone help me out on this. Any help would be appreciated greatly.

    Glad to be back.

  2. #2
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    Sounds like you may need to replace the rotary knob assembly. I have no experience with that... but surely someone here does!
    Is yours a convertible?
    Welcome back and good luck.

  3. #3
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    if the sound is out it could be the HD antenna in the trunk. Its in the left side of the trunk under the paneling. Its the bottom one of the three. You can just jump it and you will have sound again.

    I live in Indiana (Indianapolis) where did you get your car? Specs on it? Photos?

    Welcome.
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

  4. #4
    Join Date
    May 2012
    Location
    Gallipolis Ohio
    Posts
    136
    My Cars
    2007 650i coupe
    I bought it in Sheridan. Not far from Indy. maybe 25-30 miles? Little one guy European auto lot.He has Mercedes, Porsche,BMW's and others, mostly Porsche.

    I think it's just a base 650i, haven't learned a lot about it yet, getting tires tomorrow, fixed the loose door panels today, polished the headlight lenses, changed the oil and filter.
    The problems it has are :; drivers window only goes up or down inch at a time, have to push the button 50 times to get the window down or up.
    The idrive comes on, but has no sound , can select what i want as far as entertainment, nav, communications and climate but thats far as it will go. tried the hard reset ,, no go. The guy told me he thought the CCC was bad.
    Needs a thermostat, he included a new one.
    Air cond doesn't cool, sounds to me like the compressor bearings are just about to go, I'll ut in a new one and charge it.
    Just needs a good cleaning.
    It seems to run good and drives nice except for needing new tires, paint is nice, interior is nice also ,just dirty.
    I just bought it for a daily driver car so I don't have to put a bunch of miles on my new truck.

  5. #5
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    If it is the CCC, here is a link to a reprair service....http://www.bmwlogicseven.com/?page_id=4123.

  6. #6
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    sounds like you have your work cut out for you but shouldn't be too bad.

    I have an extra set of the Silver interior trim if you need any of those parts.
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

  7. #7
    Join Date
    May 2012
    Location
    Gallipolis Ohio
    Posts
    136
    My Cars
    2007 650i coupe
    I got the sound working. There was a missing factory installed MOST jumper behind the glovebox. Not sure why anyone would have removed it but they did for some reason. The missing jumper opened the MOST circuit and stopped the CCC from getting a return signal. The control wheel still is working iffy but everything else works now. I have a stereo and all other functions.If any of the modules fail the MOST circuit is broken and nothing works.

  8. #8
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    good find.
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

  9. #9
    Join Date
    May 2012
    Location
    Gallipolis Ohio
    Posts
    136
    My Cars
    2007 650i coupe
    Everything works except the idrive controller rotation doesn't work right. You have to spin it 30 times to get it to move the curser one place. The press part works ok as does the left ,right,forward and back, just the rotating part is not working right. My question ,, if I buy another idrive controller will it have to be coded? if so I have been researching how to code using NCS expert and would like to try it myself but what module is the idrive controller in? I already tried cleaning it with contact cleaner and that didn't work. Any coding experts out there?

    - - - Updated - - -

    Quote Originally Posted by Venom13132 View Post
    sounds like you have your work cut out for you but shouldn't be too bad.

    I have an extra set of the Silver interior trim if you need any of those parts.
    Thanks but mine has the woodgrain trim and it's in pretty good shape.

Similar Threads

  1. New member to the 7 series owner club!!!
    By ducky8888 in forum 1995 - 2001 (E38)
    Replies: 20
    Last Post: 12-30-2007, 11:36 AM
  2. New 5 series owner
    By bigvedo in forum 1996 - 2003 (E39)
    Replies: 15
    Last Post: 09-20-2006, 02:29 PM
  3. New 3 series owner!
    By turbotuli in forum 1991 - 1999 (E36)
    Replies: 6
    Last Post: 09-14-2006, 05:03 PM
  4. New 5 series owner, just wanted to say hi!
    By mikeinsanmarcos in forum 1988 - 1996 (E34)
    Replies: 18
    Last Post: 10-30-2003, 11:46 PM
  5. New 3 Series owner
    By Gregg in forum 1999 - 2006 (E46)
    Replies: 5
    Last Post: 04-20-2003, 09:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •