Results 1 to 4 of 4

Thread: BMW E66 - 2007 750Li Engine Stall On Hard Stops

  1. #1
    Join Date
    Jan 2015
    Location
    Suffolk, Virginia
    Posts
    9
    My Cars
    2007 BMW 750 Li

    Smile BMW E66 - 2007 750Li Engine Stall On Hard Stops

    Good Day All,

    BMW E66 - 2007 750Li Engine Stall On Hard Stops

    Issue has occurred 3 Times in the past 4 Weeks.

    Recently had Valve Cover Gaskets; Alternator Seal done.

    Thanks in advance.

  2. #2
    Join Date
    Sep 2006
    Location
    Holly, MI
    Posts
    13,195
    My Cars
    2005 325Xi
    Sound like something caused by vacuum issues. Either a leak, or the engine isn't producing enough. Off the top of my head, I can't remember if that engine has Valvetronic, but if it does, the vacuum pump may be drowning in oil and not producing enough vacuum to begin with.
    Quote Originally Posted by B4SH View Post
    If anyone knows, it's this guy who knows literally nothing about everything.
    Quote Originally Posted by fcvapor05 View Post
    Do you even OT? The mean 401k around here is probably about $6, what with all the shiny cars and $1,000 watches and donations to get other members' Volvos running.


  3. #3
    Join Date
    Jan 2015
    Location
    Suffolk, Virginia
    Posts
    9
    My Cars
    2007 BMW 750 Li
    Thanks for the response. I will throw that in the hat with my Repair Shop. Initial discussion with them was that it could be the Intake Boot having a slit in it causing un-metered air. This particular thing is under warranty with them as they did work associated with the Intake Boot when my valve cover gaskets were done back in October of 2018.
    I will check my extended Warranty coverage options for the Vacum Pump.

    Thank you so much.
    2007 BMW 750Li - E66
    1990 BMW 735i - 6 Cylinder 3.5 Liter (M30) Needs Restoration Work

  4. #4
    Join Date
    Jan 2015
    Location
    Suffolk, Virginia
    Posts
    9
    My Cars
    2007 BMW 750 Li
    Quick update.

    Thank you all to those who provided some feedback.

    Issue was found. A smoke test was done by my local BMW Independent Service Shop; they found smoke coming out of a Hose that had come loose from the Vacuum Pump; hose is about 3 feet long. Don't know how long the hose had been loose from this connection and I don't remember where they said the hose leads to from the Vacuum Pump. New hose was installed as the previous hose was dried and brittle on the ends which made it difficult to cut down and re-use again.

    Total cost to me: $40.50 US.

    Substantial difference noticed in braking performance and issue has not occurred since.
    2007 BMW 750Li - E66
    1990 BMW 735i - 6 Cylinder 3.5 Liter (M30) Needs Restoration Work

Similar Threads

  1. Replies: 0
    Last Post: 03-29-2015, 10:15 AM
  2. E65/E66 2007 750Li Front thrust arms
    By chamilun in forum 2002 - 2008 (E65, E66)
    Replies: 0
    Last Post: 10-20-2014, 10:47 AM
  3. bmw 328i 2007- The engine is making loud noise
    By veerub in forum 2006 - 2012 (E90, E91, E92, E93)
    Replies: 8
    Last Post: 09-25-2013, 10:11 PM
  4. bmw 328i 2007- The engine is making loud noise
    By veerub in forum Forum Software Questions & Suggestions
    Replies: 0
    Last Post: 09-06-2013, 07:02 PM
  5. 2007 328i Engine Stall Fuel Cap
    By queteacher in forum 2006 - 2012 (E90, E91, E92, E93)
    Replies: 1
    Last Post: 02-07-2013, 08:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •