Results 1 to 17 of 17

Thread: Backup Cam install...HELP

  1. #1
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350

    Backup Cam install...HELP

    I am trying to install a backup cam on my 2008 BMW 650i. It has an interface module that needs a trigger from the reverse lights to activate the camera.
    I could tap into the backup lights, but would rather connect to a fuse. That is my current problem... is there a backup light system fuse on this car.
    There looks to be two, one for each light, in the wiring diagrams.... but I cannot find their actual locations in the vehicle.
    Any help is appreciated.....
    thanks

  2. #2
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    are they located in the trunk near the battery?
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

  3. #3
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    Yes, there are a lot of fuses there.... but which one!
    I am now looking at the wire bundle that goes into the CCC (radio) module to see if there is a reverse trigger there.
    Memo to self! Never again purchase a car with out a backup cam already installed!!!

  4. #4
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    Yeah. I would really like to have a back up camera in mine also. What camera did you get? You could always tap into the reverse lights wiring. I have the M-ASK setup (basically CCC but with DVD Nav?) I am not sure how you get the camera signal to the screen?
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

  5. #5
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    The setup is distributed by a company called Emerald Mobile Integrations. It taps into the system between the CCC and the LCD display. I tried the wire to the reverse light, and that should have triggered the module, but for some reason it is not. The people at Emerald are still trouble shooting, and assisting.... so I am still hopeful.

  6. #6
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    OK, update!!! The folks at Emerald have offered as much as they can, and I am unable to locate what they are refering to. So, I am going to go with the Avin system... at least that company has a decent warranty program... and I should have my back up camera!!! Will hopefully get it next week, and have it installed pronto. I will try to post some pics.

  7. #7
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    cool. What all options did you go with on the Avin system? I hope to order one here in the near future. I have some other priorities with my RX7 to focus on before spending more money on my 650i though.
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

  8. #8
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    You need the GPS splitter cable, I also got the OBDM Wifi, Screen protectors, 8.8 screen, Liscense plate camera.

  9. #9
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    does your car have an aux port already? mine does not.

    Did you order online or over the phone?
    Last edited by Venom13132; 04-08-2019 at 01:51 PM.
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

  10. #10
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    I ordered online, it is quite a pain as I had a lot of questions, and they would only do the online chat.
    Yes, I do have the aux port, but not going to use it.

  11. #11
    Join Date
    Jan 2007
    Location
    Atlanta, GA
    Posts
    5,924
    My Cars
    2019 Silverado 2500
    Maybe a little late to the game here, but there is no separate fuse for the reverse lights. All the wiring will come off whatever module controls the lamps. In a 6 series, I can't even remember what module does it.
    BMW Level 1 Master Technician

  12. #12
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    Thanks 94RX, I also heard from Timm, he too said it was LKM, lamp control module. I think its located under dash, driver side, below the light switch... but I am not going to open that up.
    So, I am installing my Avin system, and after getting it installed yesterday, it is not working. Today... trouble shooting. There is an inline fuse on the supplied harness, and a fuse on the back of the CCC unit.
    I am hoping its one of those. Do you know of any other fuses that control the CCC system?
    On a separate note....The Avin people have no proven to be helpful during this last couple of days. Everything has to be done by email, or online with their support center... but good luck getting an answer!

  13. #13
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    Here is a quick update. Found a blown fuse in the glove box. So glad I did not start with removing the dash components.
    Now to go out and learn how to use it!

  14. #14
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    It works!!! Although it takes quite a bit of learning... and again, customer service is only by their online support site. No phone calls, when you post a request for information, they usually refer you to their support site and rarely answer any questions.

  15. #15
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    glad you got it installed and working. Post up a few photos when you get a chance.
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

  16. #16
    Join Date
    Nov 2018
    Location
    parrish, fl
    Posts
    51
    My Cars
    650i, E350
    I had every intention to take pics during the install process... but when I did start, I was frustrated at the Avin support and that side tracked me.
    However, looking at their videos, and those on you tube, especially 4x4 canada, were quite helpful.
    I am still having issues getting the OBDM module to work, but hopefully will have that resolved soon. The backup camera works great, really nice to know whats back there when reversing.
    there are many more features that I will never use, but nice to know they are there.
    Installing the supplied harness was difficult, the connectors take a lot of space, there is an inline fuse box that takes up space, which all has to go behind the CCC unit.
    I did blow a fuse during the process, but luckily it was one in the glove box, and not the inline on the harness.
    The Avin support instructions are unusual... for example, trying to get the correct time to display. It kept telling me to select time, then select manual time. Simple enough? Not really, as it will not let you select anything until you de-select the current setting, which I think was auto time.
    My existing GPS, and stereo are working fine, so all in all, I am pleased with the product, just not thrilled with the customer support.

  17. #17
    Join Date
    Oct 2010
    Location
    Indianapolis
    Posts
    650
    My Cars
    650i 6-speed 95 RX7 LS1
    sounds good. Yeah these are coming from china and there is a language barrier for sure. That is why they cant do real time troubleshooting they have to translate everything haha. I still think it is worth the risk and I guess the more of us that go through it the more information people will be able to find when they do theirs.
    2006 BMW 650i 6-speed manual (Daily Driver)
    1995 Mazda RX-7 LS1 6-speed (Current Toy)
    2000 Ford Excursion Limited V10 4x4 (Giant tow work truck)
    2014 BMW 328d XDrive (Wife's daily driver)
    1993 Mazda RX-7 5.3litr Chevy V8 6-speed (why not have 2?)

Similar Threads

  1. Help No sound on Navigation after installing backup cam
    By meloike in forum 1995 - 2001 (E38)
    Replies: 1
    Last Post: 02-15-2018, 09:16 PM
  2. Rear license plate panel removal + backup cam install
    By Splitdog in forum 1995 - 2001 (E38)
    Replies: 46
    Last Post: 03-19-2011, 05:53 PM
  3. Schrick 284 cams install help....
    By ajfox in forum 1994 - 1999 Euro M3 (E36)
    Replies: 8
    Last Post: 03-10-2009, 03:13 PM
  4. Schrick Cams install help.....
    By ajfox in forum 1994 - 1999 Euro M3 (E36)
    Replies: 9
    Last Post: 11-20-2008, 12:32 PM
  5. Bay Area Cam Install help...
    By NegativeCambre in forum California sponsored by Avus Autosport
    Replies: 0
    Last Post: 08-02-2003, 12:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •