Results 1 to 6 of 6

Thread: 2006 X3 E83 Ignition Cylinder issues?

  1. #1
    Join Date
    Mar 2019
    Location
    Silsbee, TX
    Posts
    11
    My Cars
    2010 328i, 2006 X3 3.0i

    Unhappy 2006 X3 E83 Ignition Cylinder issues?

    So I have an issue where I have to turn the cylinder on and off to get it to actually turn off. Not ignition wise just electronic wise. I've replaced the ignition switch to no avail and also had it replaced with no change. So the dealership has said its the ignition switch even though they changed it and didn't fix the issue. They also want to replace the keys and the cylinder. And I can't lock the vehicle with the key less feature I have to use the door cylinder. Unlock and rear hatch work fine. Also the ignition switch is what they said is drawing 600mA off the battery. I need some suggestions because I'm about at my wits end here.

  2. #2
    Join Date
    Jan 2016
    Location
    Ca
    Posts
    3,165
    My Cars
    2001 525it
    So you've had a couple of ignition switches replaced clearly that's not the problem. If the tumbler is not working moving correctly that could cause issues also with the tumbler acting up it would be hard to sync the keys I would replace the tumbler first then if it works normal again I would try to resnyc the remotes to the car and see if the remote buttons start working. Also if you un plugged the ignition switch the draw went away that would be a good test. But if physically the tumbler is not spinning correctly the I would start with the tumbler. I just replaced mine because the key was getting stuck in it.

  3. #3
    Join Date
    Mar 2019
    Location
    Silsbee, TX
    Posts
    11
    My Cars
    2010 328i, 2006 X3 3.0i
    So how do I go about getting a tumbler that is matched or that I can match to my current key? Thank you

  4. #4
    Join Date
    Jan 2016
    Location
    Ca
    Posts
    3,165
    My Cars
    2001 525it
    Only avalibe thru the dealer keyed to you vin number already

  5. #5
    Join Date
    Mar 2019
    Location
    Silsbee, TX
    Posts
    11
    My Cars
    2010 328i, 2006 X3 3.0i
    Quote Originally Posted by jclausen View Post
    Only avalibe thru the dealer keyed to you vin number already

    I see thank you

  6. #6
    Join Date
    Mar 2019
    Location
    Silsbee, TX
    Posts
    11
    My Cars
    2010 328i, 2006 X3 3.0i
    Quote Originally Posted by jclausen View Post
    So you've had a couple of ignition switches replaced clearly that's not the problem. If the tumbler is not working moving correctly that could cause issues also with the tumbler acting up it would be hard to sync the keys I would replace the tumbler first then if it works normal again I would try to resnyc the remotes to the car and see if the remote buttons start working. Also if you un plugged the ignition switch the draw went away that would be a good test. But if physically the tumbler is not spinning correctly the I would start with the tumbler. I just replaced mine because the key was getting stuck in it.

    So it actually turned out to be the occupancy sensor on the passenger seat causing the issue I traced it down and saw power draining there as well as the resistor on the buckle. Never threw a code and even BMW didnt notice it which to be honest their mechanics are pretty half ass anyways. I'm getting them to refund me for the BS they told me because its apparent the 5 hours they had it they didn't look into anything.

Similar Threads

  1. 2006 X3 E83 HELP! Stalling after starting and rough running issue.
    By Rockycameron in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 0
    Last Post: 01-04-2018, 04:34 PM
  2. '95 525iT ignition cylinder issue
    By afredo in forum 1988 - 1996 (E34)
    Replies: 5
    Last Post: 01-21-2014, 12:15 PM
  3. X3 (E83) automatic transmission issues
    By roenlev in forum 2003+ X3, X4 (E83, F25, F26, G02)
    Replies: 3
    Last Post: 01-15-2012, 09:26 PM
  4. Ignition Cylinder Issue
    By CanuckE36 in forum 1992 - 1999 M3 (E36)
    Replies: 0
    Last Post: 05-24-2010, 04:58 PM
  5. Ignition Cylinder Issue
    By jdma300 in forum 1995 - 2001 (E38)
    Replies: 1
    Last Post: 04-20-2007, 05:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •