Results 1 to 18 of 18

Thread: 5HP30 problems after valve body rebuild - solved

  1. #1
    Join Date
    Apr 2016
    Location
    Poland
    Posts
    29
    My Cars
    E34 540

    5HP30 problems after valve body rebuild - solved

    Hello, this is my 1st post on forum because English is not my national language. I'm reading this forum for a long time and it helped mi with a lot problems. I have problem with Transmission in my E34 540. Before i decided to rebuild valve body with zf kit, everything was fine. But now, with rebuilded vb, my car have problem with forward. At d it moves very slowly, tugs at the gear change and displays transprogramm. In winter mode it moves normally, but before gear change the same things happens. On reverse everything is ok, like before rebuild. On diagnostic tool there is code 105 - speed monitoring.

    What i check:
    - i checked twice every springs, checkballs valves etc and everything seems like in instructions
    - replace speed sensors
    - oil level is good
    - filter OEM
    - resistance of solenoids is good (checked under hood)
    - gears are displaying well before failsafe

    I wanted to extend the life of the gearbox but i killed her
    Thanks for any sugestion

  2. #2
    Join Date
    Jul 2007
    Location
    Oldham UK
    Posts
    2,507
    My Cars
    '00 330i Sprt '92 525i
    Did you remember to hook up the end of the shift lever to the manual valve in the valve body when you put the VB back in?

  3. #3
    Join Date
    Jan 2009
    Location
    Wisconsin
    Posts
    449
    My Cars
    '95 540i, '95 525it
    You replaced the speed sensors and now you're getting a "speed monitoring" error. Have you still got the old ones? Maybe you could reinstall those and see what happens.

  4. #4
    Join Date
    Apr 2016
    Location
    Poland
    Posts
    29
    My Cars
    E34 540
    whiskychaser, I think yes, all gears engage good when I move shifter, but i will check it again
    mrgraybeard, Error appeared on old sensors after installation rebuilded vb, then I replaced it with others without change

    Do you know if the valve body from newer 5hp30 with green plate will fit p&p to black plate? I know that in newer are green solenoids but does it matter? My tranny is 1995
    Last edited by lubek; 03-01-2019 at 04:16 AM.

  5. #5
    Join Date
    Jan 2005
    Location
    Japan
    Posts
    44,389
    My Cars
    11/88 E32 750iL+98 E36M3
    Did you install the same, identical valve body gasket and did you compare the gaskets before installing the new one?
    There are 2 versions:
    1055 327 093 5HP30 old version, used in valve body 1055 000 010 and 011
    1055 327 102 5HP30 new version, used in valve body 1055 000 017/026/027/028/029/030/031/032/039/040
    I was told by a ZF repair shop that the new gasket will fit instead of an old gasket, but installing a old version gasket in a valve body where before the new gasket was installed, will cause problems.

    a 5HP30 VBK usually consists of : https://www.thectsc.com/products/val...p30-80-39.html


    same is on 5HP18
    1056 327 100 5HP18 old version gasket
    1056 327 110 5HP18 new version gasket
    Last edited by shogun; 03-02-2019 at 09:41 PM.
    SHOGUN'S TRICKS AND TIPS FOR THE SEVEN SERIES
    http://twrite.org/shogunnew/topmenu.html

  6. #6
    Join Date
    Apr 2016
    Location
    Poland
    Posts
    29
    My Cars
    E34 540
    There is the question. Google graphics says there is 2 different gasket 093(differences in red circle)
    093:
    85593(s).jpg
    093? (that was in my VB)
    IMG_110113_5754.jpg
    102: (I instaled this) vb have nr 323
    85594(s).jpg

  7. #7
    Join Date
    Jul 2010
    Location
    Los Angeles, CA
    Posts
    2,390
    My Cars
    '89 525i (slow but good)
    I actually had an issue when I did the rebuild with a spring.

    The new spring was considerably stiffer than the old one. No other versions for that part.
    After installing it the car was making a terrible clanking with Trans program and no forward engagement.

    I tore down the VB again and reinstalled the old spring. All was well after that.


    I believe it was for 2nd gear clutch or something. I can look it up I wrote it in the records somewhere if you need.

    Quote Originally Posted by 1990525i View Post
    the bees knees

  8. #8
    Join Date
    Apr 2016
    Location
    Poland
    Posts
    29
    My Cars
    E34 540
    It can be this. I would be grateful if you would check. Write if you can, which spring number you reinstall.
    http://www.unofficialbmw.com/images/BMW_A5S560Z.pdf



  9. #9
    Join Date
    Jul 2010
    Location
    Los Angeles, CA
    Posts
    2,390
    My Cars
    '89 525i (slow but good)
    Yes its on page 4 of 16. The spring for valve number 23 was the one. It's for the MV Solenoid Regulator Valve (DR. Red.-V1)

    My car has a prod date of 09/94. Black tag 5hp30.

    Quote Originally Posted by 1990525i View Post
    the bees knees

  10. #10
    Join Date
    Apr 2016
    Location
    Poland
    Posts
    29
    My Cars
    E34 540
    This is good news because I only compared the length of the springs, not stiffnes. Tomorrow I'll have messy job again

  11. #11
    Join Date
    Apr 2016
    Location
    Poland
    Posts
    29
    My Cars
    E34 540
    paperplane94, You save my life Same spring, same situation. Thank you
    But why zf give this spring in kit?

    20190302_123750_Easy-Resize.com.jpg
    Kit I bought
    20190301_211545_Easy-Resize.com(1).jpg
    Run like new
    20181014_134854_HDR_Easy-Resize.com.jpg

  12. #12
    Join Date
    Jul 2010
    Location
    Los Angeles, CA
    Posts
    2,390
    My Cars
    '89 525i (slow but good)
    https://imgur.com/a/0KDNqob
    https://imgur.com/Sa8jjqn
    forgot how to imbed pics.


    Super glad it worked! I hope it stays that way.

    I couldn't find any documentation on this issue when I did mine. Glad this is on the forums now.

    I wonder if this is a problem with the transmission being different or the valve body kit has the wrong part.

    Quote Originally Posted by 1990525i View Post
    the bees knees

  13. #13
    Join Date
    Jul 2010
    Location
    Los Angeles, CA
    Posts
    2,390
    My Cars
    '89 525i (slow but good)
    Also my valve body kit had the same part number as yours: 5961.300.598 009

    Quote Originally Posted by 1990525i View Post
    the bees knees

  14. #14
    Join Date
    Apr 2016
    Location
    Poland
    Posts
    29
    My Cars
    E34 540
    I checked in the green tag valve body and there is also stiffer spring. My valve body is 95 and from green plate 99

  15. #15
    Join Date
    Jan 2005
    Location
    Japan
    Posts
    44,389
    My Cars
    11/88 E32 750iL+98 E36M3
    Quote Originally Posted by lubek View Post
    But why zf give this spring in kit?
    Such a kit is only sold on the US market, not in Europe. Actually you basically only need the balls and the paper gasket and no springs, cups or whatsoever.
    I usually only replace these parts and keep the original springs.
    Usually on the 5HP30 even the old plate gasket can be re-used, as it does not stick solid between the plates like on 4HP22/24.

    Also did not hear of a change of part number for that spring, maybe whiskychaser knows
    Last edited by shogun; 03-02-2019 at 09:47 PM.
    SHOGUN'S TRICKS AND TIPS FOR THE SEVEN SERIES
    http://twrite.org/shogunnew/topmenu.html

  16. #16
    Join Date
    Jul 2007
    Location
    Oldham UK
    Posts
    2,507
    My Cars
    '00 330i Sprt '92 525i
    Part number D159165 appears to be made by Transmaxx, even though it has the ZF logo on the box. Is that kit actually manufactured by ZF?

  17. #17
    Join Date
    Jul 2010
    Location
    Los Angeles, CA
    Posts
    2,390
    My Cars
    '89 525i (slow but good)
    I didn't see that D159165 part number on my box. Just a lot of ZF branding all over everything.

    Quote Originally Posted by 1990525i View Post
    the bees knees

  18. #18
    Join Date
    Apr 2016
    Location
    Poland
    Posts
    29
    My Cars
    E34 540
    It was the cheapest kit on ebay, but it didn't look like a fake. ZF logo on each bag. But who knows?

Similar Threads

  1. Software update after valve body rebuild?
    By Stephen Max in forum 2004-2010 (E60,E61)
    Replies: 0
    Last Post: 10-05-2015, 01:05 PM
  2. Replies: 9
    Last Post: 02-23-2013, 03:38 PM
  3. 5HP30 valve body rebuild thanks guys
    By billys bmw in forum 1988 - 1994 (E32)
    Replies: 2
    Last Post: 10-22-2010, 10:11 PM
  4. 5HP30 Valve Body Rebuild (lots of pics)
    By shogun in forum 1988 - 1994 (E32)
    Replies: 2
    Last Post: 10-02-2010, 05:02 AM
  5. WTB E32 Valve Body Rebuild Kit (5HP30)
    By 9mmkungfu in forum BMW Parts Wanted sponsored by Bavarian Auto Recycling
    Replies: 4
    Last Post: 04-29-2009, 06:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •