Page 1 of 2 12 LastLast
Results 1 to 25 of 50

Thread: How does immobilizer works? No crank-no start.

  1. #1
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport

    How does immobilizer works? No crank-no start.

    I already did a thread a while back, with a no crank/no start. I got a new battery since the old one was low. Car was running fine, left it at work and at night it would not start. Didn't play too much with a low battery, jumped it next day, and nothing.
    All lights, electric locks, windows, etc work fine, got a new key from dealer, same thing.
    On the 1st key position I don't get the beep beep from ews, or fuel pump priming.
    Using a test light I get power to pin 2 (black wire) and out of pin 1 from the ews module going to starter. So I think the ignition switch and key is good.
    I am stomped.....
    To get to the starter the intake has to be removed?

    I don't want to send it to the crusher yet.....

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  2. #2
    JimLev's Avatar
    JimLev is offline Artifically Aspirated Moderator
    Join Date
    Oct 2006
    Location
    Sundance Mesa, NM
    Posts
    13,540
    My Cars
    00 540/6, '16 Highlander

  3. #3
    geargrinder's Avatar
    geargrinder is offline Having No Trouble Here BMW CCA Member
    Join Date
    Mar 2010
    Location
    AndoverRockport MA & Intl
    Posts
    14,743
    My Cars
    E46M3Cic E39.540iT E84X1
    Yep. Super low battery could cause the EWS to get scrambled, although normally a new dealer key will usually work.

    The best thing to do is to get somebody with INPA to plug in and read codes, and then read 'digital status' on the EWS and try to see this screen:



    That screen will show you why EWS doesn't want to run the starter (either key won't be "sending", or, one of the black dots on the bottom will be lit up).

    As a general remark, WTF... we have had SO many EWS/no-starts lately its unbelievable. And really unfortunate that most mechanics dont understand how the systems work because there's just such loads of mis-diagnosis and wasted time and money...
    2003 M3CicM6 TiAg
    2002 540iT Sport Vortech S/C 6MT LSD TiAg
    2014 BMW X1 xDrive28i (hers)
    2008 Audi A3 2.0T DSG (soon to go on the block)
    1999 Cherokee Sport 4L (trailer-hitched in-law-loaner bomber)


    Former:

    1985 Euro 300SL
    1995.5 Audi S6 Avant (utility/winter billetturbobattlewagen)


  4. #4
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Guess it will go to the crusher because I don't know anyone with INPA. Unless I take it to the dealer, but not worth it. Since they would charge more than what an e39 goes for...



    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  5. #5
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Quote Originally Posted by geargrinder View Post
    Yep. Super low battery could cause the EWS to get scrambled, although normally a new dealer key will usually work.

    The best thing to do is to get somebody with INPA to plug in and read codes, and then read 'digital status' on the EWS and try to see this screen:



    That screen will show you why EWS doesn't want to run the starter (either key won't be "sending", or, one of the black dots on the bottom will be lit up).

    As a general remark, WTF... we have had SO many EWS/no-starts lately its unbelievable. And really unfortunate that most mechanics dont understand how the systems work because there's just such loads of mis-diagnosis and wasted time and money...
    I got the key thru the dealer, it was coded with my VIN.

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  6. #6
    JimLev's Avatar
    JimLev is offline Artifically Aspirated Moderator
    Join Date
    Oct 2006
    Location
    Sundance Mesa, NM
    Posts
    13,540
    My Cars
    00 540/6, '16 Highlander
    Quote Originally Posted by Yonkers320is View Post
    Guess it will go to the crusher because I don't know anyone with INPA. Unless I take it to the dealer, but not worth it. Since they would charge more than what an e39 goes for...

    Sent from my SM-G930V using Tapatalk
    Are you serious?
    There must be someone near you that has it.
    You can buy INPA on eBay for pretty cheap.

  7. #7
    Join Date
    Jan 2015
    Location
    Shreveport Louisiana
    Posts
    245
    My Cars
    1999 5281
    sheesh INPA with the cable is only about $30 on the big eauction site, youll need to provide your laptop to run it on.

    jim just beat me to it by seconds
    Last edited by mattmar1; 02-15-2019 at 12:54 PM.

  8. #8
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    I'm going to ask on the nyc subforums, if not I will try and buy it. Unfortunately i live in the boondocks, even repair shops don't want to deal with older cars.

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  9. #9
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Quote Originally Posted by mattmar1 View Post
    sheesh INPA with the cable is only about $30 on the big eauction site, youll need to provide your laptop to run it on.

    jim just beat me to it by seconds
    Im going to buy it, because i may need it on other bimmers.

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  10. #10
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Quote Originally Posted by mattmar1 View Post
    sheesh INPA with the cable is only about $30 on the big eauction site, youll need to provide your laptop to run it on.

    jim just beat me to it by seconds
    Is there a version i should look for? Some say K+ DCan, K+CAN..

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  11. #11
    Join Date
    Jan 2015
    Location
    Shreveport Louisiana
    Posts
    245
    My Cars
    1999 5281
    theres an option for a cable with a switch on it, gives you either option, as you may be using it on other BMW's.

  12. #12
    geargrinder's Avatar
    geargrinder is offline Having No Trouble Here BMW CCA Member
    Join Date
    Mar 2010
    Location
    AndoverRockport MA & Intl
    Posts
    14,743
    My Cars
    E46M3Cic E39.540iT E84X1
    All those "K+DCAN etc." cables are roughly the same, though some are better than others.

    What that means is, they can work in K-line connection cars (aka E46/39 and older) and also on DCAN connection cars (aka E90 and newer E platforms).

    Although F-series cars need yet again another thing as BMW tries to make it harder and harder for techs and owners to fiddle.

    You don't have to get one with a switch but honestly its easier way to go.

    Once you get it, either run the install from "Mikes Easy BMW Tools" package, or, Bimmergeeks download (free).

    You can also buy the Bimmergeeks cable, you're slightly more guaranteed to get a good one that way. OR better, buy it from Bimmerlabs where they tweak the software in the cable to fix some bugs (and a buck or two goes to some of our own forum members). Its more expensive but its slightly better and sometimes the eBay cable quality is up and down from various sellers... with those guys you know youre getting a good one.
    2003 M3CicM6 TiAg
    2002 540iT Sport Vortech S/C 6MT LSD TiAg
    2014 BMW X1 xDrive28i (hers)
    2008 Audi A3 2.0T DSG (soon to go on the block)
    1999 Cherokee Sport 4L (trailer-hitched in-law-loaner bomber)


    Former:

    1985 Euro 300SL
    1995.5 Audi S6 Avant (utility/winter billetturbobattlewagen)


  13. #13
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Quote Originally Posted by geargrinder View Post
    All those "K+DCAN etc." cables are roughly the same, though some are better than others.

    What that means is, they can work in K-line connection cars (aka E46/39 and older) and also on DCAN connection cars (aka E90 and newer E platforms).

    Although F-series cars need yet again another thing as BMW tries to make it harder and harder for techs and owners to fiddle.

    You don't have to get one with a switch but honestly its easier way to go.

    Once you get it, either run the install from "Mikes Easy BMW Tools" package, or, Bimmergeeks download (free).

    You can also buy the Bimmergeeks cable, you're slightly more guaranteed to get a good one that way. OR better, buy it from Bimmerlabs where they tweak the software in the cable to fix some bugs (and a buck or two goes to some of our own forum members). Its more expensive but its slightly better and sometimes the eBay cable quality is up and down from various sellers... with those guys you know youre getting a good one.
    Cool, thanks.

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  14. #14
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Quote Originally Posted by geargrinder View Post
    Yep. Super low battery could cause the EWS to get scrambled, although normally a new dealer key will usually work.

    The best thing to do is to get somebody with INPA to plug in and read codes, and then read 'digital status' on the EWS and try to see this screen:



    That screen will show you why EWS doesn't want to run the starter (either key won't be "sending", or, one of the black dots on the bottom will be lit up).

    As a general remark, WTF... we have had SO many EWS/no-starts lately its unbelievable. And really unfortunate that most mechanics dont understand how the systems work because there's just such loads of mis-diagnosis and wasted time and money...
    Running INPA, but I don't get anything related to EWS. The image doesn't load up.

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  15. #15
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    I get a bunch of screens, so i guess it can communicate. Turn ignition on, and use Shift+F8, scroll down e39, engine m52 41.1 with OBD11....
    What i don't get is the black dot on the ignition... it's white and off.

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  16. #16
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Voltage at 12.7.....

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  17. #17
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    If I scroll to body, electronic vehicle imm.. EWS.

    I don't know what else....


    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  18. #18
    Join Date
    Jan 2015
    Location
    Shreveport Louisiana
    Posts
    245
    My Cars
    1999 5281
    as i asked in your other post, are you connected with the 20 to 16 pin adapter to the 20 pin underhood port as your car is a 1998? 16 pin underdash connector will only give you DME and trans info (if auto)

    https://www.ebay.com/itm/20-Pin-to-O...-/263291156662
    Last edited by mattmar1; 03-09-2019 at 01:57 PM.

  19. #19
    geargrinder's Avatar
    geargrinder is offline Having No Trouble Here BMW CCA Member
    Join Date
    Mar 2010
    Location
    AndoverRockport MA & Intl
    Posts
    14,743
    My Cars
    E46M3Cic E39.540iT E84X1
    Ko-Wreckt.
    2003 M3CicM6 TiAg
    2002 540iT Sport Vortech S/C 6MT LSD TiAg
    2014 BMW X1 xDrive28i (hers)
    2008 Audi A3 2.0T DSG (soon to go on the block)
    1999 Cherokee Sport 4L (trailer-hitched in-law-loaner bomber)


    Former:

    1985 Euro 300SL
    1995.5 Audi S6 Avant (utility/winter billetturbobattlewagen)


  20. #20
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Quote Originally Posted by mattmar1 View Post
    as i asked in your other post, are you connected with the 20 to 16 pin adapter to the 20 pin underhood port as your car is a 1998? 16 pin underdash connector will only give you DME and trans info (if auto)

    https://www.ebay.com/itm/20-Pin-to-O...-/263291156662
    Whaaaaaaaaaaaaaaaa?

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  21. #21
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Quote Originally Posted by geargrinder View Post
    Ko-Wreckt.
    Had no idea. I have a adapter, but yhought it was for the service reminder. It sucks to be old..... jaja.


    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  22. #22
    Join Date
    Oct 2017
    Location
    Beaverton, Oregon, USA
    Posts
    146
    My Cars
    2001 E39 540i Aut,180 k
    So, once you get INPA set up and working correctly on your car, try to follow the steps ins posting #80 and above of this thread. Similar problem, and I think similar solution
    https://www.bimmerforums.com/forum/showthread.php?2397348-No-Start-No-error-codes-after-removing-battery-and-charging-it/page4

  23. #23
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Quote Originally Posted by Chedley View Post
    So, once you get INPA set up and working correctly on your car, try to follow the steps ins posting #80 and above of this thread. Similar problem, and I think similar solution
    https://www.bimmerforums.com/forum/showthread.php?2397348-No-Start-No-error-codes-after-removing-battery-and-charging-it/page4
    Ok thanks, on a side note, can I use a battery charger on the car to keep the battery full while doing the testing?

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

  24. #24
    Join Date
    Oct 2017
    Location
    Beaverton, Oregon, USA
    Posts
    146
    My Cars
    2001 E39 540i Aut,180 k
    Yes, absolutely.
    That is the preferred way of recharging the battery. Connect the charger to the + and - posts under the hood in the engine bay.
    Attached Images Attached Images
    Last edited by Chedley; 03-10-2019 at 05:56 AM.

  25. #25
    Join Date
    Feb 2003
    Location
    Yonkers, NY and Argentina
    Posts
    2,962
    My Cars
    1998 528i 5speed Sport
    Got the adapter to the car, with the laptop and INPA running. Got couple more screens: engine,transmission, chassis, body, communications.
    Go to Body, scroll to EWS, doubke click and get a version do not match and sends me back to menu screen.
    Hit F4, read error codes, come up three in german, related to ews. Clear codes, and nothing.
    I still don't get a EWS alignment (f2) like on the other posts.

    I give up, its been a month, it is like cursed...

    Sent from my SM-G930V using Tapatalk
    e30 325i, the mighty 4 door granma mobile....Gone
    e39 528i, 4 door sports tank

Page 1 of 2 12 LastLast

Similar Threads

  1. E36 No crank, no start but lights on dash work like normal.
    By Grush123 in forum 1991 - 1999 (E36)
    Replies: 49
    Last Post: 03-23-2019, 11:07 AM
  2. Replies: 2
    Last Post: 01-09-2013, 12:48 AM
  3. 08 540I very rough start up and A/C sometimes does not work
    By 98540ibeamer in forum 1996 - 2003 (E39)
    Replies: 14
    Last Post: 10-14-2011, 06:34 PM
  4. car lights work, no crank, car won't start
    By plmuzikmaster in forum 1988 - 1996 (E34)
    Replies: 37
    Last Post: 12-26-2008, 09:49 PM
  5. bypass ews II. starter work fine, cranked, engine wont start, Locate ECM and ULR
    By 323iptg in forum Car Audio & Electronics sponsored by Bavsound
    Replies: 1
    Last Post: 04-06-2007, 11:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •