Results 1 to 2 of 2

Thread: Please help! Vanos noise after Chain replacement (Not Solinoids)

  1. #1
    Join Date
    Oct 2018
    Location
    Sweden
    Posts
    1
    My Cars
    BMW 1 Series 116i N45

    Please help! Vanos noise after Chain replacement (Not Solinoids)

    Hi guys,

    Thanks for letting me in. Im new in this forum and looking for a solution to the problem with my BMW E87 116i N45 Engine


    The background is the timing chain is replaced because the old chain had become slack. I replaced the chains, guides etc according to the workshop manual. After the replacement then there is noise from the top / center of the engine accompanied with bad idle and cylinder missfire. I have used bmw tool to lock the engine when replacing the chain, changed the oil and filter. The engine run fine before the chain replacement.

    I have diagnosed the ECu and get fault code P0015

    So far I have replaced follwing part with no result

    Vanos Unites (both)
    Vanos Solinoids (Both)


    Any suggestions are welcome, would appreciate all help I can get.

    Thanks again

  2. #2
    Join Date
    May 2019
    Location
    UK
    Posts
    3
    My Cars
    E60

    I have a similar issue 283D and 2870 Vanos inlet adaptation stop

    Quote Originally Posted by Mazimo View Post
    Hi guys,

    Thanks for letting me in. Im new in this forum and looking for a solution to the problem with my BMW E87 116i N45 Engine


    The background is the timing chain is replaced because the old chain had become slack. I replaced the chains, guides etc according to the workshop manual. After the replacement then there is noise from the top / center of the engine accompanied with bad idle and cylinder missfire. I have used bmw tool to lock the engine when replacing the chain, changed the oil and filter. The engine run fine before the chain replacement.

    I have diagnosed the ECu and get fault code P0015

    So far I have replaced follwing part with no result

    Vanos Unites (both)
    Vanos Solinoids (Both)


    Any suggestions are welcome, would appreciate all help I can get.

    Thanks again
    Hello I have a similar issue. Timing chain has been replaced. I get rough idle and stalling. Problem goes if you disconnect the exhaust solenoid. Tried swapping solenoids and problem stays with exhaust so unlikely it is the solenoid. Replaced rectangrings on camshafts and changed exhaust Vanos. No change.

    Need some expert help. Car has done 113k and top of engine looks very clean and unworn. Car is 2007 116i with N45 engine. Problem existed before timing chain change. Special purpose locking tools were used. Anyone else had this issue and knows how to fix it?

Similar Threads

  1. Replies: 6
    Last Post: 06-02-2015, 12:28 PM
  2. PLEASE HELP! Fuel problems after new engine
    By BMuu in forum 1991 - 1999 (E36)
    Replies: 8
    Last Post: 06-29-2005, 01:30 PM
  3. Please help diagnose noise after installing
    By ronzo in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 2
    Last Post: 03-22-2003, 09:45 PM
  4. Vanos noise after S/C install
    By X'z95M3 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 0
    Last Post: 03-07-2003, 10:41 PM
  5. Please help with noise!!!
    By Lahight in forum 1992 - 1999 M3 (E36)
    Replies: 11
    Last Post: 07-23-2002, 11:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •