Results 1 to 10 of 10

Thread: e36 megasquirt

  1. #1
    Join Date
    Jul 2012
    Location
    denville new jersey
    Posts
    41
    My Cars
    1987 325es, 1995 m3

    e36 megasquirt

    does anyone on here have an ms3pro on their e36? I recently installed one on my obd1 m3 and i'd like to pick your brains on tuning.

  2. #2
    Join Date
    Apr 2006
    Location
    Minnesota eh?
    Posts
    5,512
    My Cars
    86 325es
    I have an ms3 ultimate in my e30. Do you have the PNP setup?


    86 325es, 2.8L m50, S472sxe, MS3pro Ultimate, e85, solid rear axle, 4 link, spool, TH400 trans, Protorque converter, 28x10.5w slicks, zip ties
    Best = 9.43 @ 149.15 mph, 1.30 60 foot 28 psi boost

  3. #3
    Join Date
    Jul 2012
    Location
    denville new jersey
    Posts
    41
    My Cars
    1987 325es, 1995 m3
    i do have the pnp setup. basically my issue is i load up the obd1 s50 stock basemap, i make a couple changes for my individual throttle bodies and injectors and the cars runs pretty damn well other than my afr gauge showing its too rich so i run ve analyze live for a little while and then it seems like my car starts to run worse especially in lower rpm and while cruising with little throttle. my afr gauge is pinned at 10 so im assuming its choking itself with too much fuel. i believe that this is because i need to make changes to my afr target table so im wondering if anyone has any insight on where i should be making changes to get this thing to be running right. im very new to tuning and any help would be greatly appreciated.

  4. #4
    Join Date
    Sep 2009
    Location
    Lawrenceville, GA
    Posts
    4,234
    My Cars
    328i vert and Dodge Dart
    First, what sort of O2 sensor are you using, and is it displaying the correct AFR in TunerStudio?
    Matt Cramer
    1997 BMW 328i convertible, 1972 Chevy C10 pickup, 1966 Dodge Dart slant six
    BMW - where "Why doesn't everybody build cars the way they do?" meets "Why can't they build a car the same way everyone else does it?"

  5. #5
    Join Date
    Jul 2012
    Location
    denville new jersey
    Posts
    41
    My Cars
    1987 325es, 1995 m3
    just a factory narrowband. i have a wideband hooked up but not to the dme just to an afr gauge which is something i will get to. when i get some time i will check and make sure tunerstudio is displaying the correct afr although i believe it is. assuming it is what would be my next step?

  6. #6
    Join Date
    Jul 2012
    Location
    denville new jersey
    Posts
    41
    My Cars
    1987 325es, 1995 m3
    well i looked back at my data log and it appears as though my afr stays pinned at 15.9 maybe i have a faulty o2 sensor and i should install that wideband. I'll give that a shot and get back to you guys.

  7. #7
    Join Date
    Jul 2012
    Location
    denville new jersey
    Posts
    41
    My Cars
    1987 325es, 1995 m3
    wideband installed and calibrated but still not reading afr or datalogging afr help

  8. #8
    Join Date
    Sep 2009
    Location
    Lawrenceville, GA
    Posts
    4,234
    My Cars
    328i vert and Dodge Dart
    You'll need to make sure the factory narrow band is disconnected too. If you have both connected and are using the default EGO port, the two sensors will interfere.
    Matt Cramer
    1997 BMW 328i convertible, 1972 Chevy C10 pickup, 1966 Dodge Dart slant six
    BMW - where "Why doesn't everybody build cars the way they do?" meets "Why can't they build a car the same way everyone else does it?"

  9. #9
    Join Date
    Jul 2012
    Location
    denville new jersey
    Posts
    41
    My Cars
    1987 325es, 1995 m3
    Hey Matt Cramer I think i was just talking to you via ampefi support. I have since disconnected the factory o2 sensor and its still not reading an afr signal. I have told tunerstudio that i am using a wideband in all three locations: Project Properties, EGO Control, and Calibrate AFR choosing the AEM x Series wideband. im a little stumped as I believe the sensor is wired correctly: red wire switched power, black Wire grounded in the same location as the ecu, and the white wire to the #10 pin of the options port. Also after wiring it and opening tuner studio it told me the controller settings didnt match tunerstudio because of the wideband so i feel it is wired correctly. When opening VEAL and starting to autotune I get an o2 sensor calibration active filter that i am having a hard time getting rid of.

  10. #10
    Join Date
    Sep 2009
    Location
    Lawrenceville, GA
    Posts
    4,234
    My Cars
    328i vert and Dodge Dart
    Check the output voltage on that pin and make sure it matches AEM's published calibration.

    Alternatively, is this an X series with CAN input? If you're not using the CANBus for anything else, the wideband over CAN feature is typically more accurate.
    Matt Cramer
    1997 BMW 328i convertible, 1972 Chevy C10 pickup, 1966 Dodge Dart slant six
    BMW - where "Why doesn't everybody build cars the way they do?" meets "Why can't they build a car the same way everyone else does it?"

Similar Threads

  1. e36 megasquirt
    By trofa in forum 1991 - 1999 (E36)
    Replies: 13
    Last Post: 01-22-2013, 08:43 AM
  2. Megasquirt e36 M50B20TU/M50B25 w/ ITBs idle surge...help?
    By bmbelo in forum 1991 - 1999 (E36)
    Replies: 3
    Last Post: 02-24-2011, 07:05 AM
  3. e36 325 M50 + .120 MLS + ARP + Megasquirt = 350rwhp?
    By EFreak in forum Forced Induction
    Replies: 28
    Last Post: 06-07-2009, 06:23 PM
  4. Calling on megasquirt users For my turbo e36 M42 project
    By bearsbmw in forum Forced Induction
    Replies: 3
    Last Post: 04-21-2009, 10:25 AM
  5. Megasquirted E36 runs, some questions.
    By Kingbob in forum 1991 - 1999 (E36)
    Replies: 7
    Last Post: 09-24-2008, 10:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •