Results 1 to 4 of 4

Thread: 2008 335i: engine light issue when accelerating

  1. #1
    Join Date
    Aug 2018
    Location
    Miami
    Posts
    12
    My Cars
    2008 335i

    2008 335i: engine light issue when accelerating

    the issue I have with acceleration: once i accelerate hard for a couple of seconds, gaining fast incremental speed, the engine light will come on and suggest that there's an engine malfunction AND that it will operate at reduced power...but I really don't see any measure of reduced power (accelerating or steady driving) - and if so, not even close to the power reduction I experienced when the crankshaft position sensor was faulty.

    So, the warning light comes on but I don't see any difference in the actual power in the vehicle itself - I can continue to higher speeds and accelerate.

    I'm curious to know is that a faulty wire or sensor somewhere, obviously something is going on but it's connected to the accelerated pedal and gradual but fast incremental speed...and it can happen from any particular initialization - from 0-miles per hour or from 40-miles per hour.

    I can clear the engine warning light and malfunction message by restarting the vehicle and it won't reappear until I do a hard acceleration again which I normally don't - really only to test.

    I can say that it happens in regular drive, in sport drive, but not in manual drive...and when it does happen no codes are shown or stored only the malfunction message and engine light which can be cleared by turning the vehicle off then back on again.

    It occurs on the down slide from 3500 RPMs and pops on at about 3000 RPMs.

    Thanks
    Last edited by Managementpub; 08-06-2018 at 08:12 PM.

  2. #2
    Join Date
    Jun 2017
    Location
    Denver, CO
    Posts
    135
    My Cars
    '07 E90 335xi auto
    Pull the codes, fix the problem.

  3. #3
    Join Date
    Apr 2009
    Location
    Vancouver Isl, BC, Canada
    Posts
    4,146
    My Cars
    09 335, 98 Evo M3, 01 M3
    check all your vacuum hoses for the wastegate controllers. Including the 2 that run down past the oil filter. They love to crumble and any leaks will cause symptoms like you describe. It will store codes for boost control if this is the issue(i dont remember the exact codes or wording off hand)
    Last edited by legoman67; 08-11-2018 at 05:06 AM.
    Current:

    - 09 335i
    - 98 M3 Eurospec
    - 01 M3

    Ex's: 1984 325e, 1988 325IX, 1992 525I, 1995 540i/6, 2002 330i, 2005 330xi, 1992 850i, 2003 330i #1, 2003 330i #2, 2002 330ci, 2004 330ci, 2007 328CI, 2007 335i

  4. #4
    Join Date
    Jun 2017
    Location
    Denver, CO
    Posts
    135
    My Cars
    '07 E90 335xi auto
    Quote Originally Posted by legoman67 View Post
    check all your vacuum hoses for the wastegate controllers. Including the 2 that run down past the oil filter. They love to crumble and any leaks will cause symptoms like you describe. It will store codes for boost control if this is the issue(i dont remember the exact codes or wording off hand)
    Bad boost control hoses will throw a 30FF and cause substantially reduced acceleration, not matching the OP's reported symptoms.

Similar Threads

  1. Yes, I searched, Check engine light issue
    By Silvbullit in forum 1991 - 1999 (E36)
    Replies: 7
    Last Post: 10-31-2008, 02:43 PM
  2. New Check Engine Light Issue?
    By smcgee in forum 1992 - 1999 M3 (E36)
    Replies: 6
    Last Post: 05-16-2008, 12:54 PM
  3. New Check Engine Light Issue?
    By smcgee in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 1
    Last Post: 05-14-2008, 07:54 PM
  4. weird "Check Engine" light issue
    By flyeryan in forum 1988 - 1996 (E34)
    Replies: 2
    Last Post: 09-11-2007, 10:24 AM
  5. Replies: 6
    Last Post: 10-22-2006, 12:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •