Bavarian Soundwerks
Results 1 to 3 of 3

Thread: New to me 2007 335i - e92 coupe without Nav.

  1. #1
    Join Date
    Mar 2004
    Location
    Tyler, Tx
    Posts
    6,765
    My Cars
    '01 740i Sp, '07 335i

    Post New to me 2007 335i - e92 coupe without Nav.

    My problem the radio is dead. The pixels are unreadable and no sounds, regardless of which buttons I push.

    My question is this - is it worth while to try repairing this unit or just try my luck and buy another unit off ebay. I have seen them for anywhere from 125.00 to 300.00, 150.00 seems to be the average asking price.
    http://i293.photobucket.com/albums/mm71/krallopian/darthSigTest2_zpsn6zkw5id.jpg[/URL][URL="http://www.facebook.com/pages/DFW7-Dallas-Fort-Worth-BMW-7-Series-Club/300942239566"]DFW7 on Facebook/URL]
    "The Last Great e38" 2001 i Sport - Born'd on date 1/01 Cosmos/Grey - 32.8K miles - 2 1/2 " Custom Exhaust, Center “X”over , Modified OEM rear bumper, M5 style trunk spoiler, M6 OEM wheels, M3 Steering wheel with working paddle shift & CF trim, Bi-Xenon upgrade, 13mm Rear sway bar added, SS brake lines and bronze bushings, Cross drilled rotors and painted calipers, Akebono pads, Zionsville aluminum radiator & exp. tank with electric fan, Sprint Booster, BluTooth conversion, MKIV Nav., Custom wood cupholder, DUDMD Tune, Orien V2.5 LED Angel Eyes, Evans waterless. Recently added grey faced //M5 Cluster - all gauges functioning. Changed the grey carpet to black and topped off with GG Bailey front/rear mats[/SIZE]

  2. #2
    Join Date
    Jul 2011
    Location
    Arlington, VA
    Posts
    5,905
    My Cars
    2018 BMW M240i
    The pixels issue could be one or more bad solder joints. The reason is the solder used in the head unit has no lead. As a result the solder joints tend to go bad as lead free solder isn’t very flexible. Of course, there could be other reasons such as a bad ribbon cable or a bad screen driver.

    The lack of sound could be a bad amp. But first check the fuses. Then get the wiring diagram and ensure that the amp is getting:
    1. The 12VDC “turn on” signal from the head unit
    2. 12VDC from the fuse panel. This should be present even when the car is off.

  3. #3
    Join Date
    Mar 2004
    Location
    Tyler, Tx
    Posts
    6,765
    My Cars
    '01 740i Sp, '07 335i
    Quote Originally Posted by MarcoZandrini View Post
    The pixels issue could be one or more bad solder joints. The reason is the solder used in the head unit has no lead. As a result the solder joints tend to go bad as lead free solder isn’t very flexible. Of course, there could be other reasons such as a bad ribbon cable or a bad screen driver.

    The lack of sound could be a bad amp. But first check the fuses. Then get the wiring diagram and ensure that the amp is getting:
    1. The 12VDC “turn on” signal from the head unit
    2. 12VDC from the fuse panel. This should be present even when the car is off.
    Thanx for the reply - I will check fuses first - if I can get noise I will go further into the head unit for pixels.
    http://i293.photobucket.com/albums/mm71/krallopian/darthSigTest2_zpsn6zkw5id.jpg[/URL][URL="http://www.facebook.com/pages/DFW7-Dallas-Fort-Worth-BMW-7-Series-Club/300942239566"]DFW7 on Facebook/URL]
    "The Last Great e38" 2001 i Sport - Born'd on date 1/01 Cosmos/Grey - 32.8K miles - 2 1/2 " Custom Exhaust, Center “X”over , Modified OEM rear bumper, M5 style trunk spoiler, M6 OEM wheels, M3 Steering wheel with working paddle shift & CF trim, Bi-Xenon upgrade, 13mm Rear sway bar added, SS brake lines and bronze bushings, Cross drilled rotors and painted calipers, Akebono pads, Zionsville aluminum radiator & exp. tank with electric fan, Sprint Booster, BluTooth conversion, MKIV Nav., Custom wood cupholder, DUDMD Tune, Orien V2.5 LED Angel Eyes, Evans waterless. Recently added grey faced //M5 Cluster - all gauges functioning. Changed the grey carpet to black and topped off with GG Bailey front/rear mats[/SIZE]

Similar Threads

  1. New-To-Me 2007 335i Coupe 6-Speed
    By Uress in forum 2006 - 2012 (E90, E91, E92, E93)
    Replies: 4
    Last Post: 03-29-2017, 09:28 AM
  2. Engine Bay cleaning - 2007 335i e92 coupe
    By amirahmad7705 in forum Car Detailing and Show & Shine Prep sponsored by Autogeek.net
    Replies: 6
    Last Post: 03-25-2016, 04:55 PM
  3. 2007 335i E92 Coupe, Low miles, California car
    By jeffb325 in forum 3 series & Z Series
    Replies: 2
    Last Post: 12-17-2015, 03:26 PM
  4. New to me.. 2007 335i Coupe
    By gav91183 in forum BMW Rides & Events
    Replies: 3
    Last Post: 08-05-2013, 12:16 PM
  5. New wheels for 2007 335i
    By thefitter in forum Tire & Wheel Forum sponsored by The Tire Rack
    Replies: 12
    Last Post: 01-17-2007, 01:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •