Results 1 to 3 of 3

Thread: Rubber burning smell for few seconds after 5 minutes of driving

  1. #1
    Join Date
    May 2018
    Location
    San Diego
    Posts
    1
    My Cars
    Z4. 2008

    Rubber burning smell for few seconds after 5 minutes of driving

    Hi,
    Recently, I smell rubber burning smell for a few seconds after 5 minutes driving then the smell goes away. Any idea what might be the problem?

    Thanks

  2. #2
    Join Date
    Jan 2016
    Location
    Ca
    Posts
    2,653
    My Cars
    2001 525it
    A leaking valve cover gasket would make a burning smell, not really a rubber smell.

  3. #3
    Join Date
    Sep 2018
    Location
    NOVA
    Posts
    15
    My Cars
    2003 e85 BMW Z4
    Sam what was problem? Pulley seized up and belt slip?


    Sent from my iPhone using Tapatalk

Similar Threads

  1. Replies: 1
    Last Post: 08-25-2013, 02:00 AM
  2. 90 325i sputters for a few seconds after warming up
    By fongbros in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 0
    Last Post: 05-20-2013, 09:04 PM
  3. Oil Light comes on for 10 seconds after cold start
    By Landerholm in forum 1999 - 2006 (E46)
    Replies: 8
    Last Post: 06-07-2006, 11:37 PM
  4. ECU not priming fuel for few seconds ign on
    By ozim535i in forum 1988 - 1996 (E34)
    Replies: 0
    Last Post: 01-14-2006, 07:01 PM
  5. windows only work for few seconds! help please
    By 89crazy5 in forum 1988 - 1996 (E34)
    Replies: 4
    Last Post: 07-18-2005, 06:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •