Results 1 to 5 of 5

Thread: Front Windows Won't Go Up with the "All Up" Switch, But Work Fine By Themselves

  1. #1
    Join Date
    Mar 2018
    Location
    Jackson, Michigan
    Posts
    17
    My Cars
    05 E46

    Front Windows Won't Go Up with the "All Up" Switch, But Work Fine By Themselves

    Hi everyone.

    Wondering if anyone can point me in a direction for troubleshooting this.

    The front windows on my 330Ci convertible won't go up when I use the "all up" switch. They go up completely fine by themselves, and they go down with the "all down" switch.

    When I operate the automatic convertible top, they go down the required amount to lower the top as well.

    So basically, they seem to ONLY not work correctly when using the "all up" button.

    The rear windows go up and down with the "all up" and "all down" switch.

    I read in the manual that they should go up when the switch is used, but I have no idea where to start troubleshooting this. I also read about the "roll the windows down then up and hold the switch" to reset the windows after a loss of power, and I did put a new battery in the car so a loss of power would have occurred, however, this didn't fix the issue.

    It's not really a huge deal, but it seems to be something that's just kind of irritating.

    Any tips would be great.

    Thanks.
    Jeff
    Last edited by Gimpdiggity; 04-16-2018 at 01:40 AM.

  2. #2
    Join Date
    Apr 2018
    Location
    Salt Lake City
    Posts
    5
    My Cars
    E91 Daily, E46 Race Car
    Did both windows start doing this at the same time? I would say start with the window switches, but it's very odd for both to fail at the same time.

  3. #3
    Join Date
    Mar 2018
    Location
    Jackson, Michigan
    Posts
    17
    My Cars
    05 E46
    Quote Originally Posted by EngelhartRacing View Post
    Did both windows start doing this at the same time? I would say start with the window switches, but it's very odd for both to fail at the same time.
    Unfortunately I am not sure. The car is new to me, so Iíve been going through repairing little things here and there, and having my mechanic do what I canít or donít feel up to.

    I did end up with a pretty nasty spark when connecting the battery after replacing the missing battery vent elbow, which led to a battle for an evening with what I believe was the K-Bus. Nothing would work at all...windows wouldnít work, convertible top wouldnít work, dash lights wouldnít work. I ended up checking all the fuses, found none bad, but decided to change out the radio fuse as that one looked a bit suspect (the larger one, canít recall but I think it was a 30a fuse). Of course I didnít have one on hand, so I popped it out so I could easily just pop the new fuse in when I got home from the store. Weirdly, everything started working again, save for the radio, with the fuse removed. Put the new one in and everything is fine again.

    Thing is, the front windows wouldnít go up on their own BEFORE all of this. When I first got the car I took it for an inspection at a good BMW Indy (who is doing the work I canít/donít want to do) and they said it had a pinch sensor code that they cleared. Iím wondering if that code has anything to do with it?

  4. #4
    Join Date
    Mar 2018
    Location
    Jackson, Michigan
    Posts
    17
    My Cars
    05 E46
    Well, the driver side started working tonight...not sure what exactly I did, but I think I managed to do the reset on that one.

    I tried doing the passenger side a few times and it still won’t work. I’ve read that the reset procedure can sometimes take numerous attempts.

    It’s not a huge deal, but I’m trying to get everything on the car working as it did when it was new...so I’m trying to get these windows all set up.


    ***EDIT***

    After messing with it a bit more, the passenger side started to work...but then the driver side stopped working. I decided to go ahead and disconnect the negative terminal on the battery, as I have read that this can get rid of some little electrical gremlins...even though the last time I did it I ended up having that battle with the K-bus that I eventually managed to win...at least I think I won.

    Anyway, after doing that and letting it sit for nearly an hour with no power, I went out and reconnected everything...and all of the windows work with the all up and all down button now. While testing everything out, I used the top several times and they all went back up after dropping the top and raising the top...and the button works just fine. I get a bit OCD with things, so I was messing with them a LOT...and eventually they started failing again, and only working after a good several seconds (maybe 10-15?). I ended up just leaving it alone, and then the issue resolved itself again.

    What I think that I am seeing is window motors that are getting too hot from me constantly moving the windows up and down, and basically not allowing themselves to work while they are hot. Realistically, there is no way anyone would EVER be using the windows the way I have while trying to get this worked out, so it makes sense that it would be something not many people would notice. After letting them sit without touching them for a good five minutes, they worked flawlessly again. I will go out and test them again in an hour or so, after the car has had some time to cool off completely, and see if I can move them up and down a few times. If so, I will consider this issue resolved...until it's not resolved again.

    I love this car...but it's been a bit of a pain. After having that issue with the K-Bus I've been VERY hesitant to work on anything in the car...like I need to replace the lighter socket so that I can use it to charge my phone, but I'm really nervous about taking it out and unplugging things to get the socket replaced. I really don't want to have the frustration I had that night with the K-Bus again.

    ***EDIT 2***

    Testing about an hour after initially getting them all to work yielded all four windows working perfectly. They go down with the all down, and up with the all up. When putting the top down they all go back up if I hold the button for two seconds after the light goes out, and they do the same when putting the top up. So I think I may have gotten this worked out.
    Last edited by Gimpdiggity; 04-22-2018 at 02:01 AM.

  5. #5
    Join Date
    Oct 2009
    Location
    Torrance, CA
    Posts
    57
    My Cars
    1999 323i
    The door locks, trunk release and windows all have timed arrest features. If you are repeatedly playing with any of these systems they will stop working to prevent overheating the motor. It will take about 15 seconds to get back one use. If you go into the body control module with INPA you will find Timed Arrest fault codes in the Shadow codes section.

Similar Threads

  1. Rear window won't go all the way up with convertible top down
    By mjposner in forum 1983 - 1991 (E30)
    Replies: 2
    Last Post: 08-08-2015, 11:50 AM
  2. Passenger side front window won't go up on "auto"
    By mrwheels in forum 1996 - 2003 (E39)
    Replies: 12
    Last Post: 06-11-2010, 03:37 AM
  3. front windows won't go up
    By hrtfxr in forum Convertible Questions
    Replies: 2
    Last Post: 07-11-2008, 02:22 PM
  4. window won't go up all the way
    By NHenson1 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 5
    Last Post: 03-14-2005, 09:25 PM
  5. Help Window won't go all the way up anymore
    By mbadger in forum 1991 - 1999 (E36)
    Replies: 3
    Last Post: 11-20-2002, 09:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •