Results 1 to 5 of 5

Thread: M70 Crank/Cam Position Help!

  1. #1
    Join Date
    Feb 2015
    Location
    Kuna, Idaho
    Posts
    549
    My Cars
    Too Many Cars (NOT!)

    M70 Crank/Cam Position Help!

    1991 850i CB73309

    Can someone verify which wires feed the crank and cam position sensor plugs.

    Note:right and left is from inside car facing forward.

    My car has 4 wires coming out of the plastic box under the engine cover that are for these sensors.

    The top left wire has a black socket that (I belive) goes to the crank sensor and the lower left wire has a tan connector on it.
    Do those go to the crank/cam position sensors on the left side of the engine?
    Do the two wires that sit on the right side of that box go to the right sensors?

    I'm asking because there seems to other things that cross sides and I would really like to get this car running again.

    Thank you
    Last edited by masbury; 04-14-2018 at 05:11 PM. Reason: screw up
    Mike Drives:
    BMW's
    E24 - 635CSiA - (1) 1985 (US)
    E24 - 635CSi - (1) 1985 (EC)
    E24 - 633CSiA - (1) 1980 (US)
    E31 - 850iA - (1) 1991
    E32 - 740iA - (1) 1994
    E32 - 750iA - (1) 1990 (Not an "L") (EC)
    E34 - 540iA - (1) 1994
    E38 - 740iLA - (2) 1997 & 1998
    E38 - 750iLA - (1) 1998
    E39 - 528iA - (3) 1997, & (2) 2000
    Also:
    2015 Ram 3500 Dually
    2014 Dodge Dart
    2007 Mercedes Benz CL600
    2002 Mercedes Benz SL500
    1967 Buick Riviera (2)

  2. #2
    Join Date
    Dec 2013
    Location
    San Antonio
    Posts
    405
    My Cars
    850i, '76 2002, '76 530
    I installed new crank and cam sensors in my '91 recently. Let me double-check. The right bank, 1-6 CIS (cam) goes to bottom plug receptacle on passenger side. The receptacle on top is for the top crank sensor. The top receptacle on driver's side is for the 7-12 CIS and receptacle below it is for the lower crank sensor.

    IMG_20171221_125736877_HDR.jpg
    Last edited by JDP530; 04-14-2018 at 05:24 PM.

  3. #3
    Join Date
    Feb 2015
    Location
    Kuna, Idaho
    Posts
    549
    My Cars
    Too Many Cars (NOT!)
    Just to be sure also, the tan connectors are for the donuts, correct?
    Mike Drives:
    BMW's
    E24 - 635CSiA - (1) 1985 (US)
    E24 - 635CSi - (1) 1985 (EC)
    E24 - 633CSiA - (1) 1980 (US)
    E31 - 850iA - (1) 1991
    E32 - 740iA - (1) 1994
    E32 - 750iA - (1) 1990 (Not an "L") (EC)
    E34 - 540iA - (1) 1994
    E38 - 740iLA - (2) 1997 & 1998
    E38 - 750iLA - (1) 1998
    E39 - 528iA - (3) 1997, & (2) 2000
    Also:
    2015 Ram 3500 Dually
    2014 Dodge Dart
    2007 Mercedes Benz CL600
    2002 Mercedes Benz SL500
    1967 Buick Riviera (2)

  4. #4
    Join Date
    Jul 2017
    Location
    toronto, ontario
    Posts
    34
    My Cars
    1991 BMW 850i
    Quote Originally Posted by masbury View Post
    Just to be sure also, the tan connectors are for the donuts, correct?
    I don't think so. The tan engine harness connectors are on the bottom and as JDP530 states only the passenger side tan connector is for a donut (1-6). The 7-12 donut connects to the drivers side, upper, black connector. Definitely not intuitive, probably why so many people get this wrong.
    Last edited by pollack138; 04-14-2018 at 08:28 PM.

  5. #5
    Join Date
    Feb 2015
    Location
    Kuna, Idaho
    Posts
    549
    My Cars
    Too Many Cars (NOT!)
    There is a top end rebuild (M70) document floating around where the author says the tan connectors are for the donuts. Weird that BMW switched colors in mid stream so to speak.

    Thanks for the correction.
    Mike Drives:
    BMW's
    E24 - 635CSiA - (1) 1985 (US)
    E24 - 635CSi - (1) 1985 (EC)
    E24 - 633CSiA - (1) 1980 (US)
    E31 - 850iA - (1) 1991
    E32 - 740iA - (1) 1994
    E32 - 750iA - (1) 1990 (Not an "L") (EC)
    E34 - 540iA - (1) 1994
    E38 - 740iLA - (2) 1997 & 1998
    E38 - 750iLA - (1) 1998
    E39 - 528iA - (3) 1997, & (2) 2000
    Also:
    2015 Ram 3500 Dually
    2014 Dodge Dart
    2007 Mercedes Benz CL600
    2002 Mercedes Benz SL500
    1967 Buick Riviera (2)

Similar Threads

  1. Cam Position Sensor Help
    By Harry24 in forum 1991 - 1999 (E36)
    Replies: 11
    Last Post: 05-05-2007, 12:43 PM
  2. WTB: M50/S50 cam position sensor and crank sensor
    By Lobstrosity in forum BMW Parts Wanted sponsored by Bavarian Auto Recycling
    Replies: 2
    Last Post: 02-21-2007, 09:18 PM
  3. So I replaced the cam position sensors and SES light is still on. Help!
    By tynash@yahoo.co in forum 1995 - 2001 (E38)
    Replies: 9
    Last Post: 01-13-2007, 08:27 PM
  4. Help, Need crank and cam positions
    By M3ANMUG in forum 1975 - 1983 (E21)
    Replies: 6
    Last Post: 10-01-2006, 02:21 PM
  5. Help! - Cam position sensor problem
    By red740is in forum 1995 - 2001 (E38)
    Replies: 0
    Last Post: 02-23-2004, 05:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •