Results 1 to 7 of 7

Thread: BMW X3 no spark

  1. #1
    Join Date
    Apr 2018
    Location
    Mesa, AZ USA
    Posts
    4
    My Cars
    2006 BMW X3

    Post BMW X3 no spark

    Hi Guys,
    I'm new at the forum and I have learned a lot from all of you guys...Thanks!

    My problem is that I have no spark; therefore, the care only cranks and no start... this what I have done:

    2006 BMW X3 automatic M54

    Replace all the CCV because it has an air leak... but then cylinder 9 started to misfire, so reading some of your suggestions about the rings getting stuck, I pulled the spark plugs out and added the ACdelco injector cleaner. as expected the car smoked for awhile and then got better, smoke gone, but the misfire was there... let it run for 40 minutes and puled the spark plugs again to see if their were wet, some where... clean them up and put them back in to find than now cylinder 4 and 5 where misfiring... let run for a bit, then turn the car off and never started again.

    replaced:
    Spark plugs
    swap coils
    replaced the DDE (light blue relay)
    checked fueses

    I don't know what else to do!!! any suggestings

    Thanks guys

  2. #2
    Join Date
    Jul 2007
    Location
    Cave Creek, AZ
    Posts
    908
    My Cars
    1993 850ci 2001 M5
    Are there any codes present on the X 3?

    What is the condition of the engine ground strap?
    Regards,

    Brian
    Cave Creek, AZ

  3. #3
    Join Date
    Apr 2018
    Location
    Mesa, AZ USA
    Posts
    4
    My Cars
    2006 BMW X3
    The only code is E10 with the Peak reader.
    The car is all stock

  4. #4
    Join Date
    Jul 2007
    Location
    Cave Creek, AZ
    Posts
    908
    My Cars
    1993 850ci 2001 M5
    re run the peake reader, and give us all of the numbers that come up
    Regards,

    Brian
    Cave Creek, AZ

  5. #5
    Join Date
    Apr 2018
    Location
    Mesa, AZ USA
    Posts
    4
    My Cars
    2006 BMW X3
    ok, I just runned the Peake scanner
    27A4 - Interface EWS 3.3 - DME
    281d - BSD generator: signal (This maybe because my battery is getting low of cranking)
    281c - bit serial data interface (BSD): signal

    Any suggestions... Like I said, I checked all the fuses, replaced the green and light blue relay and nothing

  6. #6
    Join Date
    Aug 2012
    Location
    Kansas
    Posts
    1,607
    My Cars
    2000 m roadster 2010 x3
    Are you using an original key or replacement. Could be a transponder issue in the key

  7. #7
    Join Date
    Jun 2019
    Location
    Millstadt, IL
    Posts
    10
    My Cars
    2008 e92 m3 2006 e83 x3
    Quote Originally Posted by aldoygloria View Post
    ok, I just runned the Peake scanner
    27A4 - Interface EWS 3.3 - DME
    281d - BSD generator: signal (This maybe because my battery is getting low of cranking)
    281c - bit serial data interface (BSD): signal

    Any suggestions... Like I said, I checked all the fuses, replaced the green and light blue relay and nothing

    did you ever figure out what was wrong?

    I have the exact same codes/no spark situation going on too, driving me crazy

Similar Threads

  1. 08 BMW X3 no crank no start
    By Locallawns in forum 2003+ X3, X4 (E83, F25, F26, F97, F98, G02)
    Replies: 3
    Last Post: 06-20-2017, 05:41 PM
  2. 2004 BMW X3 - No Longer Available
    By edcvin in forum 3 series & Z Series
    Replies: 0
    Last Post: 12-13-2016, 05:40 AM
  3. 1994 BMW 740iL no spark
    By dcobb21264 in forum 1988 - 1994 (E32)
    Replies: 5
    Last Post: 08-19-2014, 03:39 PM
  4. 89 bmw 325i no spark?
    By tylerbreitwese in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 7
    Last Post: 05-03-2013, 07:58 PM
  5. 89 bmw 325i no spark?
    By tylerbreitwese in forum General BMW and Automotive Discussion sponsored by Intercity Lines
    Replies: 6
    Last Post: 05-01-2013, 06:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •