Results 1 to 10 of 10

Thread: 1999 BMW Z3 2.5 motor 5spd Wont start Cranks - No spark . appears to have fuel

  1. #1
    Join Date
    Mar 2018
    Location
    Plainfield, Illinois
    Posts
    4
    My Cars
    1999 bmw z3

    1999 BMW Z3 2.5 motor 5spd Wont start Cranks - No spark . appears to have fuel

    1999 BMW Z3 2.5 E36 M52 engine.. 98k no check engine lights 5sp. Was running fine.. Backed car into drive-way, while backing in stalled it out (Ooops Clutch) Park job was good enough so I just turned the key to off position and pulled the key. I dont remember exactly but I think when I turned the key off the door unlocked and then locked again ? Opened the door from interior door handle. Couple hours later went to start the car cranks / motor spins over but wont start.. Pulled plug and check for spark.. Appears to have no spark.. I check the fuel rail and there is plenty of gas that comes out when I push the Valve stem down. Any Ideas ? Cam shaft or crank sensor? Odd tho just like that... What about the security system? EWS III in this car I think... I have 3 sets of keys... Tried all 3 keys still same result.. If the EWS / Immobilizer is activated is there any time of warning light activated ? Will the car crank if its the EWS ? Any help would be greatly appreciated.... Thanks in advance...

  2. #2
    Join Date
    Jun 2010
    Location
    NY
    Posts
    5,866
    My Cars
    1997 328i
    Try locking and unlocking the door with the key.
    Avoid Vogtland Suspensions! Rusted then failed!

  3. #3
    Join Date
    Mar 2018
    Location
    Plainfield, Illinois
    Posts
    4
    My Cars
    1999 bmw z3
    Quote Originally Posted by Eric93se View Post
    Try locking and unlocking the door with the key.

    I've tried that... Still no start... Does the EWS completely disable the car or does the engine still crank with no starting? Getting ready to order a Cam shaft sensor. But i'm sure i'm wasting my time..

  4. #4
    Join Date
    Jun 2010
    Location
    NY
    Posts
    5,866
    My Cars
    1997 328i
    I think its EWS related. Check the battery voltage, needs to be at least 12.0v or better.

    - - - Updated - - -

    Scan for codes, use INPA if you or someone you know has it.
    Avoid Vogtland Suspensions! Rusted then failed!

  5. #5
    Join Date
    Mar 2018
    Location
    Plainfield, Illinois
    Posts
    4
    My Cars
    1999 bmw z3
    I suspect it is the EWS system as well because of the way the door unlocked and then locked again.... Is there away to reset the EWS after its been activated?

  6. #6
    Join Date
    Mar 2018
    Location
    Plainfield, Illinois
    Posts
    4
    My Cars
    1999 bmw z3
    Well I bought a ODB2 to usb conector and a 20 pin BMW to ODB 16 pin along with INPA software. Once I figured out how to get the software to communicate with the car I was able to read the EWS and that showed 4 errors I was able to clear the errors (Still wouldn't start) and then after more research I found I had to sync the ECU up with the EWS I was also able to find that via many google searches... Sync it up with the INPA software and the car started right up... Did I mention that the INPA software was all in German even after I specified install in English!!! And yes I looked up ways to switch it to English -None worked... Used a good old German to English translator and made my way thru it.. Car was down for less than 2 weeks and I saved around 400 bucks by not towing to the Dealer (nearest dealer 25 miles ) and having them fix it.. O and learned a whole bunch about the EWS...

  7. #7
    Join Date
    Jun 2010
    Location
    NY
    Posts
    5,866
    My Cars
    1997 328i
    Wow awesomeness work! So sorry we weren't able to give a quicker solution!

    There are many versions of INPA online, so your good at it now, might as well find an English version.

    Care to share the method to align the DME and EWS since you had to do a lot of leg work to figure it out??
    Avoid Vogtland Suspensions! Rusted then failed!

  8. #8
    Join Date
    Apr 2019
    Location
    Wichita
    Posts
    26
    My Cars
    1999 BMW Z3 2.3 Roadster
    This sounds EXACTLY like the same problem we are having right now. Your steps at solving this are similar to what I have been doing however I have replaced both camshaft position sensors and the crankshaft position sensor. Also replaced fuel filter. Ive checked all fuses and relays. Turns over but no spark. Getting ready to order INPA because right before finding your thread, I was beginning to lean towards the EWS just like you came across. You stated "I had to sync the ECU up with the EWS" Can you update with more specific information on how you did this?

  9. #9
    Join Date
    Jun 2010
    Location
    NY
    Posts
    5,866
    My Cars
    1997 328i
    It's called EWSsync

    Also here is a link to INPA. You'll also need an INPA cable which you can get off ebay or amazon.

    https://www.bimmerforums.com/forum/s...ad.php?2184573
    Avoid Vogtland Suspensions! Rusted then failed!

  10. #10
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    9,705
    My Cars
    MCoupe, 328is, Z3, TDI
    Some incompatible info here.
    EWSSync is only for ews2 cars without rolling codes in dme.

    The 2 Z3s here are the facelift ones with MS42 dme, EWS3D, and rolling codes. EWSSync will not work on those.
    These problems cannot be diagnosed without factory diagnostics, so getting INPA running, and pulling codes in both dme and ews modules is crucial.
    Most of the time this is a crankshaft position sensor issue. Then people replace their old broken sensor with a low quality aftermarket Chinese one (because Siemens / Bosch brand, or genuine BMW are pricy), which are horribly unreliable and don't work.

    If your diag system cannot see rpm, then the dme cannot see crankshaft signal, so therefore it won't start.

    EWS issues are far less common. So if the dme to ews rolling codes have lost sync, there is another problem, which can creep up again. A sync isn't a fix, it just gets you going again.
    Last edited by 328 Power 04; 04-20-2019 at 09:29 PM.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 250hp/400ft-lbs

Similar Threads

  1. 1999 BMW Z3 coupe 2.8L 5spd Black on Tan - No Longer Available
    By jersey2.8 in forum 3 series & Z Series
    Replies: 4
    Last Post: 07-15-2016, 01:57 AM
  2. Z3 E36/7 FS: 1999 BMW Z3 Coupe -
    By hexagone in forum Z3,Z4,Z8 Classifieds
    Replies: 1
    Last Post: 12-13-2011, 09:22 PM
  3. Z3 E36/7 1999 BMW Z3 M-Coupe - Lots of Extras
    By E55 Bulldog in forum 3 series & Z Series
    Replies: 33
    Last Post: 05-15-2011, 12:50 AM
  4. Z3 E36/7 For Sale: 1999 BMW Z3 Roadster 2.3 37k miles
    By muhamor in forum Z3,Z4,Z8 Classifieds
    Replies: 0
    Last Post: 07-17-2010, 12:23 AM
  5. Z3 E36/7 FS: 1999 BMW Z3 M-Coupe
    By E55 Bulldog in forum 3 series & Z Series
    Replies: 10
    Last Post: 03-24-2010, 03:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •