Page 2 of 2 FirstFirst 12
Results 26 to 42 of 42

Thread: 1998 750il M73 - Slow Acceleration

  1. #26
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    Ill pull the acoustic cover and give it a listen. Both of the little returns are clicking over by the oil filter/hydraulic reservoir.
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  2. #27
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    Definitely 7-12 is not ticking.

    Looking to see which crank sensor is supposed to "fire" that side. (driver side USA)

    Quote Originally Posted by XAlt View Post
    Do you hear six injectors ticking or do you hear 12 injectors ticking?
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  3. #28
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    Swapped coils for fun, because mine were made by Bremi 4.29.15. No luck with the fire. I pulled both crank sensors and had them separated, but my helper got them mixed up. They were filthy. So I cleaned them with contact cleaner spray and reinstalled. Still only firing on passenger side, facing car.

    Debating on trying the crank sensors off dads car.
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  4. #29
    Join Date
    Feb 2011
    Location
    Chicago, IL
    Posts
    11,636
    My Cars
    98 740IL & 00 740i sport
    Quote Originally Posted by 740ilDuke View Post
    Swapped coils for fun, because mine were made by Bremi 4.29.15. No luck with the fire. I pulled both crank sensors and had them separated, but my helper got them mixed up. They were filthy. So I cleaned them with contact cleaner spray and reinstalled. Still only firing on passenger side, facing car.

    Debating on trying the crank sensors off dads car.
    I am assuming the DME that was in the back seat is the one not firing?

    Sent from my SM-N910T3 using Tapatalk
    155,000 Miles

  5. #30
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    That's my thinking as well. I swapped the crank sensors one more time in case the 50/50 chance that I'd reinstalled them the same way. No change.

    Coils & wires are new/Bremi.



    Is there a way to replace the faulty DME? Or is this when the scenario goes to find donor V12 & source DME's lock cylinder, ignition switch, EWS & keys and so on?

    ews 3.3 code 204, 39,108
    DME 1.jpgDME1.1.jpgEWS.jpg






    Quote Originally Posted by purplecty View Post
    I am assuming the DME that was in the back seat is the one not firing?

    Sent from my SM-N910T3 using Tapatalk
    Last edited by 740ilDuke; 02-18-2018 at 09:44 PM. Reason: information update
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  6. #31
    Join Date
    Apr 2007
    Location
    Kansas City, MO
    Posts
    6,706
    My Cars
    2x01 750, 01 740, 98 740
    I see you do indeed have DIS working and reading DME I, are you able to read DME II with it?
    See my E38 parts for sale on eBay: click here!
    PM me here for a 5% discount on any of them!

    WTB/WTT: Ecru Walknappa (US Highline), and black rear armrests, non-skibag. Can trade skibag + skibag armrest.

  7. #32
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    Yeah, I can choose which bank to look at if that's what you mean. The EWS codes are coming from 7-12. I will go out and connect now and verify my findings.
    Being one of the DME's was on the back seat when I bought it, I think that's the issue. It has been "worked on" apparently because it has some numbers on it added by another party. It is however the sequential DME that came in the car with the VIN stamped on it.

    I wonder if the DME that controls bank 2 (7-12) has lost sync and will not allow that side to fire...if that's possible. I've tried to sync the EWS and seem to have issues doing so. However - the car starts every time.

    Back in a few!

    Quote Originally Posted by psjr View Post
    I see you do indeed have DIS working and reading DME I, are you able to read DME II with it?
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  8. #33
    Join Date
    Jul 2016
    Location
    Chicago, Illinois
    Posts
    3,837
    My Cars
    are slow
    On the E32, if only one MAF is connected it will cut power to the disconnected bank's injectors. If both are disconnected it will cut off fuel completely, check if this trick works on the M73.
    Last edited by XAlt; 02-19-2018 at 01:43 PM.

  9. #34
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    Well, after another boxing round, failed programming attempts, EWS miscommunication errors and some texting (Thanks PrplCty!) - I decided to take it back to basics. I'd recalled that after swapping DME's the car didn't want to run. So, I did that again - I swapped it. Viola - bank 2 came ALIVE (7-12). Because it sat for over a year, as told by the seller, I think it only ran cyl 1-6 during its final rides - so for 2 years based on what I've pieced together. The DME that was on the back seat was good for the garbage, that's what I've come to.

    The un-tampered with factory DME (VIN label on it) would start the car on either harness. It would run bank 2 (7-12) great - but a show a pegged temp needle and nothing else (tach) would work. I could swap that same DME to bank 1, or 1-6 and it would run that bank fine, with instrumentation working (this was how it had been connected all along) - minus the temp. So, for fun I tried to start the car with the spray painted/seviced DME and it would not start the car or run either bank.

    Next step: I've sourced a DME with the identical hardware code as my working/VIN matched DME. I'll be sending my DME's, EWS and key to DUDMD so that he may work his wizardry. I'm a tech savvy guy, but you learn by doing and I've never delved that deep - so Im shipping my bits off tomorrow, East to West coast.
    I feel confident that my torque bank error and EWS codes will vanish...after all - if theres not a working DME -or a faulty one they have nothing to communicate with.

    Happily the coils, wires and plugs are new Bremi's (done by the tech that was trying to solve this issue..who kept it 14 months). Ive got some less intense things to do in the interim, like CCVs on the back of the plenums, upper windscreen gasket and the driver's side seat control panel. Thats my afternoon tomorrow..then the Dinan will start getting torn apart door panel at a time for the Monsoons. No head unit there yet, so that payoff will come later.

    As soon as my parts have made the 6000 mile cross country trip, I'll report back my findings to the land of V12 Keepers.

    Thank you all, hopefully this thread is nearing the end. :-))))))
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  10. #35
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    So, the car is now running on 12 ZYL. The only code I keep getting so far is the Signal Loss from the MAF on Bank 1 -Zyl 1-6, or passenger side US. So Im trying to figure out which connector(s) on the DME to focus on. One DME has BLACK plugs the other has GRAY. So, if I can at least find out which color goes to which bank, thats a starting place.

    The other issue is the temp gauge inside does not register. The cluster test makes it move, but noting otherwise. The engine is running at 86 C or about 186 F viewable after cracking the cluster. Being that we have two points that measure temp (under expansion tank and on the thermostat itself) , I was curious if one feeds the cluster's physical gauge or how that works.

    To get it running on 12, one DME was replaced using a donor and cloning it from my good DME. With one DME unplugged, IIRC the temp gauge is pegged.

    Finally, after filling the car up the first time in 2 years, the following morning the cabin smelled like gas - still does.
    - checked all the injectors and lines under the hood, bone dry
    - checked under the back seat - nothing there
    - I did replace the fuel filter, so I will have a second look since it is located under the passenger seat
    -I guess the other place to look is filler neck by removing rear tire and rear wheel well


    Thanks for any helps, tips and suggestions.
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  11. #36
    Join Date
    Apr 2007
    Location
    Kansas City, MO
    Posts
    6,706
    My Cars
    2x01 750, 01 740, 98 740
    Bank 1 MAF (located on the driver's side) pins:
    Ground to a ground splice in the engine harness that eventually terminates at a passenger side shock tower ground nut.
    Power from the second fuse in the tan DME fuse box
    2 Signal lines to DME I (the one with black plugs) pins 9 and 23 of the middle (52-pin) plug.

    Most common E38 fuel leak is where the fuel lines come out of the passenger side firewall into the engine bay. The 750 has a few more lines to the rails more susceptible to leaks too. All of those would usually only smell when running however.
    See my E38 parts for sale on eBay: click here!
    PM me here for a 5% discount on any of them!

    WTB/WTT: Ecru Walknappa (US Highline), and black rear armrests, non-skibag. Can trade skibag + skibag armrest.

  12. #37
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    Good info. I'd read that Bank 2 is drivers side (US) and Bank 1 is passenger which is confusing me a little bit. I know exactly where the ground cables are, beside the e-box.

    I'll have to revisit the panel as far as the "tan DME fuse box" goes.

    DME 1 / Black plugs - goes to the driver side according to this, correct?

    Gas Smell - I was about to pull the rear tire and wheel well, but the car has security nuts on
    it. So that'll have to wait.

    Excited to try to narrow this MAF issue down at least for now. It literally kills the car if its at idle. Hoefully I wont have to buy a harness, but BMW does sell them for a cool grand.

    Attached a couple pics for fun. Previously I could not see the cylinder readouts.IMG_3167.jpgIMG_3190.jpg

    Quote Originally Posted by psjr View Post
    Bank 1 MAF (located on the driver's side) pins:
    Ground to a ground splice in the engine harness that eventually terminates at a passenger side shock tower ground nut.
    Power from the second fuse in the tan DME fuse box
    2 Signal lines to DME I (the one with black plugs) pins 9 and 23 of the middle (52-pin) plug.

    Most common E38 fuel leak is where the fuel lines come out of the passenger side firewall into the engine bay. The 750 has a few more lines to the rails more susceptible to leaks too. All of those would usually only smell when running however.
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  13. #38
    Join Date
    Apr 2007
    Location
    Kansas City, MO
    Posts
    6,706
    My Cars
    2x01 750, 01 740, 98 740
    Bank 1 of cylinders is on the passenger side, yes. The MAF for that bank of cylinders is located on the driver's side of the car.
    See my E38 parts for sale on eBay: click here!
    PM me here for a 5% discount on any of them!

    WTB/WTT: Ecru Walknappa (US Highline), and black rear armrests, non-skibag. Can trade skibag + skibag armrest.

  14. #39
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    That's crazy. That sort of engineering baffles me, placing the MAF on the opposite side... wowza.

    Quote Originally Posted by psjr View Post
    Bank 1 of cylinders is on the passenger side, yes. The MAF for that bank of cylinders is located on the driver's side of the car.
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  15. #40
    Join Date
    Jul 2016
    Location
    Chicago, Illinois
    Posts
    3,837
    My Cars
    are slow
    Quote Originally Posted by 740ilDuke View Post
    That's crazy. That sort of engineering baffles me, placing the MAF on the opposite side... wowza.
    It's because of the design of the intake manifold, this pic explains itself.

    6db790cbc1614f3b55a869d1b958d393.jpg

  16. #41
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    252
    My Cars
    2001 DINAN 7, 1998 750il
    That makes sense, I wasn't considering the destination of the plenum pipes. I've been out of the V12 game for a little while.

    Thanks for sharing!

    Quote Originally Posted by XAlt View Post
    It's because of the design of the intake manifold, this pic explains itself.

    6db790cbc1614f3b55a869d1b958d393.jpg
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus Gray - 88k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front, New M-Pars, Monsoons, NBT Nav/Radio, Dual Pane Glass
    1998 - 750il V12 - Arctic Silver - 71k miles
    Bone Stock.
    @scotthduke on Instagram


  17. #42
    Join Date
    Mar 2016
    Location
    Tampa FL
    Posts
    17
    My Cars
    1998 e38 750il
    I had a problem like this just the other day slow acceleration.. I posted my fix on the e38 group but you can see if it works for you. My problem was because of a dead battery



    Car starts now but runs like shit-->> (low idle barely running dme forcing 600 rpm idle real idle 680ish)… Tried to move it NO power low rpm can just make it to 40 mph flooring it… Looking over the car check the MAF unplug passenger side nothing happens unplug driver side it dies, ok easy enough I have new ones at home… swap same thing it’s not reading bank 1 and running off bank 2 readings only….. mmmm soo after an hour of looking and reading … there is something call bank mixture adaption…
    So things I noted is both the DME in the car are the same. Part# Code# and the serial# was one character off and both are labeled DME1. So I’m guess both the DMEs read as one. And the adaptions is finding out which dme is on which back as far at TB, injectors, spark and O2…
    Form what I get off of TIS, this job can be forced by Gt1/SSS. If you don’t have that this is what it calls for:
    1. Coolant >85C
    2. Evap check done
    3. vacuum check done
    4. And TB sync complete
    5. No CEL codes
    After all the setting are met:
    1. Turn the car off
    2. Turn the car back on
    3. Wait 5 minute to all checks 1-4 are done again you will know once the evap stops clicking
    4. 30s mid rpm load of 3500
    5. 15s low rpm load of 1500
    6. Wait 5 minutes again
    7. Turn the car off and leave car in position 2
    Now you will have all power back and car will idle perfect again
    27
    Cc
    73
    8c
    62
    50
    Last edited by redlinebanging; 03-19-2018 at 09:31 AM.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Help needed on a 1998 750iL - M73 engine
    By TxGR8White in forum 1995 - 2001 (E38)
    Replies: 4
    Last Post: 09-02-2016, 08:21 AM
  2. 1998 750iL No acceleration
    By jmindler in forum 1995 - 2001 (E38)
    Replies: 10
    Last Post: 08-08-2013, 08:39 PM
  3. 1998 540i Slow Acceleration and Noise
    By chrisbenejam in forum 1996 - 2003 (E39)
    Replies: 2
    Last Post: 02-27-2013, 09:13 AM
  4. 1998 750il with 125k stll worth a crap or is it about to bust
    By chinaman in forum 1995 - 2001 (E38)
    Replies: 12
    Last Post: 10-10-2005, 12:53 AM
  5. 1998 750il 42k miles White on Tan 4 Sale
    By marshcorona in forum BMW Cars For Sale / Wanted (Panjo)
    Replies: 0
    Last Post: 09-05-2004, 03:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •