Page 2 of 2 FirstFirst 12
Results 26 to 34 of 34

Thread: 1998 750il M73 - Slow Acceleration

  1. #26
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    106
    My Cars
    2001 DINAN 7, 1998 750il
    Ill pull the acoustic cover and give it a listen. Both of the little returns are clicking over by the oil filter/hydraulic reservoir.
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus - 84k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front. Brand New M-Pars

    1998 - 750il V12 - Arctic Silver - 70k miles
    Bone Stock. Style 4 forged wheels.


  2. #27
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    106
    My Cars
    2001 DINAN 7, 1998 750il
    Definitely 7-12 is not ticking.

    Looking to see which crank sensor is supposed to "fire" that side. (driver side USA)

    Quote Originally Posted by XAlt View Post
    Do you hear six injectors ticking or do you hear 12 injectors ticking?
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus - 84k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front. Brand New M-Pars

    1998 - 750il V12 - Arctic Silver - 70k miles
    Bone Stock. Style 4 forged wheels.


  3. #28
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    106
    My Cars
    2001 DINAN 7, 1998 750il
    Swapped coils for fun, because mine were made by Bremi 4.29.15. No luck with the fire. I pulled both crank sensors and had them separated, but my helper got them mixed up. They were filthy. So I cleaned them with contact cleaner spray and reinstalled. Still only firing on passenger side, facing car.

    Debating on trying the crank sensors off dads car.
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus - 84k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front. Brand New M-Pars

    1998 - 750il V12 - Arctic Silver - 70k miles
    Bone Stock. Style 4 forged wheels.


  4. #29
    Join Date
    Feb 2011
    Location
    Chicago, IL
    Posts
    11,464
    My Cars
    98 740IL & 00 740i sport
    Quote Originally Posted by 740ilDuke View Post
    Swapped coils for fun, because mine were made by Bremi 4.29.15. No luck with the fire. I pulled both crank sensors and had them separated, but my helper got them mixed up. They were filthy. So I cleaned them with contact cleaner spray and reinstalled. Still only firing on passenger side, facing car.

    Debating on trying the crank sensors off dads car.
    I am assuming the DME that was in the back seat is the one not firing?

    Sent from my SM-N910T3 using Tapatalk
    155,000 Miles

  5. #30
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    106
    My Cars
    2001 DINAN 7, 1998 750il
    That's my thinking as well. I swapped the crank sensors one more time in case the 50/50 chance that I'd reinstalled them the same way. No change.

    Coils & wires are new/Bremi.



    Is there a way to replace the faulty DME? Or is this when the scenario goes to find donor V12 & source DME's lock cylinder, ignition switch, EWS & keys and so on?

    ews 3.3 code 204, 39,108
    DME 1.jpgDME1.1.jpgEWS.jpg






    Quote Originally Posted by purplecty View Post
    I am assuming the DME that was in the back seat is the one not firing?

    Sent from my SM-N910T3 using Tapatalk
    Last edited by 740ilDuke; 02-18-2018 at 10:44 PM. Reason: information update
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus - 84k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front. Brand New M-Pars

    1998 - 750il V12 - Arctic Silver - 70k miles
    Bone Stock. Style 4 forged wheels.


  6. #31
    Join Date
    Apr 2007
    Location
    Kansas City, MO
    Posts
    6,684
    My Cars
    2x01 750, 01 740, 98 740
    I see you do indeed have DIS working and reading DME I, are you able to read DME II with it?
    See my E38 parts for sale on eBay: click here!
    PM me here for a 5% discount on any of them!

    WTB/WTT: Ecru Walknappa (US Highline), and black rear armrests, non-skibag. Can trade skibag + skibag armrest.

  7. #32
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    106
    My Cars
    2001 DINAN 7, 1998 750il
    Yeah, I can choose which bank to look at if that's what you mean. The EWS codes are coming from 7-12. I will go out and connect now and verify my findings.
    Being one of the DME's was on the back seat when I bought it, I think that's the issue. It has been "worked on" apparently because it has some numbers on it added by another party. It is however the sequential DME that came in the car with the VIN stamped on it.

    I wonder if the DME that controls bank 2 (7-12) has lost sync and will not allow that side to fire...if that's possible. I've tried to sync the EWS and seem to have issues doing so. However - the car starts every time.

    Back in a few!

    Quote Originally Posted by psjr View Post
    I see you do indeed have DIS working and reading DME I, are you able to read DME II with it?
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus - 84k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front. Brand New M-Pars

    1998 - 750il V12 - Arctic Silver - 70k miles
    Bone Stock. Style 4 forged wheels.


  8. #33
    Join Date
    Jul 2016
    Location
    Chicago, Illinois
    Posts
    3,780
    My Cars
    are slow
    On the E32, if only one MAF is connected it will cut power to the disconnected bank's injectors. If both are disconnected it will cut off fuel completely, check if this trick works on the M73.
    Last edited by XAlt; 02-19-2018 at 02:43 PM.

  9. #34
    Join Date
    Mar 2011
    Location
    Greenville, NC
    Posts
    106
    My Cars
    2001 DINAN 7, 1998 750il
    Well, after another boxing round, failed programming attempts, EWS miscommunication errors and some texting (Thanks PrplCty!) - I decided to take it back to basics. I'd recalled that after swapping DME's the car didn't want to run. So, I did that again - I swapped it. Viola - bank 2 came ALIVE (7-12). Because it sat for over a year, as told by the seller, I think it only ran cyl 1-6 during its final rides - so for 2 years based on what I've pieced together. The DME that was on the back seat was good for the garbage, that's what I've come to.

    The un-tampered with factory DME (VIN label on it) would start the car on either harness. It would run bank 2 (7-12) great - but a show a pegged temp needle and nothing else (tach) would work. I could swap that same DME to bank 1, or 1-6 and it would run that bank fine, with instrumentation working (this was how it had been connected all along) - minus the temp. So, for fun I tried to start the car with the spray painted/seviced DME and it would not start the car or run either bank.

    Next step: I've sourced a DME with the identical hardware code as my working/VIN matched DME. I'll be sending my DME's, EWS and key to DUDMD so that he may work his wizardry. I'm a tech savvy guy, but you learn by doing and I've never delved that deep - so Im shipping my bits off tomorrow, East to West coast.
    I feel confident that my torque bank error and EWS codes will vanish...after all - if theres not a working DME -or a faulty one they have nothing to communicate with.

    Happily the coils, wires and plugs are new Bremi's (done by the tech that was trying to solve this issue..who kept it 14 months). Ive got some less intense things to do in the interim, like CCVs on the back of the plenums, upper windscreen gasket and the driver's side seat control panel. Thats my afternoon tomorrow..then the Dinan will start getting torn apart door panel at a time for the Monsoons. No head unit there yet, so that payoff will come later.

    As soon as my parts have made the 6000 mile cross country trip, I'll report back my findings to the land of V12 Keepers.

    Thank you all, hopefully this thread is nearing the end. :-))))))
    740iLDUKE
    2001 - DINAN 7 Sport - Stratus - 84k miles
    DINAN Springs, Throttle body, Intake, CAI, MAF & Exhaust / Powder-coated Valve Covers & 750 brakes up front. Brand New M-Pars

    1998 - 750il V12 - Arctic Silver - 70k miles
    Bone Stock. Style 4 forged wheels.


Page 2 of 2 FirstFirst 12

Similar Threads

  1. Help needed on a 1998 750iL - M73 engine
    By TxGR8White in forum 1995 - 2001 (E38)
    Replies: 4
    Last Post: 09-02-2016, 08:21 AM
  2. 1998 750iL No acceleration
    By jmindler in forum 1995 - 2001 (E38)
    Replies: 10
    Last Post: 08-08-2013, 08:39 PM
  3. 1998 540i Slow Acceleration and Noise
    By chrisbenejam in forum 1996 - 2003 (E39)
    Replies: 2
    Last Post: 02-27-2013, 10:13 AM
  4. 1998 750il with 125k stll worth a crap or is it about to bust
    By chinaman in forum 1995 - 2001 (E38)
    Replies: 12
    Last Post: 10-10-2005, 12:53 AM
  5. 1998 750il 42k miles White on Tan 4 Sale
    By marshcorona in forum BMW Cars For Sale / Wanted (Panjo)
    Replies: 0
    Last Post: 09-05-2004, 03:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •