Results 1 to 11 of 11

Thread: I need help, no idea about e46 models

  1. #1
    Join Date
    Dec 2005
    Location
    corpus christi, texas
    Posts
    3,992
    My Cars
    86 325e

    I need help, no idea about e46 models

    My mom volunteered me to work on a family friend's car. Its a beautiful blue two door but is an automatic, unfortunately.

    Anyways, the o2 harnes dropped onto the exhaust manifold and now the car only idles. It won't drive when you put it in gear and give it gas. The rpms raise to about 1200 and thats it, no go and no nothing.

    It had 6 or 7 codes when i pulled them, 4 or 5 of them were o2 sensor codes and the other 1 or 2, i do not remember so i will have to pull them again.

    I found a replacement engine harness, the one the connects to the o2s. I am going to swap that in and than see what codes come up but what else could be burned up or fried because of that harness getting melted?

    Thanks
    Still in the game

  2. #2
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,684
    My Cars
    EXOTICS
    Take note of the codes for reference.
    Replace harness, along with inspecting/replacing burnt fuses in fuse pack,
    located in underhood DME fuse box. Clear all codes, followed by a short drive.
    Take note of newly displayed codes, post back with results.




  3. #3
    Join Date
    Dec 2005
    Location
    corpus christi, texas
    Posts
    3,992
    My Cars
    86 325e
    Ok, wont be till next weekend though, thats my next junkyard trip for the harness

  4. #4
    Join Date
    Dec 2005
    Location
    corpus christi, texas
    Posts
    3,992
    My Cars
    86 325e
    I totally forgot to out its a 330i. I don't think that matters though

  5. #5
    Join Date
    Dec 2005
    Location
    corpus christi, texas
    Posts
    3,992
    My Cars
    86 325e
    ok, we go tomorrow to pull the harness. anything weird I need to bring? does it run into the cabin? if so, is there a bunch I need to remove inside? also, a buddy told me something might need to be flashed and that could be something also not helping it to run properly?

    just asking since when I pulled the codes, that the first time I had ever seen inside one of these (very nice looking) new bmws. the newest I have ever owned was a 91 euro 318 with mtech2 kit, and that was way back in the day.
    Still in the game

  6. #6
    Join Date
    Dec 2005
    Location
    corpus christi, texas
    Posts
    3,992
    My Cars
    86 325e
    Ok, you guys didnt meantion there is weird little 5 pack of fuses in the compartment by the brake booster. We pulled the harness from the junkyard car and than found it was actually different than the one we have. And the harness is the trans harness, not the engine harness. I dont know why the trans harness plugs in the way it did but it does. Anyways, we found the secret fuse pack and one of the 20 amp fuses was popped so we replaced it and the car drives and shifts and everything works, just low on power and rough idle.

    It turns out one of the coil packs looked horrible and leaked all its fluid into the chamber in the head that it fits into so we cleaned all that and had no new coil so the car is on hold for new coil packs and a new battery.

    Before we pulled the coil packs, we test drove it to the gas station, thinking it need new gas and and run down the road. That is an impressive car, even running with a misfire and stumble. Its fast and powerful. And its comfortable and good looking, its an all around nice car.

    Here are the before and after codes. Misfires and o2 sensor stuff.

  7. #7
    Join Date
    Dec 2005
    Location
    corpus christi, texas
    Posts
    3,992
    My Cars
    86 325e
    P0050
    P0057
    P0030
    P0306
    P0300
    P0152


    And there are two different hoses not connected under the brake booster intake side area. Both very tiny rubber hoses and one is pulling vacuim lile crazy so i think it goes to the intake or throttle body on the side hooked up but where the other end goes, no idea.

    The other is coming from the firewall, just above and left of the booster. It has a blue stripe on it. It was just hanging.

    The two do not hook together, even though they are the same size

  8. #8
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,684
    My Cars
    EXOTICS
    Quote Originally Posted by MIKYZZ4 View Post
    Take note of the codes for reference.
    Replace harness, along with inspecting/replacing burnt fuses in fuse pack,
    located in underhood DME fuse box
    . Clear all codes, followed by a short drive.
    Take note of newly displayed codes, post back with results.
    Ohhh yes I did, post #2




  9. #9
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,684
    My Cars
    EXOTICS
    Clear all codes, replace coil packs, along with a new set of NGK sparkplugs.
    Once installed, complete a short drive, then re-scan for new codes.
    Post back with results. Can you post the last 7digits of the VIN for vehicle specifics/diagrams?




  10. #10
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,684
    My Cars
    EXOTICS
    I hope you only used OE-OEM replacement coils,
    NOT your nearest AutoZone...etc...junk?




  11. #11
    Join Date
    Dec 2005
    Location
    corpus christi, texas
    Posts
    3,992
    My Cars
    86 325e
    I see you did tell me, sorry.


    He is ordering new coils, i am not sure from where though. He said the no.6 coil he swapped from a junkyard car previously so i knew that was why we kept getting code for no.6 misfire.


    The plan is to do what you said. Je said he is going to call me when the parts get in so i can get the vin then.

    I did notice the build date was 12/03 when i was there. And its paint code is mystic blue. They want to get ride of it once its running. I am tempted to buy it but it would have to be cheap because there are 3 or 4 others on craigslist ranging from 2k to 4k here. They are plain silver, though. If i wasn't getting 2 e30s on the road right now, i would have bought one the first time i sat in this one

Similar Threads

  1. hi guys need help with my 316 e46 not starting no crank
    By shugmacd in forum 1999 - 2006 (E46)
    Replies: 6
    Last Post: 11-21-2009, 07:41 PM
  2. Need Help - No Dash lights
    By Beaner7102 in forum 2002
    Replies: 2
    Last Post: 10-08-2007, 04:58 PM
  3. Need help/info/advice about 99 M3
    By sjM3Ryder in forum 1992 - 1999 M3 (E36)
    Replies: 5
    Last Post: 07-08-2005, 12:28 AM
  4. need help deciding... e36 or e46
    By e36Silvr328i in forum 1999 - 2006 (E46)
    Replies: 8
    Last Post: 05-17-2005, 04:26 PM
  5. Need help!! No reverse.
    By kadaf in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 3
    Last Post: 01-25-2005, 05:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •