Results 1 to 3 of 3

Thread: COG Light on after engine swap

  1. #1
    Join Date
    Feb 2006
    Location
    dearborn, MI, USA
    Posts
    83
    My Cars
    73,98 conv mustang, 83 320i

    COG Light on after engine swap

    Evening everyone have a 2001 BMW 330I, Customer dropped it off couple years ago for a blown head gasket and never heard from them again. It ended up having the typical problems with the head bolt threads pulling out of the block so it sat. Finally last month came across a good deal on an engine just swapped it it in she fires up smoothly but the COG is on and staying on. I do have a pretty High end scanner I can see 17 different modules and interact with them but i am not seeing a transmission/EGS module. It is an automatic. Current faulted modules Engine/DME - Signal CAN EGS. Activation, O2 heater before cat Bank 1 & 2, Activation, O2 heater after cat Bank 1 & 2. Cluster/KO - KOMBI: No CAN Identification (EGS) HVAC Control/IHKA - AUC sensor Lighting/LSZ - Brakelight left faulty Rain/Light Sensor /RLS RLS Control unit

    Any ideas on what way to look would be greatly appreciated
    Last edited by o0darkhaven0o; 01-10-2018 at 07:10 PM.

  2. #2
    Join Date
    Jan 2015
    Location
    Timaru, New Zealand
    Posts
    414
    My Cars
    Two Z3 Roadsters 2L & 3L
    Did you remove the transmission when you did the engine swap?

    There are several fault codes listed in your post about no "CAN EGS". Would suggest that you check all connectors are plugged in on the transmission and EGS.

    If the codes are still there, then trace the wiring looms back towards the DME and KOMBI looking for wiring damage.
    2000 2.0L Z3 Roadster, Mora Red, Individual, Originally from UK, daily drive.
    2000 3.0L Z3 Roadster, Siena Red, BMW Development car, Originally from Germany, Garage Queen
    There is only one thing more pleasurable than working on a Z3, that's driving it top down on a fine day.

  3. #3
    Join Date
    Feb 2006
    Location
    dearborn, MI, USA
    Posts
    83
    My Cars
    73,98 conv mustang, 83 320i
    just pulled the block, once it stops raining going to go and triple check all the harnessing again, all the DME/EGS fuses are good.

Similar Threads

  1. 2004 645Ci has security light on after engine swap now.
    By BlueCrabMafia in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 5
    Last Post: 07-20-2014, 07:24 PM
  2. Anti lock light on after strut swap
    By keithlovin in forum 1991 - 1999 (E36)
    Replies: 3
    Last Post: 03-03-2011, 03:05 PM
  3. Idiot light bugs after engine swap
    By Username in use in forum 1988 - 1996 (E34)
    Replies: 11
    Last Post: 08-24-2008, 08:41 PM
  4. Check engine light on after motor swap
    By dlduke in forum 1991 - 1999 (E36)
    Replies: 9
    Last Post: 07-28-2008, 11:23 PM
  5. Need help with auxilary A/C fan not on after engine swap
    By Adriano in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 0
    Last Post: 02-09-2003, 02:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •