Results 1 to 13 of 13

Thread: Replaced cracked expansion tank but light still coming on

  1. #1
    Join Date
    Feb 2013
    Location
    Lynnwood, WA
    Posts
    47
    My Cars
    02 325i

    Replaced cracked expansion tank but light still coming on

    I just replace my cracked expansion tank and went through the process of filling bleeding filling bleeding and then took the car around the block.

    With the engine at normal operating temperature the coolant light is coming back on. I checked the level in the expansion tank and it was fine.

    The tank came with a new sensor already installed. What are the chances that that is bad? Is there a way to test it without pulling it?

    Thanks in advance.

  2. #2
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,675
    My Cars
    EXOTICS
    Check in the morning on a cold engine, fill to proper level-repeat for 2-3 mornings, all air pockets should be removed by then.




  3. #3
    dworthy's Avatar
    dworthy is offline Wagon meister :) BMW Tech Expert
    Join Date
    Nov 2010
    Location
    Hohenfels, Germany
    Posts
    10,987
    My Cars
    16 220i 05 325it 05 M3
    The level sensor can be pulled without loosing any coolant. You could just swap in the new one and see if the lamp stays off.

    Also double check, triple check the bleeding, as there could still be air trapped in the system.
    Darin
    Current:
    16 220i Active Tourer Platinsilver MET (C08)/Dakota Black (PDSW), P7ACA, P7LDA, P7LHA, P9BDA, 6sp Manual - Wife's new toy!
    05 325it Electric Red(438)/Gray(N6TT) ZCW, ZSP 5sp Manual Back set cover, trunk mat, Euro Infra-Rot front windshield, and mud flaps! Mr. Wagon My new Winter car.
    05 M3 Imolarot II(405)/Gray(N5TT) ZCW, ZPP 6sp Manual C.F. Lip, CSL diffuser, Euro Infra-Rot front windshield and a trunk liner! Mr. Go_Fast Stored for the Winter
    Past:
    95 318is Montreal Blue Met (297)/Beige(K1SN) A Hooptie!
    84 M535i gray market Burgandy Rot Met/Black Leather Lowered by Intrax on bilies, poly everywhere, B&B cat back system, K&N, and a hitch! Da Beast - Still running w/375k+!
    91 316i euro Tizianrot/Gray cloth - E-36 w/M-40 motor, such a beater, but great on gas! Best was 38 MPG
    82 528i euro Saphire Blue Met/Blue Leather RIP
    79 525 euro Green/Green RIP
    79 318 Silver/Black - The first one that got it all started
    M-Flight Member

  4. #4
    Join Date
    Jul 2011
    Location
    Arlington, VA
    Posts
    5,994
    My Cars
    2018 BMW M240i
    What brand are the new twnkbsbd the sensor?

  5. #5
    Join Date
    Feb 2013
    Location
    Lynnwood, WA
    Posts
    47
    My Cars
    02 325i
    Quote Originally Posted by MarcoZandrini View Post
    What brand are the new twnkbsbd the sensor?
    Tank is Behr.

    I popped the cap off this morning and the fluid level was showing full. Started the car up and let it run for a bit and the light came back on.

    There is only the one bleed screw at the expansion tank correct? I cracked it and filled slowly until the fluid was coming out. Will attempt the entire bleed again tonight before I attempt to squeeze my hand down to swap out the sender.

  6. #6
    dworthy's Avatar
    dworthy is offline Wagon meister :) BMW Tech Expert
    Join Date
    Nov 2010
    Location
    Hohenfels, Germany
    Posts
    10,987
    My Cars
    16 220i 05 325it 05 M3
    Behr is the OE supplier to BMW for that part IIRC. Try this: After coming home from a drive, open the bleeder screw and see if any air comes out. Normally there will be a little, and then you will see some coolant. I have to do this a couple of times with the heater on MAX, and when the thermostat opens up, it gets rid of the rest.
    Darin
    Current:
    16 220i Active Tourer Platinsilver MET (C08)/Dakota Black (PDSW), P7ACA, P7LDA, P7LHA, P9BDA, 6sp Manual - Wife's new toy!
    05 325it Electric Red(438)/Gray(N6TT) ZCW, ZSP 5sp Manual Back set cover, trunk mat, Euro Infra-Rot front windshield, and mud flaps! Mr. Wagon My new Winter car.
    05 M3 Imolarot II(405)/Gray(N5TT) ZCW, ZPP 6sp Manual C.F. Lip, CSL diffuser, Euro Infra-Rot front windshield and a trunk liner! Mr. Go_Fast Stored for the Winter
    Past:
    95 318is Montreal Blue Met (297)/Beige(K1SN) A Hooptie!
    84 M535i gray market Burgandy Rot Met/Black Leather Lowered by Intrax on bilies, poly everywhere, B&B cat back system, K&N, and a hitch! Da Beast - Still running w/375k+!
    91 316i euro Tizianrot/Gray cloth - E-36 w/M-40 motor, such a beater, but great on gas! Best was 38 MPG
    82 528i euro Saphire Blue Met/Blue Leather RIP
    79 525 euro Green/Green RIP
    79 318 Silver/Black - The first one that got it all started
    M-Flight Member

  7. #7
    Join Date
    Feb 2013
    Location
    Lynnwood, WA
    Posts
    47
    My Cars
    02 325i
    Quote Originally Posted by dworthy View Post
    Try this: After coming home from a drive, open the bleeder screw and see if any air comes out. Normally there will be a little, and then you will see some coolant. I have to do this a couple of times with the heater on MAX, and when the thermostat opens up, it gets rid of the rest.
    I took car for a spin and brought up to normal temp. Came home and cracked the bleeder screw but only antifreeze came out.

    During test run the light came on, went off and then came back on.

    Guess I check again tomorrow.

  8. #8
    dworthy's Avatar
    dworthy is offline Wagon meister :) BMW Tech Expert
    Join Date
    Nov 2010
    Location
    Hohenfels, Germany
    Posts
    10,987
    My Cars
    16 220i 05 325it 05 M3
    Humm, since you have only coolant coming out, and have normal heat, I would swap the sensor.
    Darin
    Current:
    16 220i Active Tourer Platinsilver MET (C08)/Dakota Black (PDSW), P7ACA, P7LDA, P7LHA, P9BDA, 6sp Manual - Wife's new toy!
    05 325it Electric Red(438)/Gray(N6TT) ZCW, ZSP 5sp Manual Back set cover, trunk mat, Euro Infra-Rot front windshield, and mud flaps! Mr. Wagon My new Winter car.
    05 M3 Imolarot II(405)/Gray(N5TT) ZCW, ZPP 6sp Manual C.F. Lip, CSL diffuser, Euro Infra-Rot front windshield and a trunk liner! Mr. Go_Fast Stored for the Winter
    Past:
    95 318is Montreal Blue Met (297)/Beige(K1SN) A Hooptie!
    84 M535i gray market Burgandy Rot Met/Black Leather Lowered by Intrax on bilies, poly everywhere, B&B cat back system, K&N, and a hitch! Da Beast - Still running w/375k+!
    91 316i euro Tizianrot/Gray cloth - E-36 w/M-40 motor, such a beater, but great on gas! Best was 38 MPG
    82 528i euro Saphire Blue Met/Blue Leather RIP
    79 525 euro Green/Green RIP
    79 318 Silver/Black - The first one that got it all started
    M-Flight Member

  9. #9
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,675
    My Cars
    EXOTICS
    Yes, It seems the clue was obvious in your first post,
    "The tank came with a new sensor already installed."

    Was this a BMW genuine OE or OEM expansion tank?




  10. #10
    dworthy's Avatar
    dworthy is offline Wagon meister :) BMW Tech Expert
    Join Date
    Nov 2010
    Location
    Hohenfels, Germany
    Posts
    10,987
    My Cars
    16 220i 05 325it 05 M3
    Quote Originally Posted by dworthy View Post
    Behr is the OE supplier to BMW for that part IIRC. Try this: After coming home from a drive, open the bleeder screw and see if any air comes out. Normally there will be a little, and then you will see some coolant. I have to do this a couple of times with the heater on MAX, and when the thermostat opens up, it gets rid of the rest.
    Quote Originally Posted by sunnydude View Post
    Tank is Behr.

    I popped the cap off this morning and the fluid level was showing full. Started the car up and let it run for a bit and the light came back on.

    There is only the one bleed screw at the expansion tank correct? I cracked it and filled slowly until the fluid was coming out. Will attempt the entire bleed again tonight before I attempt to squeeze my hand down to swap out the sender.
    Ahem....
    Darin
    Current:
    16 220i Active Tourer Platinsilver MET (C08)/Dakota Black (PDSW), P7ACA, P7LDA, P7LHA, P9BDA, 6sp Manual - Wife's new toy!
    05 325it Electric Red(438)/Gray(N6TT) ZCW, ZSP 5sp Manual Back set cover, trunk mat, Euro Infra-Rot front windshield, and mud flaps! Mr. Wagon My new Winter car.
    05 M3 Imolarot II(405)/Gray(N5TT) ZCW, ZPP 6sp Manual C.F. Lip, CSL diffuser, Euro Infra-Rot front windshield and a trunk liner! Mr. Go_Fast Stored for the Winter
    Past:
    95 318is Montreal Blue Met (297)/Beige(K1SN) A Hooptie!
    84 M535i gray market Burgandy Rot Met/Black Leather Lowered by Intrax on bilies, poly everywhere, B&B cat back system, K&N, and a hitch! Da Beast - Still running w/375k+!
    91 316i euro Tizianrot/Gray cloth - E-36 w/M-40 motor, such a beater, but great on gas! Best was 38 MPG
    82 528i euro Saphire Blue Met/Blue Leather RIP
    79 525 euro Green/Green RIP
    79 318 Silver/Black - The first one that got it all started
    M-Flight Member

  11. #11
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,675
    My Cars
    EXOTICS
    Thanks for exposing my obvious oversight!
    OP check for a dry and clean connection at the tank, as well as the wiring for breaks.
    I would also check if the movement of the red stick in the tank was smooth,
    and not sticking. Test it by having someone push the bobber down,
    while you check the dash light operation.(on a cold engine)




  12. #12
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,675
    My Cars
    EXOTICS
    Btw, the coolant level sensor is at the bottom of the tank,
    why would you "attempt to squeeze my hand down to swap out the sender"?
    Just access it from the bottom.




  13. #13
    Join Date
    Feb 2013
    Location
    Lynnwood, WA
    Posts
    47
    My Cars
    02 325i
    Replaced the sender that came worn the tank with the original and tested all good.

Similar Threads

  1. ABS sensor replacement but light still on
    By OldSkoolBMW in forum 1996 - 2003 (E39)
    Replies: 32
    Last Post: 02-27-2017, 07:59 PM
  2. replaced drivers seat belt buckle,but light still on
    By sorin3q in forum 1996 - 2003 (E39)
    Replies: 2
    Last Post: 11-28-2009, 10:54 PM
  3. Just changed my oil, the light still comes on
    By neilmcg in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 6
    Last Post: 11-27-2006, 08:43 PM
  4. Replace? coolant expansion tank, cap, bleeder screw...
    By old skool in forum 1991 - 1999 (E36)
    Replies: 7
    Last Post: 03-24-2005, 08:56 AM
  5. Just replaced O2 Sensor, Check engine light still on!
    By Snappie in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 3
    Last Post: 03-15-2002, 07:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •