Page 1 of 2 12 LastLast
Results 1 to 25 of 27

Thread: Changed coolant reservoir, car won't start now. 2004 325i

  1. #1
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i

    Exclamation Changed coolant reservoir, car won't start now. 2004 325i

    Found the fault of the coolant leak, the expansion tank was cracked, simple replacement swapped for a new, but car will not start now.

    Car sat in the garage for 3 days, day one I took out the defective tank and was able to confirm the tank was cracked. Waited for two day shipping for the new one and today I replaced it without any issues. Except the car won't start. Lights go on and you can hear a buzz noise in the second position, going to the third position and it won't turn on. I tried this twice and realized the battery may of drained(it is 0f outside, but about 35f in the garage). So I tried jumping it with another car and there was a slight difference as the car did rumble a bit but not start. What am I missing? I took confirmed everything I unplugged was plugged back in.

    Sorry if my explanation doesn't describe it very well, I can make a video if needed.

  2. #2
    Join Date
    Jan 2009
    Location
    Chicago, IL
    Posts
    384
    My Cars
    2001 330i and 2005 330i
    Cooling system wouldn't cause a no-start, unless you accidentally clobbered something during the repair. I think the battery is a more likely culprit. Might have a bad cell...
    Johnny Murray

  3. #3
    Join Date
    Jan 2016
    Location
    Ca
    Posts
    2,020
    My Cars
    2001 525it
    Charge the battery and recheck

  4. #4
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,320
    My Cars
    EXOTICS
    Remove battery and visit your local autoparts retailer for a free battery load test.
    "you have to Pay Large to Look Large"
    Quote - MIKYZZ4


  5. #5
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    Battery is 2-3 months old and I've tried using my jump starter and using another vehicle to jump start it

  6. #6
    Join Date
    Mar 2016
    Location
    Portland, OR
    Posts
    309
    My Cars
    2002 325Ci Cabriolet
    Quote Originally Posted by nuby View Post
    Battery is 2-3 months old and I've tried using my jump starter and using another vehicle to jump start it
    So it cranks but won't start then? Did coolant get somewhere it should not have during removal?

  7. #7
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,320
    My Cars
    EXOTICS
    When batteries are discharged at below freezing temps, they also freeze!
    quit the jump starting, get that battery inside and on a charger,
    for at least an overnight charge and thaw!
    "you have to Pay Large to Look Large"
    Quote - MIKYZZ4


  8. #8
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    I will bring the battery in to charge up and get back to it

  9. #9
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    So it cranks but won't start then? Did coolant get somewhere it should not have during removal?
    Everything just poured straight down into the pan, I didn't see any electrical down there
    Last edited by nuby; 01-07-2018 at 10:53 PM.

  10. #10
    Join Date
    Jan 2007
    Location
    San Francisco, CA
    Posts
    22
    My Cars
    e46 330 Touring, e53 m54
    Most likely you left something on and your battery completely dried. Take it out and charge it, should be good to go.

  11. #11
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    Battery was taken to the shop and completely charged and verified it held it's charge

  12. #12
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    This the buzz sound I get in the second position,
    and the attempt at starting the car.

  13. #13
    Join Date
    Aug 2014
    Location
    Lawrence Kansas
    Posts
    1,103
    My Cars
    2004 325XI/2008 GL320
    Is the fuel pump kicking on?

  14. #14
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    Quote Originally Posted by dhurley34 View Post
    Is the fuel pump kicking on?
    I don't know what I'd be looking for to see if the fuel pump was kicking

  15. #15
    Join Date
    Aug 2014
    Location
    Lawrence Kansas
    Posts
    1,103
    My Cars
    2004 325XI/2008 GL320
    Turn the key on and listen for the pump to prime (buzzing from under the back seat).

    On a side note. When the tank cracked, did the engine run hot? Reason I ask, is that does not sound like a healthy cranking engine.

  16. #16
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    Quote Originally Posted by dhurley34 View Post
    On a side note. When the tank cracked, did the engine run hot? Reason I ask, is that does not sound like a healthy cranking engine.
    The temp never went to an unsafe level, all the tank did was leak through the crack over a span of a couple hours

  17. #17
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,320
    My Cars
    EXOTICS
    The clue I get from that video is to check your CPS sensor.
    "you have to Pay Large to Look Large"
    Quote - MIKYZZ4


  18. #18
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    Quote Originally Posted by MIKYZZ4 View Post
    The clue I get from that video is to check your CPS sensor.
    Wouldn't the dash light up with a couple errors? I'll see if I can check out the cps, I'm assuming your talking about the intake correct?

  19. #19
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,320
    My Cars
    EXOTICS
    Crankshaft Position Sensor, or as BMW calls them "pulse generator", as there is not much movement of the tach during engine turnover.
    Try to confirm with a diagnostic scan, or checking and testing of the connections and sensor resistance(ohms).
    "you have to Pay Large to Look Large"
    Quote - MIKYZZ4


  20. #20
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    Quote Originally Posted by dhurley34 View Post
    Turn the key on and listen for the pump to prime (buzzing from under the back seat).
    Fuel Pump is definitely working

  21. #21
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    Update- CPS replaced, it sounds a tad bit different but still no start. Is anyone familiar with that buzz noise coming from the engine area?

  22. #22
    Join Date
    Aug 2014
    Location
    Lawrence Kansas
    Posts
    1,103
    My Cars
    2004 325XI/2008 GL320
    That buzz is the Disa valve. Its normal.

  23. #23
    Join Date
    Mar 2017
    Location
    Norwich, Connecticut.
    Posts
    345
    My Cars
    E46,MB,Volvo,Audi,MG..
    Easy is to check battery and alternator function too.....Put a meter on the battery before start...next morning...12.6 volts is healthy for younger batteries...yet 12.1, with 3 to 6 year old batteries is also sufficient for starting and system wide acceptance. Please realize older batteries develop resistance even as they continue to service....5 year old, and older batteries create greater demand from your alternator. Alternators in our cars are costly to service, be it the regulator or complete removal and replacement of the alternator....don't wait for the batteries end life, I personally switch them out every 3 years.

  24. #24
    Join Date
    Dec 2013
    Location
    Chicagoland area
    Posts
    3,320
    My Cars
    EXOTICS
    Where are you located?
    Maybe someone near you with a diagnostic scan-tool can help, and may provide the clue you need.
    These are modern cars with computerized electronic diagnostic systems, no need for guessing.

    Btw, I would return that CPS if possible, since that doesn't seem to be the cause of no start,
    but before you do - take another video.
    "you have to Pay Large to Look Large"
    Quote - MIKYZZ4


  25. #25
    Join Date
    May 2015
    Location
    United States
    Posts
    21
    My Cars
    2004 BMW 325i
    Quote Originally Posted by MIKYZZ4 View Post
    Maybe someone near you with a diagnostic scan-tool can help, and may provide the clue you need.
    These are modern cars with computerized electronic diagnostic systems, no need for guessing.
    I have OBD scann tool, but the engine needs to start in order to read the codes. I'm looking into the starter now, checking out vids on how to do it.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replaced spark plugs and car won't start now
    By miamikk in forum 2004-2010 (E60,E61)
    Replies: 8
    Last Post: 12-25-2015, 12:31 AM
  2. Changed Steering Wheel, car won't start now.
    By c0lin46and2 in forum 1991 - 1999 (E36)
    Replies: 27
    Last Post: 04-06-2013, 07:37 PM
  3. Help! Battery died, car won't start now
    By E34play in forum 1988 - 1996 (E34)
    Replies: 14
    Last Post: 02-27-2013, 05:14 PM
  4. Car won't start now...fuel issue?
    By WanaBm3 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 5
    Last Post: 08-04-2009, 01:02 AM
  5. Car won't start now....HELP!
    By SkunkApe in forum 1992 - 1999 M3 (E36)
    Replies: 13
    Last Post: 12-23-2006, 12:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •