Results 1 to 13 of 13

Thread: E46 M3 stalling at random

  1. #1
    Join Date
    Oct 2015
    Location
    Hanford, Ca
    Posts
    24
    My Cars
    2002 BMW M3 coupe

    E46 M3 stalling at random

    Hey guys, sorry if I posted this in the wrong section, im new to the forums, I've been a member for a while, but I have been inactive. Anyway, I have a 2002 M3, it was originally SMG and it got converted to manual by one of the previous owners.
    Some facts about the car
    - AA stage 2 supercharged
    - Been supercharged for the last approximately 50k miles
    - Catless headers (not sure if it affects my issue)
    - I have a small boost leak (one of the couplers has a tiny tear in it, but I doubt that affects idle)
    - The car idles smoothly.
    - The car stats up with no hesitation.
    - On cold starts, the idle isn't bouncy whatsoever.
    - No check engine light or Eml on.
    Now the situation; Say I'm driving my car, and I'm approaching a stop, and I clutch in; as I approach a stop, the car will drop the rpms to right around 500/600 and then come to a stall. I'll then turn the engine back on, and sometimes the car starts and stalls again, and sometimes the idles bounce a little, but then the returns to normal. I know its an issue with the car and not my driving ability because it even does this when I throw the car in neutral as I'm approaching a stop, and it does the same thing! This issue is more pronounced when the car is warmer/at operating temp. Even when the car is cold, I notice my rpms drop to around 600 rpm's but it doesn't stall, it goes back up to around 800/900 rpm's. Another thing worth mentioning is that sometimes (only happened 3 times so far) if the car is just sitting idling for a while, it just randomly stalls, no warning, no idle issues, just randomly kills itself.

    Could anyone help me out? I took it to o'reillys to see if theres any pending codes (no ses/eml), and their scanner couldn't communicate with my car or something like that, so I have no clue if there are any pending codes. And to top it off, no engine malfunction lights on the dash (I have the smg cog light but thats from the conversion, and my traction light but thats due to my steering angle sensor).
    I have already taken apart my icv and cleaned it, and that didn't solve the issue. Most other people say clean up the MAF, but I don't think AA uses MAF's with their supercharger systems, I believe they run alpha-N, so thats another item to be crossed off the list. I was thinking maybe it could be a crank sensor or intake/exhaust cam sensor, but wouldn't there be a check engine light?
    Thank you guys in advance, any ideas as to what It could be? fuel adaptations? sensors? neutral safety switch? o2 sensor?? I live in the middle of no where, theres no race shops or anyone qualified to work on these things, and I'm definitely not taking my car to the average Joe mechanic, so any help would be greatly appreciated. Ill try and see if I can record it and ill post up a link to the video.
    Thanks a lot guys,
    Karim
    EDIT:
    I should also mention, the car was SMG when AA tuned it, could it be a software issue now that the car is manual?
    Last edited by karimnassef; 11-26-2017 at 02:43 PM.

  2. #2
    Join Date
    Jan 2006
    Location
    Gateway To The West
    Posts
    671
    My Cars
    2001 BMW M3
    Sounds like a vacuum leak. Check all the vacuum/air lines into the air box, including those underneath.

  3. #3
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    459
    My Cars
    1997 M3/4/A
    You mention you have a tear in your coupler, which coupler? That might be where your vacuum leak is.

  4. #4
    Join Date
    Oct 2015
    Location
    Hanford, Ca
    Posts
    24
    My Cars
    2002 BMW M3 coupe
    Quote Originally Posted by Feffman View Post
    Sounds like a vacuum leak. Check all the vacuum/air lines into the air box, including those underneath.
    When I cleaned up the ICV, I examined all the hoses in that area, no tears in any of the charge pipes, or couplers up top, even the tiny lines are ok.

    - - - Updated - - -

    Quote Originally Posted by brokeazz View Post
    You mention you have a tear in your coupler, which coupler? That might be where your vacuum leak is.
    The tear is in the coupler that connects the cold side of the intercooler to the charge pipe. But honestly, its so small, like not even half an inch long, I'm not sure how that would affect the idle. I can only see it as a boost leak.

  5. #5
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    459
    My Cars
    1997 M3/4/A
    Get yourself INPA software and try resetting adaptations to see if that will help. Have you checked the little vacuum line at the end of the fuel rail by the firewall? I believe it feeds the FPR and the 2 bpv.

  6. #6
    Join Date
    Oct 2015
    Location
    Hanford, Ca
    Posts
    24
    My Cars
    2002 BMW M3 coupe
    Quote Originally Posted by brokeazz View Post
    Get yourself INPA software and try resetting adaptations to see if that will help. Have you checked the little vacuum line at the end of the fuel rail by the firewall? I believe it feeds the FPR and the 2 bpv.
    I've been busy with finals, and will through next week, but hopefully after I can diagnose it, I hope clearing adaptations solves this issue. I can't find any visible vacuum leaks anywhere, ill get a proper smoke test done though.

  7. #7
    Join Date
    Nov 2011
    Location
    canada
    Posts
    146
    My Cars
    2004 E46 M3 Cab

    E46 M3 stalling at random

    Most likely Vanos solenoid then cam sensor Symptoms at first it is intermittent stalling.


    Sent from my iPhone using Tapatalk
    Last edited by being3; 12-08-2017 at 12:24 PM.

  8. #8
    Join Date
    Oct 2015
    Location
    Hanford, Ca
    Posts
    24
    My Cars
    2002 BMW M3 coupe
    Quote Originally Posted by being3 View Post
    Most likely Vanos solenoid then cam sensor Symptoms at first it is intermittent stalling.


    Sent from my iPhone using Tapatalk
    If it was Vanos solenoids wouldn't the car constantly misfire or just run very awfully? at first I thought it was that, but the car idles smoothly, runs smoothly, even at wot there are no hiccups. Am I mistaken or what do you think? I assume it would have misfires before it starts stalling the car.
    EDIT:
    Sometimes when I'm stopped and rev the car, the rpms drop a little, and then it revs up. Other times it does not do that. Idk if that helps the diagnosis, but thats something it does occasionally.
    Last edited by karimnassef; 12-08-2017 at 09:43 PM.

  9. #9
    Join Date
    Nov 2011
    Location
    canada
    Posts
    146
    My Cars
    2004 E46 M3 Cab

    E46 M3 stalling at random

    Like I said it starts intermittently then it progress to complete failure ... depends where the cams are and what rpm when it starts to fail. Use inpa and view the Vanos monitor till it fails. It may not be it but itís what happened to me. Took me months to figure it out and every one said I was wrong till I replaced it and car can fine


    Sent from my iPhone using Tapatalk
    Last edited by being3; 12-08-2017 at 09:54 PM.

  10. #10
    Join Date
    Oct 2015
    Location
    Hanford, Ca
    Posts
    24
    My Cars
    2002 BMW M3 coupe
    GUYS! ok, so I was doing some more diagnosis and I noticed a few thing.
    1- O'reillys bosche code reader couldn't scan my car, it kept saying "could not communicate"
    2- Autozones scanner connected to my car, and there were zero codes. of course their scanner isn't that high tech and can't read stored codes, but for now, no codes & no check engine lights.
    3- Idk what pepboys uses but they couldn't bring up any codes either.

    most important observation!!!!!!!!!!!!!!
    4- Ive noticed that when I'm approaching a stop and I clutch in (or throw it in neutral) and my rpms are below 2k rpms, the car doesn't stall! the rpms just drop to below 900 to around 500, but it catches itself and goes back to normal idle. Sometimes it even dipped below 500, but it still caught itself! So I started playing around with it, and noticed the car would stall if I clutch in or throw it in neutral if im above 3k rpms. This leads me to think its an air/fuel issue. What do you guys think?air and fuel trim adaptations reset??? or am I being too hopeful?

    Id assume its vanos, or tb actuators, but at the same time I have no codes, car starts without hesitation, and the car idles fine and pulls hard. This issue is getting really annoying, but I'm being hopeful.

    - - - Updated - - -

    Quote Originally Posted by being3 View Post
    Like I said it starts intermittently then it progress to complete failure ... depends where the cams are and what rpm when it starts to fail. Use inpa and view the Vanos monitor till it fails. It may not be it but it’s what happened to me. Took me months to figure it out and every one said I was wrong till I replaced it and car can fine


    Sent from my iPhone using Tapatalk
    I have no clue and dont know anyone with an inpa software or cable, I might have to invest into that.

  11. #11
    Join Date
    Oct 2015
    Location
    Hanford, Ca
    Posts
    24
    My Cars
    2002 BMW M3 coupe
    Anybody have any ideas? no codes, nothing to lead me to anything :/

  12. #12
    Join Date
    Mar 2017
    Location
    Norwich, Connecticut.
    Posts
    292
    My Cars
    E46,MB,Volvo,Audi,MG..
    Have a propane torch?...maybe a bernz-0-matic?????MOst have one....................Start engine.....lift hood...open BERNz....wave over all vaccum hoses ....if engine increases rpm....mark that hose.

  13. #13
    Join Date
    Oct 2015
    Location
    Hanford, Ca
    Posts
    24
    My Cars
    2002 BMW M3 coupe
    Ive had enough with my m3. Idk what the heck is going on. The car still stalls (no boost leaks or vacuum leaks anywhere), and the car should be 500 hp (old level 2 AA supercharger kit). Tell me why I lost to a 428i? a stock e46 M3 should still pull on a stock 428. I know its not that I can't drive, because when I had my lightly modded NA e46 I was keeping up with cars that I shouldn't have... cough* 5.0s cough*. Its just really disappointing to have a car modified to this degree and it looses to a 428, like what the heck. And to make matters worse, the car is still stalling with no engine codes popping up. And to add the cherry on top, now my car doesn't want to rev. Say im cruising and I drop it down a gear, when I go to rev match, the car will only rev like 100/200 rpms, the rpms barely blip. And its noticeable, when I rev math, ill hit the gas more than 60% and the car revs and chokes up/ doesn't rev higher. WHAT COULD EVEN CAUSE THIS. my car is hatless (tuned), has no MAF, genuine AA tune. fill up with 91 fuel, my fuel system isn't clogged, I just dont get it. Any ideas? im in college and would really prefer not to take it to a mechanic, but if thats what it has to come too. Like whats wrong with this car. AND IT IDLES GOOD *for the mostpart*. I want to say its a tune issue but could it possibly be the supercharger itself is messed up internally? it builds pressure, but when it vents, its not nearly as loud as it should. Compared to other 8psi cars, it seems like theres low boost pressure, I cant tell because I dont have a boost gauge.

Similar Threads

  1. e36 M3 with e46 M3 wheels at my apartment complex
    By Slow4Door in forum Wheels and Tires
    Replies: 0
    Last Post: 07-25-2007, 10:14 PM
  2. What does an E46 M3 need at 60k miles (besides Inspection II)?
    By jbond04 in forum 2001 - 2006 M3 (E46)
    Replies: 9
    Last Post: 05-23-2007, 09:29 PM
  3. E46 M3 GTR at the Nurburgring by Hans Stuck
    By Lance Racing in forum 2001 - 2006 M3 (E46)
    Replies: 39
    Last Post: 05-01-2007, 12:43 AM
  4. E46 M3 overheating at the track?
    By singletrack1 in forum Track, Auto-X & Drag Racing sponsored by Bimmerparts.com
    Replies: 13
    Last Post: 09-19-2005, 04:53 PM
  5. Are any Dealers selling E46 M3's at less than msrp?
    By rrrr in forum 2001 - 2006 M3 (E46)
    Replies: 10
    Last Post: 02-08-2004, 01:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •