Page 3 of 4 FirstFirst 1234 LastLast
Results 51 to 75 of 76

Thread: Airbag Control Module, Internal Error (F0, 240 errors). Finally found a fix!

  1. #51
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    Quote Originally Posted by cngizbleevng View Post
    Abel, I opened INPA to see if I had the F0 code. I've read and cleared engine codes with it before, but where do I read codes related to this system? I noticed there was an airbag section and also a bunch of ABS sections.



    Attachment 623591


    I have the intermittant airbag light, especially once the car is warm or the ambient temperature is hot.
    I believe it's under the Body menu, first item.


    Intermittent airbag light has been F0 error for a couple of users now.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  2. #52
    Join Date
    Dec 2017
    Location
    Utah
    Posts
    13
    My Cars
    528i TA
    This is a really dumb question, but I have a private message typed up, but it just says my private message message is "stored" and nothing shows in "sent" messages. Can you give me some guidance on how to actually "send" it? :-)

    Quote Originally Posted by 328 Power 04 View Post
    The airbag fault will not cause no crank.

    The F0 internal ecu error is the main problem and does not allow the airbag module to clear any codes or work properly.


    Send me a PM (private message) on here, and we can work something out. I suspect your intermittent no crank may be the EWS module or possibly crankshaft position sensor (if it hadn't been checked). I replied in your other thread.

  3. #53
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    Well I received all (10) messages..
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  4. #54
    Join Date
    Mar 2013
    Location
    Minnesota
    Posts
    251
    My Cars
    2000 M Roadster
    Abel, My roadster is in storage right now, however it went in with the airbag light on. I will read the error code when I get it out, I may need your help.
    Mike
    2000 Alpine White over Estoril Blue & Black Nappa with a Dark Blue Softtop, 1 of 43.

  5. #55
    Join Date
    Dec 2017
    Location
    Utah
    Posts
    13
    My Cars
    528i TA
    The latest update. I had the negative battery cable off for a few days and fully charged the battery. I was planning on taking the car to an independent bmw shop and I put the battery in and it started right up. I turned it off and on a few times. I drove the car down to the shop but the gates were locked, so I decided to take it a few days later.
    I went to start it and again no start....
    I did however try something the independent shop suggested I do- I jumpered the two black wires on the ews and when itís jumpered the car turns over without starting every time I turn the key. (Does this tell me the ews is good and maybe just needs re-aligned with the DME?
    Thanks again for the assistance!

  6. #56
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    Quote Originally Posted by cmfiero View Post
    The latest update. I had the negative battery cable off for a few days and fully charged the battery. I was planning on taking the car to an independent bmw shop and I put the battery in and it started right up. I turned it off and on a few times. I drove the car down to the shop but the gates were locked, so I decided to take it a few days later.
    I went to start it and again no start....
    I did however try something the independent shop suggested I do- I jumpered the two black wires on the ews and when it’s jumpered the car turns over without starting every time I turn the key. (Does this tell me the ews is good and maybe just needs re-aligned with the DME?
    Thanks again for the assistance!
    This just tells me that the EWS *may* be failing, or its power source.

    Again, no crank is not a problem with dme-ews alignment.

    You need to read EWS codes. But now that you tried to power up the car without EWS, you caused some false errors that have the capacity of throwing someone's diagnostics flow chart off.
    Last edited by 328 Power 04; 03-14-2018 at 12:16 AM.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  7. #57
    Join Date
    May 2016
    Location
    melbourne ,australia
    Posts
    19
    My Cars
    2000 Z3 2.0 manual
    Oh no! I drove my car with the passenger seat removed yesterday and now, on plugging things back in, I get error 240 (aswell as a couple of other errors that are now not active, but that I can't clear).

    Part number-8386192, Hardware number- 38, Software number - 25, Control unit MRS3, Version 2.08

    I'd love to fix the original part if I could rather than getting a replacement to keep things a known quantity with the vehicle.

    Hi Abel, is there any chance I could post it to you from Australia? :-)

  8. #58
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    Replied to PMs.

    Also, I did a Temic MRSZ4 (very late BMW Z3) module last week. This one cleared, but error came right back due to obvious corrosion. It had a different microcontroller and very different mainboard layout, greatly complicating things.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  9. #59
    Join Date
    Sep 2005
    Location
    Boiling Springs, PA
    Posts
    5,779
    My Cars
    '02 Z3 3.0i/'10 Cooper S
    Abel, now that the warmer weather is back, I'm getting the intermittent airbag light on the dash.

    Can I send the module to you for reprogramming and still drive the car without it?

  10. #60
    Join Date
    May 2016
    Location
    melbourne ,australia
    Posts
    19
    My Cars
    2000 Z3 2.0 manual
    I took mine out of the car today to be able to post to Abel and can confirm that the car runs fine without it.

    I found it curious that without the module, the car gave no airbag warning whatsoever. The only way you'd notice it wasn't active (other than having an accident!) is that the airbag light doesn't temporarily come on when starting the car as it normally would. I would have thought that by default, the dash would light up let you know that the module was not present/ working if removed . It's not as though there were any Z3s sold with airbags optional or am I wrong? As it is, people could unplug the module and sell a car to someone not looking for the temporary warning light to go out when starting the car and the purchaser would probably think everything was ok. Seems strange to me.



    Quote Originally Posted by cngizbleevng View Post
    Abel, now that the warmer weather is back, I'm getting the intermittent airbag light on the dash.

    Can I send the module to you for reprogramming and still drive the car without it?
    I
    Last edited by mobilenet; 04-15-2018 at 06:03 AM. Reason: Clarification

  11. #61
    Join Date
    Sep 2005
    Location
    Boiling Springs, PA
    Posts
    5,779
    My Cars
    '02 Z3 3.0i/'10 Cooper S
    Yeah, I don't really know whether my airbags work or not, when I've got the intermittent airbag light. Are they only not working when the light is lit, then working again when the light goes out? Thanks for the info mobilenet.

  12. #62
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    Quote Originally Posted by cngizbleevng View Post
    Yeah, I don't really know whether my airbags work or not, when I've got the intermittent airbag light. Are they only not working when the light is lit, then working again when the light goes out? Thanks for the info mobilenet.
    Intermittent light can be 2 things: A seat belt latch/tensioner 'minor' fault, where the light comes on with ignition, but goes off after some 30 seconds.. or internal error. When it's internal error + no light coming up even at ignition on, it will NOT fire the airbags at all. Internal error is a 'major' fault, that will disable the system because it doesn't know the condition of the airbag system as a whole.

    If you get a scan, I can help solve it.





    Just did the airbag module all the way from Australia.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  13. #63
    Join Date
    May 2016
    Location
    melbourne ,australia
    Posts
    19
    My Cars
    2000 Z3 2.0 manual
    Thanks a million Abel!

    I haven't checked my work email over the weekend, so didn't know you'd been successful.

    Greatly appreciate your help



    Quote Originally Posted by 328 Power 04 View Post
    Intermittent light can be 2 things: A seat belt latch/tensioner 'minor' fault, where the light comes on with ignition, but goes off after some 30 seconds.. or internal error. When it's internal error + no light coming up even at ignition on, it will NOT fire the airbags at all. Internal error is a 'major' fault, that will disable the system because it doesn't know the condition of the airbag system as a whole.

    If you get a scan, I can help solve it.





    Just did the airbag module all the way from Australia.

  14. #64
    Join Date
    Sep 2005
    Location
    Boiling Springs, PA
    Posts
    5,779
    My Cars
    '02 Z3 3.0i/'10 Cooper S
    Quote Originally Posted by 328 Power 04 View Post
    I believe it's under the Body menu, first item.

    Intermittent airbag light has been F0 error for a couple of users now.
    Quote Originally Posted by 328 Power 04 View Post
    Intermittent light can be 2 things: A seat belt latch/tensioner 'minor' fault, where the light comes on with ignition, but goes off after some 30 seconds.. or internal error. When it's internal error + no light coming up even at ignition on, it will NOT fire the airbags at all. Internal error is a 'major' fault, that will disable the system because it doesn't know the condition of the airbag system as a whole.

    If you get a scan, I can help solve it.
    The airbag light comes on when I start the car (as it should) and then goes out along with the check engine and other indicators. Later during the drive, especially when the outside temperature is higher, it comes on for a few seconds and then goes off again. It reappears for a few seconds every few minutes, and the longer the drive and hotter the temperature, the more frequently it appears.

    I couldn't get any codes to come up on INPA, airbag or otherwise.

  15. #65
    Join Date
    Sep 2005
    Location
    Boiling Springs, PA
    Posts
    5,779
    My Cars
    '02 Z3 3.0i/'10 Cooper S
    Where do I find the module in here? I used a flashlight but didn't see it anywhere.
    IMG_20180428_174316237.jpg

  16. #66
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    Quote Originally Posted by cngizbleevng View Post
    Where do I find the module in here? I used a flashlight but didn't see it anywhere.
    IMG_20180428_174316237.jpg
    IMG_20180428_174316237ed.jpg

    Somewhere in that general area (click on it to see the crude arrow i drew in), imagine it as it would be right behind your clock area.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  17. #67
    Join Date
    Jun 2016
    Location
    Odessa, TX
    Posts
    852
    My Cars
    2000 BMW Z3 2.8 Roadster
    If you look through the obdii connector opening here, you can see the side of the SRS module. IMG_20171202_164831.jpg

  18. #68
    Join Date
    Aug 2008
    Location
    Norway
    Posts
    34
    My Cars
    Automobile
    I've had the 240 error on my MRSZ3 v.2.5 module all through the winter and just now when outsidetemp is warmer, i could work on the system. My module was permanently locked up. I used Carprog v.10.05 and some soldering to rewite memory with a blank. Plugged it in and it was all fine. That is until a couple of days later when i got the red light again. It was the 240 error again only. After research i found it happens constantly when i start in cold weather. It never ever happens in warm weather OR after first start og the car the the same day. The reason the module recovers by itself even with the 240 error logged i think is the internal counter in the module. When the counter reaches 256 (16-bit ECU) then its permanently locked. That was the status of the counter when my module was locked up before i cleared it. So, the point is WHY does it act EXACTLY like this always now. Its no bad conn in sensors that im sure of. I also dont think its to do with expanding/contracting lines on the circuitboard. Im starting to wonder about two scenarios. First that the module is throwing that error when the battery isnt as good as it should. Like if capacity is going bad and when you start the engine the voltage drops too low for a fraction of a sec. I say this cause when weather is cold voltage will drop more than on a warm weather start. I havent yet gotten a new battery to try. Mine is old and had been discharged to around 11V once, but now it manages 12.3V morning after, but its capacity may be very degraded anyway. The other scenario is that the capacitors are getting bad. I came accross a post that some MB TEMIC ECU's had bad capacitors made around 2000/2001. Not saying its the cause, but im really wondering about voltage drop being the issues for the 240 error as long as sensors are fine. Any opinions on this?
    ----------------------------------------
    BMW e39 523ia Touring 04/2000
    BMW e39 528ia Sedan 01/2000
    ----------------------------------------

  19. #69
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    You can definitely trigger error 240 with wrong components or loose intermittent connections.

    I have received many modules from all over, many with less than 256 hits on the error counter for any given error..
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  20. #70
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    Now you may be onto something with the hardware failure.. for the ones that sporadically turn on the light and off, without codes or errors. That is concerning to me for some kind of hardware failure
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  21. #71
    Join Date
    Aug 2008
    Location
    Norway
    Posts
    34
    My Cars
    Automobile
    Just did a test now. Its 3 degC outside and when i turn on ignition without starting the car the light comes on, then goes out for 3 secs, then comes back on permanent. When i read errors its the 240 error only. Later in the day when warmer then it works again and never comes on again. If it indeed is a circuitboard trace/solderpoint which is contracting/expanding doing this, then im pretty much out of luck anyway cause its laquer on it and too much work trying to resolder. I do have a V.3.0 module also. Wonder if it will work better?
    ----------------------------------------
    BMW e39 523ia Touring 04/2000
    BMW e39 528ia Sedan 01/2000
    ----------------------------------------

  22. #72
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    That's amazing how predictable your module failure is. I would try a reflow of everything before replacing it. If you have an E39 MRSZ3 v3.0, then it should swap correctly. I have had 2 v3.0 with 240 error though, so it's not impossible.


    Good flux plus targeted hot air. I would avoid baking it because the accelerometer is housed in simple looking plastic that would melt quickly.
    Last edited by 328 Power 04; 04-30-2018 at 08:27 AM.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  23. #73
    Join Date
    Aug 2008
    Location
    Norway
    Posts
    34
    My Cars
    Automobile
    Yes, maybe i will try the reflow, but what about the v.3.0 module. U think its more stable and better luck with that than the v.2.5?
    ----------------------------------------
    BMW e39 523ia Touring 04/2000
    BMW e39 528ia Sedan 01/2000
    ----------------------------------------

  24. #74
    Join Date
    Jul 2004
    Location
    Houston, TX
    Posts
    8,793
    My Cars
    MCoupe, 328is, Z3, TDI
    Yes, the v3.0 seems to be improved.
    But you have to check for any wiring or component differences that go along with it, if any.

    In the case of the Z3, some updated years' modules required updated seat belt tensioners/latches.
    -Abel

    - E36 328is ~210-220whp: Lots of Mods. RomRaider self-tune work in progress.
    - 2000 Z3: Many Mods.
    - 2003 VW Jetta TDI Manual 47-50mpg: Many Mods ~300ft/lbs tq, diesel, daily beater. Love/Hate relationship.
    - S52 Estoril M Coupe
    - 2014 328d Wagon, self-tuned, 230hp/330ft-lbs

  25. #75
    Join Date
    Aug 2008
    Location
    Norway
    Posts
    34
    My Cars
    Automobile
    Today i replaced the v.2.5 with my v.3.0 and it seems ok for now. Had shadowerrors (yellow color in BMW Scanner) on all sensors after install, but they cleared without a problem. So will try it out for a few days and see. If it doesnt work i will need to install the MRSZ4 system which i have both crashsensors and the ECU on hand. I have a feeling it maybe one of more of the three capacitors on the v.2.5 board which is going bad, and their the only components in reality which is easy to replace. But that will be a project for later if needed.

    mrsz3.jpg
    ----------------------------------------
    BMW e39 523ia Touring 04/2000
    BMW e39 528ia Sedan 01/2000
    ----------------------------------------

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. F/S AIRBAG CONTROL MODULE & SIDE BAGS MODULES FROM A 98 M3
    By Corra in forum Exterior Lighting & Body Parts
    Replies: 23
    Last Post: 09-06-2012, 03:14 AM
  2. thinking about sending airbag control module out
    By KUSA325is in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 0
    Last Post: 04-08-2009, 08:17 AM
  3. Airbag control module
    By matt325ibmw in forum 8 Series (E31)
    Replies: 2
    Last Post: 06-20-2008, 03:55 PM
  4. F/s Airbag Control Module & Side Bags Modules From A 98 M3
    By Corra in forum Exterior Lighting & Body Parts
    Replies: 4
    Last Post: 02-08-2008, 02:49 PM
  5. Airbag Control Module
    By havnfun328 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 3
    Last Post: 10-29-2007, 02:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •