Page 1 of 2 12 LastLast
Results 1 to 25 of 28

Thread: Searching idle and bogs down under throttle

  1. #1
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd

    Searching idle and bogs down under throttle

    Hi folks. Long time lurker, first time poster. Struggling with my e46. Just did the vamps seals, Ccv, cleaned iac and throttle body. Also shocks, springs, brakes and front axles. Ran great for a few weeks except for the odd time it would start and die immediately then start fine. One day it suddenly crapped out on my wife on a short trip. When I came to get her I found the car would start fine but searched between 800-1400 rpm and would bog down when given any gas.
    The EML light is on and dsc and brake lights come on after a little idling.
    I have since changed the fuel filter, o2 sensors and cam position sensors (i know I shouldn't throw parts at the problem but it does have 270,000kms). I went back through my ccv and throttle body areas looking for loose connections but didn't find anything. I'm getting a steady 50psi at the fuel rail. No engine codes other than bank 2 o2. Any insight would be greatly appreciated. Please let me know if I can provide more info. I'm so deep into this old car right now! Thanks.

  2. #2
    Join Date
    May 2010
    Location
    Honolulu, Hawaii
    Posts
    509
    My Cars
    E30, E9, E36, E32
    searching idle is usually a sign of a vacuum leak. the common solution is to get the car professionally smoke tested.

    that you've been well and truly into the car, yet not acknowledging that you're a professional mechanic, brings up Mechanic's Rule: look for trouble with whatever you did last. Unfortunately that's quite a list.

    Crank position sensor would be the next thing I'd test.
    Charlie

    Your mission, should you decide to accept it, is to add value to these threads, either by pictures or by descriptions, so the next person with the same or similar problem stands on your shoulders.

  3. #3
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    Thanks for the reply Honolulu. Just finished rechecking everything. Nothing of note except i noticed what looked like an open vacuum port on the rear drivers corner of the intake. Plugged it with no change. Are there other causes of searching idle? When I apply the gas slowly the motor surges up and then almost dies over and over at the same rhythm as during idle. Does that sound like symptoms of bad crank sensor? It's not my dme is it? The fact that I'm not getting any codes seems weird.

  4. #4
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    I would bring it to a professional. It there really isn't anyone within an hour of here I could bring it to. Drawback of living in the sticks.

  5. #5
    Join Date
    Dec 2013
    Location
    SKOKIE,ILL
    Posts
    2,355
    My Cars
    EXOTICS
    Feel around or use a mirror, there can be more than one vacuum port back there missing a rubber cap,
    or hose connection. Remove and check for any cracks on rubber intake boots, very common.
    A pro smoke test is the best confirmation for locating any and all intake leaks.
    "Choosing the correct shop is as important as the correct diagnosis

    Former owner of a Red RL411 wannabe owner of pictured vehicle

  6. #6
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    Okay. I managed to smoke test this bad boy with a cookie tin, a pressure regulator, shop air and a little fire. No leaks that I could see. The brake booster also gives an audible pop when I pull the vacuum hose too, which tells me there is vacuum there anyway. It also runs way worse when that's unplugged.
    I was reading that the wiring harness at the throttle going bad is a fairly common failure and went loooking. Noticed that the plug on the throttle body doesn't click in properly. I pulled it and the car runs the same! I even hit the accelerator with it unplugged and it did the same surge and stumble thing it's been doing.
    How is that even possible? How can there be throttle response without signal going to the throttle body?
    Unless it's delivering fuel but not more air! OMG I might have just figured it out. Do I need a new throttle body?

  7. #7
    Join Date
    Dec 2013
    Location
    SKOKIE,ILL
    Posts
    2,355
    My Cars
    EXOTICS
    No codes? What type of tool or software are you scanning with?
    "Choosing the correct shop is as important as the correct diagnosis

    Former owner of a Red RL411 wannabe owner of pictured vehicle

  8. #8
    Join Date
    Jun 2009
    Location
    Vermont
    Posts
    30,849
    My Cars
    97 328i Vert, 98 M3 Vert
    You need to get that thing on a scanner and look at the live data. That data should point you in the right direction. Besides that a faulty "precat" 02 sensor can sometimes cause a very rythmic idle bounce. A small vacuum leak will usually cause the idle to bounce as you're coming to a stop. It will go from 1000 to almost 0 then 900 to 200 then 800 to 500 then it will eventually settle in at 750-800. O2 sensor just slowly goes from 1000 to 400 back to 1000 back to 400 etc.

    Your symptoms could be caused by a dozen different things. Doing a hunt and peck approach is not a good idea. Get a scanner and do it the right way.

  9. #9
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    Ok. You're right. Which scanner should I get to read codes on this thing? Is there one that reads abs codes on this thing and works on, say my pickup?

  10. #10
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    For the record, there are no CEL codes. The EML light, dsc, brake etc are on.

  11. #11
    Join Date
    Dec 2013
    Location
    SKOKIE,ILL
    Posts
    2,355
    My Cars
    EXOTICS
    Right, the generic scan tool displays no codes,
    Because it can't communicate with the BMW computer modules,
    which only a BMW specific scan tool/software can.
    Read through this thread (post#12)for insight:https://www.bimmerforums.com/forum/s...9#post29327199
    "Choosing the correct shop is as important as the correct diagnosis

    Former owner of a Red RL411 wannabe owner of pictured vehicle

  12. #12
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    Do you think this would do the trick? https://www.amazon.com/Original-Carl.../dp/B00X3UYXM0

  13. #13
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    And thank you for pointing me in the right direction. The wife is about ready to make me buy a Subaru. Blah!

  14. #14
    Join Date
    Dec 2013
    Location
    SKOKIE,ILL
    Posts
    2,355
    My Cars
    EXOTICS
    Before you purchase that, you do realize you require a smartphone to download the APP!
    "Choosing the correct shop is as important as the correct diagnosis

    Former owner of a Red RL411 wannabe owner of pictured vehicle

  15. #15
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    I do have a smartphone. Innotice the app is another $45 but that's within the budget if it will tell me what I need to know. Conversely I also have an old laptop. Would this work just as well or better? http://m.ebay.com/itm/111848792237?_...75&_mwBanner=1

  16. #16
    Join Date
    Dec 2013
    Location
    SKOKIE,ILL
    Posts
    2,355
    My Cars
    EXOTICS
    PM forum member 328 Power 04
    Abel can provide info on how to setup your laptop for diagnostics.
    Last edited by MIKYZZ4; 06-20-2017 at 06:35 AM.
    "Choosing the correct shop is as important as the correct diagnosis

    Former owner of a Red RL411 wannabe owner of pictured vehicle

  17. #17
    Join Date
    Jun 2012
    Location
    New Mexico
    Posts
    617
    My Cars
    1995 540i/6
    Quote Originally Posted by Narpod View Post
    For the record, there are no CEL codes. The EML light, dsc, brake etc are on.
    Sounds like an issue with the throttle body. If I were going to throw a dart at something I'd start with that.

    Was able to replace the TB on my e39 with the M52TUB28 with a good used item, no programming required. Plug and play. I would bet the M54 works the same way.

  18. #18
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    +1 on throttle body. That's always been my method of diagnosis until now. Unplug stuff till it doesn't change how the car runs. I would love to invest under $200 in a diagnostic tool that would read all the Bmw codes and not make me deal with ms-dos command prompts, but there doesn't seem to be a definitive solution on that. I am tempted to try out Carly however.

  19. #19
    Join Date
    Dec 2013
    Location
    SKOKIE,ILL
    Posts
    2,355
    My Cars
    EXOTICS
    Quote Originally Posted by MIKYZZ4 View Post
    PM forum member 328 Power 04
    Abel can provide info on how to setup your laptop for diagnostics.
    I believe this and a $20 cable will suffice.
    "Choosing the correct shop is as important as the correct diagnosis

    Former owner of a Red RL411 wannabe owner of pictured vehicle

  20. #20
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    Just a little update for y'all. I got my carly adaptor yesterday. Plugged it in. Didn't conne t to my car. It say , try starting the engine. So I start the engine and it starts running fine. EML light and others turn off. Full power. Idles properly. What the actual fuck? Any ideas? Do I have a bum computer or something?

  21. #21
    Join Date
    Dec 2013
    Location
    SKOKIE,ILL
    Posts
    2,355
    My Cars
    EXOTICS
    Did you actually perform a complete scan(all modules)with Carly?
    Did you happen to clear the codes?
    Last edited by MIKYZZ4; 06-24-2017 at 10:14 PM.
    "Choosing the correct shop is as important as the correct diagnosis

    Former owner of a Red RL411 wannabe owner of pictured vehicle

  22. #22
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    No. It said it couldn't connect. It said connected to module, then a wait, then couldn't connect to vehicle. Tried reinstalling app, didn't help. Tried running app while engine running, also didn't help, but, when I started the car it was running properly and I got throttle response when I pushed the pedal (instead of just bogging down). I drive it around the block and it ran pretty much how it's supposed to (with some rusty rear rotors from sitting for the last two weeks).
    Started it again today. The engine caught, then died immediately, then ran fine when I started it again.
    I'm about ready to go get a wiring harness and a throttle body from a junk yard, or just buy a less rusty e46 and keep this one for parts. I can't deal with this kind of gremlin in a daily driver.

  23. #23
    Join Date
    Jun 2012
    Location
    New Mexico
    Posts
    617
    My Cars
    1995 540i/6
    Throttle body problem can be intermittent. It was in my experience.

  24. #24
    Join Date
    Dec 2013
    Location
    SKOKIE,ILL
    Posts
    2,355
    My Cars
    EXOTICS
    You are connecting with a usb&adapter cable correct?
    "Choosing the correct shop is as important as the correct diagnosis

    Former owner of a Red RL411 wannabe owner of pictured vehicle

  25. #25
    Join Date
    May 2017
    Location
    Vermont
    Posts
    14
    My Cars
    2002 bmw 325xit 5spd
    No, I went for the carly wifi adaptor because I read inpa was going to mean rebooting a 10 year old gateway laptop over and over trying to get it to work, while carly would be plug and play. Imagine how frustrating it would be if no matter what I did with inpa it wasn't going to hook up to my computer!

Page 1 of 2 12 LastLast

Similar Threads

  1. 1995 bmw with rough idle and bogs when i hit the gas. Need some help
    By mattwoloszyn9 in forum General BMW Mechanical Help sponsored by RM European Auto Parts
    Replies: 3
    Last Post: 12-09-2012, 01:37 AM
  2. Replies: 13
    Last Post: 02-07-2012, 10:53 AM
  3. 525 pops and bogs down while..
    By aaronmarks in forum 1988 - 1996 (E34)
    Replies: 0
    Last Post: 10-22-2009, 09:56 PM
  4. check engine lt on , idles rough, bogs down when you try to accelerate
    By DesCal in forum General BMW sponsored by Intercity Lines
    Replies: 6
    Last Post: 06-11-2009, 03:08 PM
  5. Car died on me today, wont idle and bogs bad. Any guesses?
    By sogood in forum 1992 - 1999 M3 (E36)
    Replies: 45
    Last Post: 09-12-2008, 10:58 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •