Page 14 of 14 FirstFirst ... 4567891011121314
Results 326 to 329 of 329

Thread: Betty the Beater- Just a beginner drift thread

  1. #326
    Join Date
    Apr 2017
    Location
    NJ, USA
    Posts
    437
    My Cars
    '07 335I 6MT, '01 330i
    Quote Originally Posted by protomor View Post
    Clicking is usually a CV joint of some kind. Maybe the drive shaft's CV is shot. Or your new axles (remans?) might be bunk too. Maybe run the car in gear without the axles hooked up to see if that's an issue or not. Slowly take things in and out of the equation to do a process of elimination. Sadly, new parts aren't always 100%.
    This is exactly what I've been doing! New axles are 40k mile axles, verified by my before the were pulled off the car. .

    I'm uploading the video to demonstrate the clicking: https://youtu.be/eAMm0mAqdlU I'm 90% certain that its been the bearing the whole time.



    Basically, I realized that it was still clicking, with the new axle, so I felt for the vibration from it. Definitely coming from the hub, and while hand rotating the up you can feel where it clicks each rotation. Yesterday I ended up fucking up the bearing while pressing it in with the shop owner, we messed it up. Had a bunch of play, and it shouldn't have any. 2 new bearings ordered for today, and if he screws up the first I'll take it to a different shop who's owner I trust much more to have it done right. Getting a new hub too, just in case.

    Also, at my car yesterdya, I spun it up with no drivers side axle or hub on it. Didn't feel the vibration that's been killing me, so I'm pretty sure I've localized the problem. I can dream. I really need this car to be on the ground and streetable today, because I need to do my stinkin X5's trans service already before the tow! T-8 days including today...
    Keep it simple: half gutted '01 330i, welded diff, BC coils, SLR Super kit

  2. #327
    Join Date
    Apr 2017
    Location
    NJ, USA
    Posts
    437
    My Cars
    '07 335I 6MT, '01 330i
    Wow. It's been a long weekend. Tow went great, track was phenomenal, but then the shank holding the control arm snapped on a smooth surface, and ended my second day a few hours early. Had to get crane'd off the track. Pictures to come when I get the chance, but I'm happy to say that the guys at SLR continue to be good people. They're going to help me out getting the car back on the road. I can't even get it off the trailer right now...


    At the end of the day, it was still a crazy trip. Super fun, great people, and I got to meet a few new friends, and tandem with them. Then, I finished out the trip but spending the eveing at a bbq with a bunch of my buddy's friends. Included in them was a guy named mike and his fiancee, who are currently building the world's first mercedes v12 swapped 280z. I got to be there for it's first idle, and holy canoli, was the smile just plastered on my face. Eyes tearing from the rich fumes, could barely breathe, and I couldn't bring myself to step out of the garage away form the v12 straight pipe rumble.

    Oh yea, tandeming was just TOO GOD DAMNED FUN. I think I'm getting a cage this winter.. and it the weight slows the car down too much, maybe I'll just 50 shot it with a good logic controller until I have the money for more power.
    Last edited by awp235; 09-04-2019 at 11:47 AM.
    Keep it simple: half gutted '01 330i, welded diff, BC coils, SLR Super kit

  3. #328
    Join Date
    Apr 2017
    Location
    NJ, USA
    Posts
    437
    My Cars
    '07 335I 6MT, '01 330i
    Wow... it's been a while. Almost 5 months.

    In those 5 months, my car pretty much sat. I'll definitely try to sort those pictures, and put them on imgur or whatever to make this particular forum happy. Pretty much had to have a crane forklift put my car on my trailer, and then the car sat on 3 wheels on the trailer for a few months. Got it off with two jacks, 2 dollies, and some creativity. Have some pictures of that process too. I think I might've cracked a board on my trailer in the process. In the end, put it in my shop space. Stupid wireless trailer brakes unlinked, and I can't for the life of me get them to re-link.. so I might just wire in a real controller. I figure I might as well do that just so I have a reliable hardwired connection.

    I finally have all the parts that were broken. I have word from SLR that my kit is OK too. I needed the piece that the expansion tank clips into at the bottom, a new entire core support, and a set of headlights. My wheel rolled my fender and chassis behind the wheel, so I guess I don't have a perfectly clean body any longer. Oh well! I can't wait to have the kit back, and to be able to get this thing back to driving. I really miss driving manual, and need a fix! As soon as my SLR kit comes back, I'll be spending time to get the car assembled.

    As far as the cage... Life's getting in the way. My impending move-in with my girlfriend is going to about double my living costs, so a lot of my hobbies are kind of taking a break. My hangar had a bunch of my buddy's stuff in it all winter because of family stuff, so I didn't really have room to work on anything anyway. No pipe bender or welder to teach myself. I've decided to keep my car at this power level, for now, and just continue ripping on it. I can barely afford tires for it as is, and I'm going to have to survive without tandeming for now!
    Keep it simple: half gutted '01 330i, welded diff, BC coils, SLR Super kit

  4. #329
    Join Date
    May 2007
    Location
    fairfax,va, usa
    Posts
    6,540
    My Cars
    2 E30s and a maxima
    I thought moving in with someone lowers your living costs.... is your GF not a sugar mama? Where's pix? GEEZ

    Status: Someone put glitter in my oil. Wait. Why's all my oil outside the engine? What's that knocking?

Page 14 of 14 FirstFirst ... 4567891011121314

Similar Threads

  1. The drift thread ?
    By Nihilation in forum BMW Rides & Events
    Replies: 134
    Last Post: 01-22-2010, 09:10 PM
  2. The did my motor just eat a ring thread... ?
    By 328iJunkie in forum 1992 - 1999 M3 (E36)
    Replies: 20
    Last Post: 09-09-2009, 11:58 AM
  3. The "I just got back from FedEx and I'm burnt" thread
    By Biggins in forum Middle Atlantic - US
    Replies: 6
    Last Post: 07-16-2007, 03:17 PM
  4. Replies: 15
    Last Post: 06-14-2006, 06:02 AM
  5. Finally! The "I Just Got My New Car!" Thread (56K, HAHAHAHAHAHAHA)
    By Joey Link in forum Pacific Northwest - US
    Replies: 8
    Last Post: 06-12-2006, 04:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •