Page 2 of 2 FirstFirst 12
Results 26 to 30 of 30

Thread: Is my tune my problem? FI OBDI S52

  1. #26
    Join Date
    Jun 2005
    Location
    Concord, NH
    Posts
    20,074
    My Cars
    08 E90M3; 99 E36M3 Turbo
    Bad cam timing can affect fuel delivery and also damage valves and pistons. Why would your cam timing have changed?

  2. #27
    Join Date
    Sep 2016
    Location
    Radford, VA.
    Posts
    106
    My Cars
    95 M3
    I haven't done anything to change the timing. I'm just stumped and trying to think of anything to get it running decent again.

  3. #28
    Join Date
    Apr 2012
    Location
    Tampa, FL
    Posts
    4,396
    My Cars
    E36,E38, and E46
    Your iac hose is collapsing. If its oem or anything other than a tube slightly thicker than a condom there is no reason for it to collapse. Your AFR's are off meaning your not getting the right airflow. IAC is not delivering and afr's are giving an indication. Something is plugged up. The iac hose should be able to deliver enough air if its unplugged electrically and if its good like you believe then I would look for a reason why you are pulling so much vacuum (a blockage) causing the hose to collapse and AFR's to act up.
    UOENO. English?

  4. #29
    Join Date
    Sep 2016
    Location
    Radford, VA.
    Posts
    106
    My Cars
    95 M3
    Thanks for the input bry195. I took apart all of my IC pipe to make sure I didn't leave a rag or something in when I was mocking up everything. No luck. Put everything back together and same issue. I did notice that the elbow going into the throttle body is kinked some on the bottom where I couldn't see. Going to change the position of the pipe to get the kink completely out and see what happens. Also have a vacuum gauge to put on it and see how much vacuum I'm pulling.
    Last edited by badata1; 02-28-2017 at 11:25 AM. Reason: spelling

  5. #30
    Join Date
    Sep 2016
    Location
    Radford, VA.
    Posts
    106
    My Cars
    95 M3
    Redid the IC pipe to take the kink out. Its gone, still no change. Didn't have time to do a leakdown test. I put a vacuum gauge on it and it was steady at 16. If I reved it slow, it would climb a little and then bounce with the idle when I let off. Getting code 1281 again (everything is grounded as far as I know). I'm at a loss of what to do. Unfortunately due to work I won't even be able to work on it for a week or so.
    There is a slight amount of white smoke coming from the tail pipe, not sure if that's from where its running so lean or if something internal is wrong. Guess I will have to wait for the leakdown test to see.
    One last thing, when I had the throttle body off I noticed there was a small pool of gas sitting in the intake (Definitely gas, not oil). I thought Fuel pressure regulator and pulled vacuum on it and it didn't leak down. Not sure if that's the correct way to test it but I did, also there was no gas in the vacuum line itself.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. My Clutch Kit and FI plan is this good enough??
    By dredder in forum Forced Induction
    Replies: 0
    Last Post: 04-03-2006, 11:28 PM
  2. Is it just my BMW or Does Anyone has a heating problem
    By e34slave in forum 1988 - 1996 (E34)
    Replies: 20
    Last Post: 12-12-2005, 11:31 AM
  3. Is it my imagination or is there a quality problem
    By DavidNJ in forum 1988 - 1996 (E34)
    Replies: 3
    Last Post: 03-31-2004, 01:44 PM
  4. wtf is my car's problem?
    By m3j0n in forum 1992 - 1999 M3 (E36)
    Replies: 6
    Last Post: 03-23-2004, 09:51 AM
  5. FI cured my oil consumption problem. LOL.
    By fast4d in forum 1992 - 1999 M3 (E36)
    Replies: 3
    Last Post: 01-04-2004, 10:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •