Page 4 of 4 FirstFirst 1234
Results 76 to 84 of 84

Thread: Hellrot with a GTW3684R (6262) aka might as well make a build thread

  1. #76
    Join Date
    Feb 2012
    Location
    Birmingham, Alabama, USA
    Posts
    7,904
    My Cars
    1995 BMW M3
    BMW parking job XD
    H&R Coilovers - Powerflex LCAB/RTAB - Apex Arc8 Powder Coated Gold(17x9) - S52 Swap - Built Head- Built Bottom End- Borg Warner S256sx- Boost Logic- Tial 50mm/44mm - TRM 60# Tune- Full 3" Exhaust w/Vibrant & Borla - Auto>Manual Swap - ZHP Shift Knob 463whp/411wtq at 13.8Psi

  2. #77
    Join Date
    May 2014
    Location
    Noblesville, IN
    Posts
    1,660
    My Cars
    95 M3, 98 328i
    Quote Originally Posted by rajicase View Post
    BMW parking job XD
    notice that the monster truck next to him is over the line as well. probably safer than skipping that spot and then some dickhead tries to squeeze in between and door dings everyone.
    always trying to make it lighter and faster

    build: http://www.bimmerforums.com/forum/sh...-neglected-M3/
    instant grams: doktor_b

  3. #78
    Join Date
    Sep 2009
    Location
    Syracuse, NY
    Posts
    331
    My Cars
    95 M3 Turbo, 08 535xiT
    The parking lot is at my work and gated. No one is between the lines. Whoever lined it designed it for micro cars. There are more parking spots than needed and a trailer with all the collapse rescue stuff in it, and then wood stacked along side the trailer. Note that 9 out of 10 firemen drive suv's or pickup trucks.

  4. #79
    Join Date
    Sep 2009
    Location
    Syracuse, NY
    Posts
    331
    My Cars
    95 M3 Turbo, 08 535xiT
    Does anyone have knowledge about manual boost controllers? I am running a hallman rx pro. Is there a point you have to tighten the controller in to, to start seeing an affect? I have tightened it up a few turns with no affect on my pressure. I just don't want to go too far in 1 turn and see 18+ psi.

  5. #80
    Join Date
    May 2014
    Location
    Noblesville, IN
    Posts
    1,660
    My Cars
    95 M3, 98 328i
    I had a Forge MBC years ago (I actually have it in a drawer now) that worked in a very linear way. Every click, or two, was one PSI.
    Have you verified it's hooked up correctly?
    always trying to make it lighter and faster

    build: http://www.bimmerforums.com/forum/sh...-neglected-M3/
    instant grams: doktor_b

  6. #81
    Join Date
    Sep 2009
    Location
    Syracuse, NY
    Posts
    331
    My Cars
    95 M3 Turbo, 08 535xiT
    It was installed correctly. I just had to crank it down more. She has power now.

  7. #82
    Join Date
    May 2014
    Location
    Noblesville, IN
    Posts
    1,660
    My Cars
    95 M3, 98 328i
    Excellent
    always trying to make it lighter and faster

    build: http://www.bimmerforums.com/forum/sh...-neglected-M3/
    instant grams: doktor_b

  8. #83
    Join Date
    Sep 2009
    Location
    Syracuse, NY
    Posts
    331
    My Cars
    95 M3 Turbo, 08 535xiT
    So car popped a light yesterday that went out and was running oddly. Car ran fine but at part throttle trying to maintain speed at lower rpm's car would lean way out and hiccup. Got home and code was for 02 sensor/maf (which I guess is a limit reached code either upper or lower) and the second code was for cam position sensor.

    Got home from work today, looked over engine and drove it...was 100%. Then drove it again and was doing same thing as last night. I spoke to a couple people earlier today both stated to replace CPS. I am gonna do both the cps and the o2 sensor, my mileage also seems a bit low. May be due to base tune, not quite sure what mileage should actually be. I reset the trip to see what I'm really getting next fill up.

    I knew the turbo would bring out everything that is on its way out. Hoping this is the last piece for a bit. Also going to do plugs again just in case.

  9. #84
    Join Date
    Sep 2009
    Location
    Syracuse, NY
    Posts
    331
    My Cars
    95 M3 Turbo, 08 535xiT
    Anyone have any ideas as to where to look next?

    Problem at part/low throttle afr goes lean. Car runs like crap. Like from the normal 13.8-14.9 to upper 15's-18. Idle is between 13.8-14.9. Was told fluctuation is due to the aeromotive supplying a lot of pressure at idle.

    So far I have replaced:
    cam position sensor
    o2 sensor
    plugs
    fuel filter
    tightened clamps on icv
    checked vacuum lines

    going to recheck all my silicone couplings for boost piping tomorrow. Any other ideas?

    i'm running an aeromotive 340 should be plenty of pressure but could be a fueling issue, would make sense I guess.

    Not really sure how to go about checking fuel pressure at part throttle.

    could ICV be affecting part throttle?

Page 4 of 4 FirstFirst 1234

Similar Threads

  1. Replies: 2
    Last Post: 06-07-2007, 11:34 AM
  2. Oh, might as well...
    By fm.illuminatus in forum Kill Stories
    Replies: 3
    Last Post: 09-09-2006, 02:43 PM
  3. HIN AC coverage **56k might as well go wait for the first snowfall**
    By tdc in forum New York / New Jersey / Connecticut
    Replies: 8
    Last Post: 05-25-2006, 04:05 AM
  4. Replies: 101
    Last Post: 10-25-2002, 10:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •