Results 1 to 23 of 23

Thread: Need a wiring diagram for E34 M5 instrument cluster

  1. #1
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5

    Need a wiring diagram for E34 M5 instrument cluster

    Need a wiring diagram for E34 M5 instrument cluster.
    I need to know where all those pins in the four connectors should go.
    Actually I've converted my E34 518i to M5 by swapping engine (S38B36), transmission box, rear complete axle and .....
    Engine wiring harness also swapped to M5 but the rest wiring belongs to 518i.
    Now I'm gonna install the M5 instrument cluster and i need to know where all those pins in the four connectors should go?
    the problem is 518's cluster has only two connector but M5's has four!

    Thanks in advance for any help
    Last edited by shervin; 06-20-2015 at 02:48 AM.

  2. #2
    Join Date
    Apr 2014
    Location
    PA
    Posts
    1,520
    My Cars
    1992 525
    Check this manual out for the M5
    http://wedophones.com/Manuals/BMW/19...g%20Manual.pdf

    Here is the source website
    http://wedophones.com/Manuals/BMW/
    "Helicopters: 10,0000 pieces of metal fatigue rotating around an oil leak."


  3. #3
    Join Date
    Feb 2013
    Location
    Edmonton, Alberta, canada
    Posts
    510
    My Cars
    1990 BMW 525i, 1991 M5
    Not to jack this thread, but do you have a link for a full 1991 M5 manual, Dan?

    Or even know where I can get my hands on a full hard copy version?

    Thanks!

  4. #4
    Join Date
    Apr 2014
    Location
    PA
    Posts
    1,520
    My Cars
    1992 525
    Quote Originally Posted by linklaterdavid View Post
    Not to jack this thread, but do you have a link for a full 1991 M5 manual, Dan?

    Or even know where I can get my hands on a full hard copy version?

    Thanks!
    Full 91 m5 Electrical manual?
    http://wedophones.com/Manuals/BMW/19...g%20Manual.pdf
    "Helicopters: 10,0000 pieces of metal fatigue rotating around an oil leak."


  5. #5
    Join Date
    Feb 2013
    Location
    Edmonton, Alberta, canada
    Posts
    510
    My Cars
    1990 BMW 525i, 1991 M5
    Actually was just looking for the whole manual! :-)

  6. #6
    Join Date
    Apr 2014
    Location
    PA
    Posts
    1,520
    My Cars
    1992 525
    Ahhhh. I dont think the bentley covers the m5 for whatever reason.... I dont have a link to one but somebidy here has to have one.

  7. #7
    Join Date
    Feb 2013
    Location
    Edmonton, Alberta, canada
    Posts
    510
    My Cars
    1990 BMW 525i, 1991 M5
    No worries man! I will keep the search up! A hard copy would be wonderful to have!
    Thanks again!

  8. #8
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    Thank u Dan, I already had the manuals but non of them have instrument cluster pin assignment.

  9. #9
    Join Date
    Jan 2005
    Location
    Japan
    Posts
    47,252
    My Cars
    11/88 E32 750iL+98 E36M3
    Instrument cluster pin assignment is partially dependent from the built year, that means grey, white or blue backplate cluster. But I have here some info from the E32 and that should also go for the E34, X16 is different by cluster version
    http://www.e32-schrauber.de/bmw/s-stecker-kombi.htm
    and believe it or not, it is from the ETMs and we made a list, therefore it is mentioned: Steckerbelegung Kombiinstrument E32 ab Bj. 02/87 , mit freundlicher Unterstuetzung von Erich "Shogun"
    SHOGUN'S TRICKS AND TIPS FOR THE SEVEN SERIES
    http://twrite.org/shogunnew/topmenu.html

  10. #10
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    Great!!!
    That is what I was looking for
    mine is exactly same the first one (Kombiinstrument grau bis 08/90 (735)
    Thanks a lot.

  11. #11
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    Thanks again Shogun for your guide line.
    All wires are connected together properly (By Colors) but non of gauges works. not even lights. the only thing working is mileage indicator and perhaps speedometer (didn't move the car to check).

    The only brown wire (ground) is in X271 connector that I believe is related to speedometer.
    I think there must be a ground wire for the rest of the gauges and lamps. non of them works!!!
    Last edited by shervin; 06-25-2015 at 02:00 AM.

  12. #12
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    update....
    found all wires and connect them as per wiring diagram.
    -all warning lights works (oil pressure, hand break, turn signals, high beams, ....

    problems:
    - engine speedometer doesn't work
    - temp gauge goes straight to the red immediately by plug in the brown connector (even when others not connected or unplugged temp sensor).
    - fuel gauge goes on 20 liter by connecting brown connector (with or withot connecting the others.
    - Instrument illumination doesn't turned on.

    any idea whats wrong?
    Last edited by shervin; 07-21-2015 at 02:54 PM.

  13. #13
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    Update...

    Once again after four years! checked to see if I can find whats wrong with the M5 instrument cluster.
    all illumination (lamps) were broken, so replace them with new ones and now they work fine.
    lcd is Ok and all pixle light fine.
    still temp gauge goes to red upon connecting brown connector, fuel gauge stay on 20 liter while the tank is full and engine rev meter doesn't work at all.
    Can the problem have any relation with the Capacitors?
    Last edited by shervin; 11-05-2019 at 03:22 AM.

  14. #14
    Join Date
    Jan 2005
    Location
    Japan
    Posts
    47,252
    My Cars
    11/88 E32 750iL+98 E36M3
    The fuel gauge problem could be caused by the sender http://bmwe32.masscom.net/johan/fuel...el_sender.html
    http://bmwe32.masscom.net/maxf_website/gauge.htm
    broken capacitors in the instrument cluster could be the cause of the other instrument cluster problems
    http://bmwe32.masscom.net/johan/dash...dash_caps.html
    I once had this problem, fix of poor solder joints in cluster http://www.bimmerboard.com/forums/posts/569942/ read the complete thread : fuel level, temperature gauges, gear, all dark http://www.bimmerboard.com/forums/posts/569898
    Then go to my website http://twrite.org/shogunnew/topmenu.html on the left click fixes, go to instruments, click Replace blown resistor in speedometer

    I would also try to resolder the complete board, maybe some cold soldering spots.
    As for the temp gauge, check the temp sensor, maybe a wrong one is installed. The one for the DME is different from the one for the gauge
    SHOGUN'S TRICKS AND TIPS FOR THE SEVEN SERIES
    http://twrite.org/shogunnew/topmenu.html

  15. #15
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    Thank you shogun,
    There is no problem with the original instrument cluster but the M5 cluster (gen 1) has above described problems so fuel gauge sender is all right.
    Maybe I should try another Gen 1 cluster to see if the problem is with the M5 cluster or not.
    apart from that do you know what are those two gear for in the inst cluster?meterrepair2.jpg

  16. #16
    Join Date
    Jan 2005
    Location
    Japan
    Posts
    47,252
    My Cars
    11/88 E32 750iL+98 E36M3
    I do not know the E34 clusters well, such gears are not in E32 clusters, google search shows me M5 odometer gears for that Motometer
    https://www.ebay.com/itm/Motometer-c...75.c100623.m-1
    https://blog.bavauto.com/11888/bmw-d...-gears-how-to/
    Last edited by shogun; 11-06-2019 at 06:11 PM.
    SHOGUN'S TRICKS AND TIPS FOR THE SEVEN SERIES
    http://twrite.org/shogunnew/topmenu.html

  17. #17
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    Ebay gears are not the gears in my pictures I think they are for clusters with mechanical odometers. (Ebay explanations are not trustable)Screenshot_20191103-074708_Gallery.jpg
    All M5 are electronic, mine is for november 1988

  18. #18
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    This is the M5 (half cut) I"ve bought 5 years ago with 63k in odometer, she came from Japan.
    IMG_20191107_075254_332.jpgIMG_20191107_075247_801.jpgIMG_20191107_075300_006.jpg
    I replaced every part of my e34 with those came with the half cut and all works fine exept instrument cluster
    Last edited by shervin; 11-06-2019 at 11:29 PM.

  19. #19
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    Sorry to ask an irrelevant question, do you know how can I unlock tho OBC for hidden functions? Press 1000 and 10 together and then test No 19 then I see
    - - - - lock
    Last edited by shervin; 11-07-2019 at 02:43 PM.

  20. #20
    Join Date
    Jan 2005
    Location
    Japan
    Posts
    47,252
    My Cars
    11/88 E32 750iL+98 E36M3

  21. #21
    Join Date
    Jun 2011
    Location
    Tehran - Iran
    Posts
    83
    My Cars
    E21- 320i , E34 -M5
    Thank you shogun,
    I thing i should search for e32 too.

    Update:
    Problem with my M5 instrument cluster was in back electronic board. replaced it with another one and the cluster came back to the life!
    20191107_192359.jpg
    The only problem is that oil temp gauge doesn't work, it goes to high after ignition then back and forth between low and high while driving
    Last edited by shervin; 11-08-2019 at 01:11 AM.

  22. #22
    Join Date
    Jan 2005
    Location
    Japan
    Posts
    47,252
    My Cars
    11/88 E32 750iL+98 E36M3
    E34 and E32 have a lot of modules in common, so it often helps when you search also in the E32 section.
    Oil temp gauge always changing: Might be a wiring problem, check the wires and also the connection on the sensor and the pin connection on the cluster.
    SHOGUN'S TRICKS AND TIPS FOR THE SEVEN SERIES
    http://twrite.org/shogunnew/topmenu.html

  23. #23
    Join Date
    Aug 2019
    Location
    Seattle, WA
    Posts
    345
    My Cars
    1995 BMW 540i 6-speed
    Quote Originally Posted by shervin View Post
    20191107_192359.jpg
    The only problem is that oil temp gauge doesn't work, it goes to high after ignition then back and forth between low and high while driving
    Do you mean its moving like the MPG gauge on a standard cluster does?

    Where did the coding plug you are using come from? An M5? Or a ‘lesser’ e34?


    Sent from my iPhone using Tapatalk

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •