Page 83 of 83 FirstFirst ... 33587374757677787980818283
Results 2,051 to 2,074 of 2074

Thread: NBT/CIC/CCC retrofit in E39/E38/E53

  1. #2051
    Join Date
    Apr 2009
    Location
    UK
    Posts
    424
    My Cars
    BMW E63 M6, RR L322 4.4
    Has anyone else had tracking issues with the stock antenna and the carsystems adapter? Been driving for 300 miles and it jumps all over the place... emailed cs they said that the gps antenna won't work with my nbt it's too old... I told them that it works fine with the bimmer retrofit adapter which is a fact it works flawlessly with that. I then heard back and they said the firmware of my nbt was too old - again sound like bs as it's a 2014 model and worked fine with the br adapter - waiting to hear back again...


    Sent from my iPhone using Tapatalk

  2. #2052
    Join Date
    Apr 2009
    Location
    UK
    Posts
    424
    My Cars
    BMW E63 M6, RR L322 4.4
    Also side note I've ditched the dsp setup as the speakers are the same in the Range Rover for the non dsp amp - so old dsp has gone and non dsp in and everything works so much better fading correct start volumes etc


    Sent from my iPhone using Tapatalk

  3. #2053
    Join Date
    May 2010
    Location
    East Bay Area, CA
    Posts
    1,627
    My Cars
    01 Dinan 740iS, 97 318ti
    Getting closer to my install! Just waiting to get this back from hydro-dip. They haven't shot the final clear or final buff in these pics, but can't wait to see it.

    20170525_133623.jpg
    That is with the flash being on and the next for "in the dark" without flash.

    20170525_133610.jpg

    Quick question to those who fabricated their own console, this one is aluminum and I am trying to figure out how to attach the various "brackets" from the wood console to this one, so they don't just pop off because the glue dries?
    '01 740i Sport MKIV, Quad Brake Lights, OEM Bi-Xenon retrofit, LED Angel Eyes, HID Fogs, LED License Plate Lights, Dinan 7 certification, BM53 radio, OEM Sirius, Aux Input, TCU Bluetooth, Intravee II, iPod, Strong Strut, Dinan Struts, Springs, Camber Plates, Intake, MAF, CAI, Exhaust and Throttle Body

    '97 318ti Alpine White; '97 318ti Boston Green; '96 318ti Alaska Blue; '08 X5 4.8i Titanium Silver
    '84 633csi Black (sold); '88 325iC Black (sold); '97 740iL Black(sold); '01 740iS Black(sold)

  4. #2054
    Join Date
    Mar 2012
    Location
    Lansdale, Pa
    Posts
    4,820
    My Cars
    6/98 BMW 540 6sp VF S/C
    I was always impressed with this upgrade and would love to have it at some point, but there still seems to be some issues with every install.

    Has anyone got a totally perfectly running system? No issues with GPS or integration?
    6/98 540i 6sp, Mods: VF S/C, Custom Pulleys, 16 psi Boost, Tuning Tech FS Tune, 42# Injectors, Supersprint Headers, HJS Cats, 3" Custom Exhaust, D.O. Progressive Meth, AEM 320 Fuel Pump, Aeromotive FPR, AEM Failsafe AFR/Boost Gauge, Wavetrac LSD, Style 65 w/275's square, M5 bits;[Steering Box, Clutch, Motor Mounts, Front Sway Bar], Powerflex, Eibach Rear Bar, M3 Shifter, Evans Coolant, 85 Deg Stat, Clutch fan replaced with PWM fan, 10" DVC rear subs, B.A. speakers, Grom Aux and BT, Euro Console, Brushed Ti Trim. DIY everything!

  5. #2055
    Join Date
    Nov 2010
    Location
    Charlotte, NC
    Posts
    8,239
    My Cars
    549i6/530it6
    Quote Originally Posted by philly98540 View Post
    I was always impressed with this upgrade and would love to have it at some point, but there still seems to be some issues with every install.

    Has anyone got a totally perfectly running system? No issues with GPS or integration?
    Mine work well in both my e39s. No GPS issues and the latest maps.

    Sent from my SM-G950U using Tapatalk

    -Paul
    2003 "M5" - S62/420g swap, M5 diff, M5 driveshaft, M5 brakes, M5 Traction Bars, Eibach Sway Bars, UUC Evo3/DSSR, Custom Exhaust,
    BMW NBT Retrofit, M5 Gauge Cluster, Hella G4 Bi-Xenon Retrofit, M5 Extended Leather Interior Swap, APEX PS-7s, e60 Hubs, Koni Sports
    Coming Soon - M5 Bumpers
    530i 6-speed swap build thread

    2003 530it6 - M54b30/S6S-420g swap, 3.15 540it diff, e60 SSK, VMR VB2 19" Wheels, M5 Gauge Cluster, Hella G4 Bi-xenon Retrofit, NBT Retrofit, Koni Sports, 540i Brakes

    2001 749i6 - Retired and being parted out - M5Board Build Log

  6. #2056
    Join Date
    Mar 2012
    Location
    Lansdale, Pa
    Posts
    4,820
    My Cars
    6/98 BMW 540 6sp VF S/C
    Good to know Paul!
    6/98 540i 6sp, Mods: VF S/C, Custom Pulleys, 16 psi Boost, Tuning Tech FS Tune, 42# Injectors, Supersprint Headers, HJS Cats, 3" Custom Exhaust, D.O. Progressive Meth, AEM 320 Fuel Pump, Aeromotive FPR, AEM Failsafe AFR/Boost Gauge, Wavetrac LSD, Style 65 w/275's square, M5 bits;[Steering Box, Clutch, Motor Mounts, Front Sway Bar], Powerflex, Eibach Rear Bar, M3 Shifter, Evans Coolant, 85 Deg Stat, Clutch fan replaced with PWM fan, 10" DVC rear subs, B.A. speakers, Grom Aux and BT, Euro Console, Brushed Ti Trim. DIY everything!

  7. #2057
    Join Date
    May 2010
    Location
    East Bay Area, CA
    Posts
    1,627
    My Cars
    01 Dinan 740iS, 97 318ti
    And knowing the guy who programmed/coded mine, I don't expect any issues either!
    '01 740i Sport MKIV, Quad Brake Lights, OEM Bi-Xenon retrofit, LED Angel Eyes, HID Fogs, LED License Plate Lights, Dinan 7 certification, BM53 radio, OEM Sirius, Aux Input, TCU Bluetooth, Intravee II, iPod, Strong Strut, Dinan Struts, Springs, Camber Plates, Intake, MAF, CAI, Exhaust and Throttle Body

    '97 318ti Alpine White; '97 318ti Boston Green; '96 318ti Alaska Blue; '08 X5 4.8i Titanium Silver
    '84 633csi Black (sold); '88 325iC Black (sold); '97 740iL Black(sold); '01 740iS Black(sold)

  8. #2058
    Join Date
    Apr 2017
    Location
    Chicago, IL
    Posts
    13
    My Cars
    2000 540i
    Hey guys, I am having some coding issues with my NBT. The following features are not working:
    Bluetooth
    Reverse camera
    Sport display
    USB.
    Any help is appreciated.


    Sent from my SM-G950U using Tapatalk

  9. #2059
    Join Date
    Apr 2009
    Location
    UK
    Posts
    424
    My Cars
    BMW E63 M6, RR L322 4.4
    Paul any ideas how to fix my jumping around with the cs adapter?


    Sent from my iPhone using Tapatalk

  10. #2060
    Join Date
    Apr 2017
    Location
    Chicago, IL
    Posts
    13
    My Cars
    2000 540i
    Quote Originally Posted by pyro225 View Post
    Paul any ideas how to fix my jumping around with the cs adapter?


    Sent from my iPhone using Tapatalk
    Im using a eBay bought gps antenna it was less than 10 bucks works perfect for me.

    Sent from my SM-G950U using Tapatalk

  11. #2061
    Join Date
    Feb 2016
    Location
    Kent, UK
    Posts
    31
    My Cars
    2002 BMW 330ci
    Quote Originally Posted by pyro225 View Post
    Paul any ideas how to fix my jumping around with the cs adapter?


    Sent from my iPhone using Tapatalk
    I'm having this issue on my E46 still. Tried with 3 different GPS antennas (including an OEM F10 shark-fin antenna) with the same issue. CarSystems have given me some firmware to test and get back to them. Hopefully one of those resolve it.

  12. #2062
    Join Date
    Nov 2010
    Location
    Charlotte, NC
    Posts
    8,239
    My Cars
    549i6/530it6
    Quote Originally Posted by JPToadstool View Post
    I'm having this issue on my E46 still. Tried with 3 different GPS antennas (including an OEM F10 shark-fin antenna) with the same issue. CarSystems have given me some firmware to test and get back to them. Hopefully one of those resolve it.
    Check your can bus wires going to the car. Could be swapped or not making a good connection.

    Sent from my SM-G950U using Tapatalk

    -Paul
    2003 "M5" - S62/420g swap, M5 diff, M5 driveshaft, M5 brakes, M5 Traction Bars, Eibach Sway Bars, UUC Evo3/DSSR, Custom Exhaust,
    BMW NBT Retrofit, M5 Gauge Cluster, Hella G4 Bi-Xenon Retrofit, M5 Extended Leather Interior Swap, APEX PS-7s, e60 Hubs, Koni Sports
    Coming Soon - M5 Bumpers
    530i 6-speed swap build thread

    2003 530it6 - M54b30/S6S-420g swap, 3.15 540it diff, e60 SSK, VMR VB2 19" Wheels, M5 Gauge Cluster, Hella G4 Bi-xenon Retrofit, NBT Retrofit, Koni Sports, 540i Brakes

    2001 749i6 - Retired and being parted out - M5Board Build Log

  13. #2063
    Join Date
    Feb 2016
    Location
    Kent, UK
    Posts
    31
    My Cars
    2002 BMW 330ci
    Quote Originally Posted by blackknight530i View Post
    Check your can bus wires going to the car. Could be swapped or not making a good connection.

    Sent from my SM-G950U using Tapatalk
    I don't think that'll be the issue. I've verified that the correct wires are connected to can high and low. I also removed my old splice connectors and opted for a good solder joint instead, with heat shrink around it. Unless there's an issue with the wiring from that point to the emulator.

    It seems to be almost consistent as to where it loses track, normally on a right turn on a roundabout. The position arrow rotates too much (say 330 for a 270 turn). I personally think it may be due to issues in sampling / translating can messages. I'm running an NBT-EVO 2GB unit updated to ID6, so that may also be the issue. The only other thing that may be relevant is my wheel count for front left and right differs as it should, but my rear wheels are always the exact same count (I don't know if this would affect it at all).

  14. #2064
    Join Date
    Nov 2010
    Location
    Charlotte, NC
    Posts
    8,239
    My Cars
    549i6/530it6
    Quote Originally Posted by JPToadstool View Post
    I don't think that'll be the issue. I've verified that the correct wires are connected to can high and low. I also removed my old splice connectors and opted for a good solder joint instead, with heat shrink around it. Unless there's an issue with the wiring from that point to the emulator.

    It seems to be almost consistent as to where it loses track, normally on a right turn on a roundabout. The position arrow rotates too much (say 330 for a 270 turn). I personally think it may be due to issues in sampling / translating can messages. I'm running an NBT-EVO 2GB unit updated to ID6, so that may also be the issue. The only other thing that may be relevant is my wheel count for front left and right differs as it should, but my rear wheels are always the exact same count (I don't know if this would affect it at all).
    If you're getting the abs readings, you're right it isn't the can wires. I think there was a special carsystems firmware for e46 as the and module was different than what was typical. Might have to get them to tell you more.

    Sent from my SM-G950U using Tapatalk

    -Paul
    2003 "M5" - S62/420g swap, M5 diff, M5 driveshaft, M5 brakes, M5 Traction Bars, Eibach Sway Bars, UUC Evo3/DSSR, Custom Exhaust,
    BMW NBT Retrofit, M5 Gauge Cluster, Hella G4 Bi-Xenon Retrofit, M5 Extended Leather Interior Swap, APEX PS-7s, e60 Hubs, Koni Sports
    Coming Soon - M5 Bumpers
    530i 6-speed swap build thread

    2003 530it6 - M54b30/S6S-420g swap, 3.15 540it diff, e60 SSK, VMR VB2 19" Wheels, M5 Gauge Cluster, Hella G4 Bi-xenon Retrofit, NBT Retrofit, Koni Sports, 540i Brakes

    2001 749i6 - Retired and being parted out - M5Board Build Log

  15. #2065
    Join Date
    Feb 2016
    Location
    Kent, UK
    Posts
    31
    My Cars
    2002 BMW 330ci
    Quote Originally Posted by blackknight530i View Post
    If you're getting the abs readings, you're right it isn't the can wires. I think there was a special carsystems firmware for e46 as the and module was different than what was typical. Might have to get them to tell you more.

    Sent from my SM-G950U using Tapatalk
    That's interesting, thanks for that, I'll enquire with them. They have been pretty fantastic so far, and I really do want to get it resolved for me and others. I'm new to coding, but I'm enjoying it so far and have learnt a lot in trying to fix this. I've one year left of a degree in electrical engineering and enjoy troubleshooting, so part of this is my persistence to not let something beat me.

  16. #2066
    Join Date
    Feb 2016
    Location
    Kent, UK
    Posts
    31
    My Cars
    2002 BMW 330ci
    I've had problems with my NBT Evo 2GB unit running ID6 since I bought it. The actual navigation side of things doesn't track well at all, which I'm hoping Carsystems will help to rectify. The main problem with my unit is that it constantly crashes, to the point that it's pretty much useless. A 2 hour car journey will result in it crashing at least 6 times, even without nav running or being displayed. I've spoken to Mick, who said he'd try and source a 4GB unit for me, however, I'm considering asking to swap to an NBT unit instead and ask for a refund of the difference.

    Questions to those of you that have standard NBT in an E39/E46/E38: Does it track correctly? Does speed volume work? Is it stable (does not crash)? Were you able to get online services / RTTI over bluetooth working?

  17. #2067
    Join Date
    Aug 2013
    Location
    Sydney
    Posts
    391
    My Cars
    01 E39 530i,05 E53 4.8IS
    Mine works "almost" everything correctly including navigation and cover art over bluetooth........except for BMW Apps. ...suddenly stops and wont connect any of my IOS devices via USB port.

    My NBT does not crash and/or have any issues.
    01 E39 530i - SOLD !
    05 E53 4.8is


    Pics of Bianca (E39) and Betsy (E53)

  18. #2068
    Join Date
    Feb 2016
    Location
    Kent, UK
    Posts
    31
    My Cars
    2002 BMW 330ci
    Quote Originally Posted by Jopecasa View Post
    Mine works "almost" everything correctly including navigation and cover art over bluetooth........except for BMW Apps. ...suddenly stops and wont connect any of my IOS devices via USB port.

    My NBT does not crash and/or have any issues.
    That's good to know. Speed volume works as well? This is something I really want to get working. How long is the cable to your USB socket? Apparently a long cable can cause issues.

  19. #2069
    Join Date
    Aug 2013
    Location
    Sydney
    Posts
    391
    My Cars
    01 E39 530i,05 E53 4.8IS
    Speed volume works and can be adjusted from the NBT settings......or via FDL coding.

    I've got two USB cable/ports....one at 3.5m (console) and 1.0m at the trunk .....both sees USB drives but not my IOS devices.

    Checked my coding a few times but none made any difference.......even bought a BMW Genuine Y-cable.....same issue.

    I maybe have to get/purchase a 9C FSC repair kit.....if nothing else work.
    01 E39 530i - SOLD !
    05 E53 4.8is


    Pics of Bianca (E39) and Betsy (E53)

  20. #2070
    Join Date
    Jun 2013
    Location
    United States
    Posts
    205
    My Cars
    2002 E39 M5
    The HSD USB cables are very sensitive to the USB cable you're using for iOS. I've been thru hell with this issue. The conclusion is that you need to use a 100% genuine Apple cable or a very high quality one. I use Anker USB cables and they charge/detect my iPhone just fine. This is all on NBT, I haven't tested with EVO yet.

    Which EVO unit are you guys using? I have one out of a G1x, haven't tested it yet.
    '02 TiAg/Blk E39 ///M5
    '08
    JZB/FR E92 ///M3

  21. #2071
    Join Date
    Aug 2013
    Location
    Sydney
    Posts
    391
    My Cars
    01 E39 530i,05 E53 4.8IS
    Quote Originally Posted by theshafro View Post
    The HSD USB cables are very sensitive to the USB cable you're using for iOS. I've been thru hell with this issue. The conclusion is that you need to use a 100% genuine Apple cable or a very high quality one. I use Anker USB cables and they charge/detect my iPhone just fine. This is all on NBT, I haven't tested with EVO yet.

    Which EVO unit are you guys using? I have one out of a G1x, haven't tested it yet.
    Thanks!

    Finally........ got it working!

    Bought a new Anker 1.8m USB cable and 180 degrees rotated the HSD cable........Connected drive worked!

    Now......just need to finished fabricating the bezel and iDrive mount.
    01 E39 530i - SOLD !
    05 E53 4.8is


    Pics of Bianca (E39) and Betsy (E53)

  22. #2072
    Join Date
    Feb 2016
    Location
    Kent, UK
    Posts
    31
    My Cars
    2002 BMW 330ci
    Hi everyone.

    Just wanted to give a warning against Germaniks (Michael Riva / BMWPlanetDude). Last September, I bought an NBT Evo unit, screen and cables. I opted for NBT Evo as it seemed much more capable than NBT unit. I was unaware of the fact that it was a ID4 unit originally with only 2GB RAM upgraded to run ID5/ID6. After months of chasing, Mick eventually delivered my unit to me a few days before Christmas. During testing before the install, I immediately noticed a high-pitched buzzing from the screen, and sent a message to Mick with a video. It also crashes constantly, and is completely unfit for purpose. I sent it back, and Mick upgraded the firmware saying it would resolve the crashing - it didn't. He gave me a new voltage regulator, and this didn't resolve the screen buzzing, which he said he couldn't hear. For something he said I would have back within few days, it took around a month to return, during which time I really considered contacting the Police.

    I've finally managed to get in contact with Mick again, and he is refusing to honour warranty on a faulty product. I've asked for it to be swapped to an NBT unit, or an NBT Evo 4GB as previously agreed on the phone, but he has declined. I am now seeking legal advice against him.

    Please do not purchase anything from him. I know he had a good reputation previously, but this has certainly not been the case in recent months. I don't want anyone losing out on the amount of money I have.

  23. #2073
    Join Date
    Jun 2013
    Location
    United States
    Posts
    205
    My Cars
    2002 E39 M5
    WOW! And to think that loser Commanderwiggin would call me a troll....FOH

    There's a reason Mick doesn't post anymore here. He stole $2,000 from me and never delivered anything. Should have listened to all the horror stories, that guy is a thief.

    - - - Updated - - -

    Quote Originally Posted by Jopecasa View Post
    Thanks!

    Finally........ got it working!

    Bought a new Anker 1.8m USB cable and 180 degrees rotated the HSD cable........Connected drive worked!

    Now......just need to finished fabricating the bezel and iDrive mount.
    No problem. Bezel for which car?
    '02 TiAg/Blk E39 ///M5
    '08
    JZB/FR E92 ///M3

  24. #2074
    Join Date
    Aug 2013
    Location
    Sydney
    Posts
    391
    My Cars
    01 E39 530i,05 E53 4.8IS
    Quote Originally Posted by theshafro View Post


    no problem. Bezel for which car?
    e53 x5
    01 E39 530i - SOLD !
    05 E53 4.8is


    Pics of Bianca (E39) and Betsy (E53)

Page 83 of 83 FirstFirst ... 33587374757677787980818283

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •