Page 3 of 6 FirstFirst 123456 LastLast
Results 51 to 75 of 136

Thread: M50 turbo project finsihed

  1. #51
    Join Date
    Nov 2013
    Location
    Gerrrmany
    Posts
    480
    My Cars
    E21 M50 Turbo
    Afaik M20 ones still tend to bend earlier.

    I've taken a photo of a few sets of rods, maybe helpful.

    From left to right: M52B28 - M50B25 - M50B25T▄

    - - - Updated - - -

    But lets not harass this build. Its save to say, that those M50B25 NV ones will last very very long.
    Attached Images Attached Images
    1982 E21 323i
    M50B25 Turbo
    Borg Warner S362 SX-E
    ECU Master Emu


  2. #52
    Join Date
    Oct 2010
    Location
    Huntsville, AL
    Posts
    1,903
    My Cars
    95 M3
    Quote Originally Posted by DieselGhost View Post
    Only OEM BMW Forged cranks i've seen so far are S50 euro crankshafts...

    Also i'd like a picture of those forged rods...

    ..
    http://www.google.co.uk/search?um=1&...=&oq=&tbm=isch


    Below are search words if the above link doesnt work:
    parting lines forging versus casting

    folks have indicated the stock OEM rods bend. If the OEM rods were cast, they would break, not bend. Cast material is brittle, kind of like our cylinder walls haha.
    WOT

  3. #53
    Join Date
    Nov 2010
    Location
    Njar­vÝk, Iceland
    Posts
    646
    My Cars
    2001 E36 M57TUD Compact
    i know how to spot the difference...
    Viktor Agnar Falk Gu­mundsson
    -----------------------------

    Signature idea, courtesy of 5mall5nails

  4. #54
    Join Date
    Oct 2010
    Location
    Huntsville, AL
    Posts
    1,903
    My Cars
    95 M3
    Quote Originally Posted by DieselGhost View Post
    i know how to spot the difference...
    My bad, I misunderstood your statement.
    WOT

  5. #55
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    Been putting in some major work! Drove for the first time today. No real issues, just little things to button up here and there. I bought new oil pressure and temp gauges so they matched the red interior lights. I installed them using the same sending units the old gauges used thinking they would work all the same. Well they didnt. The temp gauge now was reading 125C and oil pressure was 100psi. So i swapped the sending units with the new ones. Temp is now correct, but the oil pressure now only reads 5psi at idle and 15-18 driving. Any ideas wtf is going on with this? Why would one be so high and the other so low? Running rotella t6 5w40 btw. Guessing maybe the new oil pressure sending unit is bad. The stock oil pressure sensor is still in place and doesn't illuminate at all. Clutch and flywheel feel stock so hopefully after these 500 miles it will feel even better.
    Last edited by usherboy83; 11-03-2014 at 01:47 AM.

  6. #56
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    Car is def getting oil pressure so i just requested a new sending unit. I bought a ZF trans a couple months ago and was trying to sell it, but a buddy of mine ran across a guy who wrecked his drift m3, so i got driveshaft, guibo and bolts, full short shifter assembly and trm drift shift knob for real cheap. rocking the better trans now!! Been doing little things here and there to make the car look better. Those $150 vaders finally were reupholstered and put in, my repainted wheels finally installed with some fender rolling, installed a mateo version 1 rear diffuser, new front lip since mine was broken and repaired. I am just being super cautious with the clutch and after i put miles on it since im on vacation ill finally rip into her and see how much better she feels over the stock m50. I do need an electronic boost controller, just too cheap right now to buy a really good one as I'm thinking about the turbosmart eboost. Anyone have any experience with these? not the eboost 2 with the 60mm gauge.








  7. #57
    Join Date
    Apr 2012
    Location
    Tampa, FL
    Posts
    4,407
    My Cars
    E36,E38, and E46
    looks great man! either Im going blind or you are taking pictures with a blackberry!

  8. #58
    Join Date
    Oct 2010
    Location
    Manchester, N.H.
    Posts
    16,712
    My Cars
    96 332IS 6466 turbo
    Get the eboost2. No question about it. Best "add on" I have done, by a long shot.
    1996 332IS
    Built 3.2
    CES/Steed TS Precision 6466, spraying a "$π!℅" load of meth.
    Technique Tuning 80# tune.
    1/4 mile 10.84 @ 136.72
    Your 1 and only stop for all your BMW performance needs
    WWW.CESMOTORSPORT.COM

  9. #59
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    Quote Originally Posted by bry195 View Post
    looks great man! either Im going blind or you are taking pictures with a blackberry!
    Haha thanks. Its a galaxy note 3. The pics look great on the phone but once transfered not so much. Quick question.....i can't get my idle to stay above the rpm i choose depending on outside temp in the war tune. Im guessing its because my ambient temp sensor is bad. Any ideas?

    Butters.....any reason the eboost2 is better than the regular eboost? They are based on the same technology with prevention of over boost and solenoid strength. Just wondering.

  10. #60
    Join Date
    Apr 2012
    Location
    Tampa, FL
    Posts
    4,407
    My Cars
    E36,E38, and E46
    Quote Originally Posted by usherboy83 View Post
    Haha thanks. Its a galaxy note 3. The pics look great on the phone but once transfered not so much. Quick question.....i can't get my idle to stay above the rpm i choose depending on outside temp in the war tune. Im guessing its because my ambient temp sensor is bad. Any ideas? Butters.....any reason the eboost2 is better than the regular eboost? They are based on the same technology with prevention of over boost and solenoid strength. Just wondering.
    it could be vacuum related. check for leaks on the intake after the MAF. (try this second)
    it could be charge air temp sensor related. make sure its obd1 and the resistance values are in range.
    could be the idle control valve not working or the alignment between the MAF, TPS, and ICV is off.
    O2 sensor could be too far away from exhaust gas causing AFR swing. what is the afr at idle? disable the O2 in the war chip. (start here if you havent cuz its easy)


    if your maf/and temp are on a border area, the injector loads in the adjacent cells should be smooth and close to each other in value. its good to have very smooth transitions horizontally in RPM based maps (wot) as well as any maps that transition vertically and horizontally like PT and idle. your maps will be more responsive, the motor will run better and you will make more power. do all of this tuning with the o2 off. Im sure its not a requirement but any datalog I do I see close to 0 difference with the o2 on or off anymore but that is just me being anal retentive.

  11. #61
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    The car idles at 7-800 rpm. the o2 is already disabled, wideband and o2 are withing 18" of the turbo as brody suggested. ive checked for vaccum leaks and didnt find any, but ill def check behind the maf. i havent done any real tuning with the war chip just yet, just things to get afrs good at cruising speed and idle. other than that everything else is still running off the base tune settings. my idle afr at 7-800 doesnt register, but as soon as i get it to 1000 rpm its in the 14.6-15.1 range. after the 500 miles ill actually get it tuned

  12. #62
    Join Date
    Apr 2012
    Location
    Tampa, FL
    Posts
    4,407
    My Cars
    E36,E38, and E46
    Quote Originally Posted by usherboy83 View Post
    The car idles at 7-800 rpm. the o2 is already disabled, wideband and o2 are withing 18" of the turbo as brody suggested. ive checked for vaccum leaks and didnt find any, but ill def check behind the maf. i havent done any real tuning with the war chip just yet, just things to get afrs good at cruising speed and idle. other than that everything else is still running off the base tune settings. my idle afr at 7-800 doesnt register, but as soon as i get it to 1000 rpm its in the 14.6-15.1 range. after the 500 miles ill actually get it tuned
    I have an afr on the wideband at 500 rpm.

  13. #63
    Join Date
    Nov 2013
    Location
    Gerrrmany
    Posts
    480
    My Cars
    E21 M50 Turbo
    Maybe its running out of range lean?
    1982 E21 323i
    M50B25 Turbo
    Borg Warner S362 SX-E
    ECU Master Emu


  14. #64
    Join Date
    Apr 2012
    Location
    Tampa, FL
    Posts
    4,407
    My Cars
    E36,E38, and E46
    Quote Originally Posted by PowerKraut View Post
    Maybe its running out of range lean?
    along those lines I can turn on my ignition to accessory and Im running 14.7 without the motor running until the heater warms the sensor up. then it goes lean. I start the car and then I get a real reading. if the heater circuit is not working or the sensor goes goes cold while in operation you could get bad readings.

  15. #65
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    the gauge is saying its running out of range lean, but I haven't messed with the idle fuel trims at all and the base tune runs rich. my garage def lets me know the car is running rich. Once I blimp the throttle and idle stays at 1000rpm AFR will range 14-15, sometimes ill see it jump 13, but generally 15, until idle dies and then ---. I haven't found a single vacuum leak. All vacuum lines are new, the IAC worked fine before the swap, so Im still stumped as to why it will not idle as I want it. basically I have it set so that no matter how cold or hot the car should idle at a least 1000rpm, 1200, 1400, and 1600. I did this so that I don't run the risk of not letting the oil heat up properly, especially when it can get cold here in NC.

  16. #66
    Join Date
    Nov 2013
    Location
    Gerrrmany
    Posts
    480
    My Cars
    E21 M50 Turbo
    The symptomes sound ICV or MAF related to me.
    1982 E21 323i
    M50B25 Turbo
    Borg Warner S362 SX-E
    ECU Master Emu


  17. #67
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39




    borrowed a mechanical oil pressure gauge from a buddy....both hooked up, the electrical one is def off even with a new pressure sending unit. what gauge is everyone else running with no problems??

  18. #68
    Join Date
    Oct 2010
    Location
    Huntsville, AL
    Posts
    1,903
    My Cars
    95 M3
    Quote Originally Posted by usherboy83 View Post
    what gauge is everyone else running with no problems??
    The OEM oil light works for me.
    WOT

  19. #69
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    My oem light works but since i had an oil pump failure the first go around and the light only flickered once there was no pressure at all, i wanted a gauge. Could've saved some headache if i saw there wasnt enough pressure to begin with.

  20. #70
    Join Date
    Sep 2008
    Location
    Toronto, ON
    Posts
    2,676
    My Cars
    6465 328ti
    Quote Originally Posted by usherboy83 View Post
    borrowed a mechanical oil pressure gauge from a buddy....both hooked up, the electrical one is def off even with a new pressure sending unit. what gauge is everyone else running with no problems??
    I run a VDO vision series oil pressure gauge, electrical.

    After a buddy of mine who half assed an mechanical install had a leak and his car interior smelled like oil for weeks I got scared and decided electrical ftw. Lol

  21. #71
    Join Date
    Jun 2005
    Location
    Concord, NH
    Posts
    24,775
    My Cars
    08 E90M3; 99 E36M3 Turbo
    You need a gauge compatible with the sending unit. I use a VDO with sending unit that does both the gauge and the stock warning light.

  22. #72
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    The gauge comes with its own sending unit. Not using the stock one for gauge reading just the oem warning light.

  23. #73
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    A friend with intake, remus exhaust, and a cobb tuned e92 335i wanted to see how my car was at 8psi so we did a couple quick runs. I get noo traction in 1 or 2 so we tried a 30mph roll in 3rd....my afrs were 11.3 to 11.8 on base map and i pulled a couple cars on him twice. So im def happy to have the 2.8 this time. Now I've got to get my EBC, get redefined tune, and turn up the boost!

  24. #74
    Join Date
    Nov 2013
    Location
    Gerrrmany
    Posts
    480
    My Cars
    E21 M50 Turbo
    Wow, sounds strong for only 8 psi!
    1982 E21 323i
    M50B25 Turbo
    Borg Warner S362 SX-E
    ECU Master Emu


  25. #75
    Join Date
    Oct 2010
    Location
    greenville, nc, usa
    Posts
    1,295
    My Cars
    Turbo E36, V8 E39
    So my baby bought me autometer digital oil pressure and temperature gauges for christmas! :-) :-) :-) so i installed them all tonight after work. Soo happy with the outcome and i finally have a gauge that reads my oil pressure correctly.

Page 3 of 6 FirstFirst 123456 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •