Page 38 of 38 FirstFirst ... 132829303132333435363738
Results 926 to 949 of 949

Thread: Diagnostic program with realtime graph view

  1. #926
    Join Date
    Nov 2007
    Location
    Finland, Europe
    Posts
    524
    My Cars
    E61 520d LCI
    Quote Originally Posted by R Shaffner View Post
    Got it working! Thank you Pheno! Next step is to make a donation.
    Thanks, got it! Most appreciated! Thanks to you I got inspiration to work on some new features
    Last edited by pheno; 01-30-2019 at 01:56 AM.
    E61 520d LCI

    Check out TestO - free datalogger for BMW. Includes support for: AEM, PLX, 14point7, Innovate (through SDK)

  2. #927
    Join Date
    Feb 2019
    Location
    Italy
    Posts
    1
    My Cars
    Mini F56
    Would this software correctly read parameters on a Mini F56 Cooper S, B48 engine, MEVD17.2.3 ecu?

  3. #928
    Join Date
    Aug 2009
    Location
    London, UK
    Posts
    51
    My Cars
    E46 M3
    Is the latest version still available through the link on the first page?

    Are there any improvements scheduled?

  4. #929
    Join Date
    Jun 2017
    Location
    munich germany
    Posts
    4
    My Cars
    DS124
    Hello Mika,

    your Software seems to be ingenious, so I´d like to test and use your logger on my MINI R53 with W11 Engine.
    The DME is a EMS2K in INPA.
    Could you please implement this? Or give a hand how to manage this.
    This would be very nice.

    Best Regards
    Nik
    Last edited by flyingart; 02-18-2019 at 12:31 PM. Reason: my english ;-(

  5. #930
    Join Date
    Jul 2018
    Location
    Northern California
    Posts
    76
    My Cars
    2004 BMW 525I
    does anyone know how to get this software to work on a 2004 525i which is a e60?

  6. #931
    Join Date
    Nov 2007
    Location
    Finland, Europe
    Posts
    524
    My Cars
    E61 520d LCI
    Quote Originally Posted by flyingart View Post
    Hello Mika,

    your Software seems to be ingenious, so I´d like to test and use your logger on my MINI R53 with W11 Engine.
    The DME is a EMS2K in INPA.
    Could you please implement this? Or give a hand how to manage this.
    This would be very nice.

    Best Regards
    Nik
    FIrst try the 'Ecu Detect' function. Does it work and identify your ecu correctly ?

    - - - Updated - - -

    Quote Originally Posted by nelsonjmbf View Post
    does anyone know how to get this software to work on a 2004 525i which is a e60?
    Try the standalone version. Change COM port in file: 'ediabaslib.config' and run testo. First try: 'Ecu Detect' function to get ecu identified. Then you can run 'jobs'.
    E61 520d LCI

    Check out TestO - free datalogger for BMW. Includes support for: AEM, PLX, 14point7, Innovate (through SDK)

  7. #932
    Join Date
    Jun 2017
    Location
    munich germany
    Posts
    4
    My Cars
    DS124
    [QUOTE=pheno;30207270]FIrst try the 'Ecu Detect' function. Does it work and identify your ecu correctly ?

    Hi Mika,

    no, the Software doesn´t work or identify the ecu correctly.
    Tried all other ECU in the left window manually, but no luck.

    got Errormessage: SYS010-Initialisation Error

    The Ports all set on COM4. Also in your .ini File manually with Notepad.

    INPA and Tools32 working ok, as I could see. Both programs are calling EMS2K for the ECU.

    Would try this evening to set them all manually on COM1.



    What Idea´s do you have?
    Thanks for your assistance.

  8. #933
    Join Date
    Nov 2007
    Location
    Finland, Europe
    Posts
    524
    My Cars
    E61 520d LCI
    [QUOTE=flyingart;30207280]
    Quote Originally Posted by pheno View Post
    FIrst try the 'Ecu Detect' function. Does it work and identify your ecu correctly ?

    Hi Mika,

    no, the Software doesn´t work or identify the ecu correctly.
    Tried all other ECU in the left window manually, but no luck.

    got Errormessage: SYS010-Initialisation Error

    The Ports all set on COM4. Also in your .ini File manually with Notepad.

    INPA and Tools32 working ok, as I could see. Both programs are calling EMS2K for the ECU.

    Would try this evening to set them all manually on COM1.



    What Idea´s do you have?
    Thanks for your assistance.
    Could be something wrong with the COM port I think. Maybe some other program has reserved it. Do you use Ediabas or standalone version ?
    E61 520d LCI

    Check out TestO - free datalogger for BMW. Includes support for: AEM, PLX, 14point7, Innovate (through SDK)

  9. #934
    Join Date
    Jun 2017
    Location
    munich germany
    Posts
    4
    My Cars
    DS124
    Hi Mika,

    I use EDIABAS.
    Tried the Version with switching to COM1. INPA works, TestO do not find a ECU, Tool32 works.
    Look at the .docx I send to you via Em@il.
    By selecting the DD6 in INPA I get a fault message. Tool32 doesn´t do anything.
    Searching by https://www.leebmann24.de/bmw-ersatz...=13&bt=13_1018
    shows, this ECU is for Diesel/gasoline Engine

    So for my insight, the matching ECU-Program is absent.
    If it is so, it would be really appricate, you could implent this ECUfamily into the software.
    In assistance, if you don´t have the appropriate datas, please give a info, which do you need. Maybe I´m able to send them to you.

    thanks for your assistance
    Regards
    Nik

  10. #935
    Join Date
    Mar 2019
    Location
    lithuania
    Posts
    1
    My Cars
    e46 330d 135kw FL
    hello, i dont understand what im doing wrong but how can i change these names in english in custom jobs dde4

    N Drehzahl
    aktueller Ladedruck / Luftdruck
    Sollwert Ladedruck
    VDF Vorfoerderdruck
    KDF Raildruck
    Raildruck Sollwert
    Fahrerwunschmoment
    aktuelle Geschwindigkeit
    M_E Einspritzmenge nach ARD

    and etc.

  11. #936
    Join Date
    Sep 2018
    Location
    Georgia
    Posts
    2
    My Cars
    BMW
    Please anyone help me!
    When i try to use Test-O it shows this dialog and can't read anything from car: API-0015: Host COMMUNICATION ERROR
    I'm also using INPA and Rheingold on same laptop without any problem.
    It is win xp 32bit

  12. #937
    Join Date
    Jul 2018
    Location
    Northern California
    Posts
    76
    My Cars
    2004 BMW 525I
    im trying to use it on a 2004 525i an I get an error as well but inpa NCS an all BMW stahdartr tools work with my cable

  13. #938
    Join Date
    Nov 2007
    Location
    Finland, Europe
    Posts
    524
    My Cars
    E61 520d LCI
    Quote Originally Posted by Tato1989 View Post
    Please anyone help me!
    When i try to use Test-O it shows this dialog and can't read anything from car: API-0015: Host COMMUNICATION ERROR
    I'm also using INPA and Rheingold on same laptop without any problem.
    It is win xp 32bit
    Quote Originally Posted by nelsonjmbf View Post
    im trying to use it on a 2004 525i an I get an error as well but inpa NCS an all BMW stahdartr tools work with my cable
    Check that you have c:\ediabas\bin folder added to PATH variable in windows and have OBD.ini file located in c:\windows
    E61 520d LCI

    Check out TestO - free datalogger for BMW. Includes support for: AEM, PLX, 14point7, Innovate (through SDK)

  14. #939
    Join Date
    Jul 2018
    Location
    Northern California
    Posts
    76
    My Cars
    2004 BMW 525I
    ok, as far as I remember I do, also does anyone know where there is a decent guide on how to use datazap to catalog? also where to I EVEN get the csv file or w/e the extension is that I use to make the log from?

  15. #940
    Join Date
    Jan 2003
    Location
    Free America AZ
    Posts
    726
    My Cars
    German ones
    Pheno,

    The software identifies my ECU correctly, but when I select 'MSS54 Serial' I get an error trying to connect to COM 9? Any ideas on this? I need to do some logging with my LC-1. Thanks!
    Dave
    '15 Pure White VW Touareg TDI - The M hauler
    ///'95 Avus M3 S54B32 -Stripped, caged @ 2681#
    ///'90 Calypso 325ic (70K miles)
    ///'72 Chamonix 2002 (Restoration project)
    ///'87 Alpine 535is

  16. #941
    Join Date
    Nov 2007
    Location
    Finland, Europe
    Posts
    524
    My Cars
    E61 520d LCI
    Quote Originally Posted by MPWRCPE View Post
    Pheno,

    The software identifies my ECU correctly, but when I select 'MSS54 Serial' I get an error trying to connect to COM 9? Any ideas on this? I need to do some logging with my LC-1. Thanks!
    try modifying testo.ini and set correct COM port there for your OBD2 adapter.

    [serial]
    port=COM9
    E61 520d LCI

    Check out TestO - free datalogger for BMW. Includes support for: AEM, PLX, 14point7, Innovate (through SDK)

  17. #942
    Join Date
    Jan 2003
    Location
    Free America AZ
    Posts
    726
    My Cars
    German ones
    Quote Originally Posted by pheno View Post
    try modifying testo.ini and set correct COM port there for your OBD2 adapter.

    [serial]
    port=COM9
    INPA is using COM1 I believe, so I would change the COM9 to COM1 correct? Are there any specific cable limitations to use the MSS54 Serial option? Sorry for the lame questions, thanks!
    Dave
    '15 Pure White VW Touareg TDI - The M hauler
    ///'95 Avus M3 S54B32 -Stripped, caged @ 2681#
    ///'90 Calypso 325ic (70K miles)
    ///'72 Chamonix 2002 (Restoration project)
    ///'87 Alpine 535is

  18. #943
    Join Date
    Nov 2007
    Location
    Finland, Europe
    Posts
    524
    My Cars
    E61 520d LCI
    Quote Originally Posted by MPWRCPE View Post
    INPA is using COM1 I believe, so I would change the COM9 to COM1 correct? Are there any specific cable limitations to use the MSS54 Serial option? Sorry for the lame questions, thanks!
    Correct! The same INPA cable will work with the serial option.
    E61 520d LCI

    Check out TestO - free datalogger for BMW. Includes support for: AEM, PLX, 14point7, Innovate (through SDK)

  19. #944
    Join Date
    Jan 2003
    Location
    Free America AZ
    Posts
    726
    My Cars
    German ones
    Quote Originally Posted by pheno View Post
    Correct! The same INPA cable will work with the serial option.
    Got it running, thanks so much pheno!
    Dave
    '15 Pure White VW Touareg TDI - The M hauler
    ///'95 Avus M3 S54B32 -Stripped, caged @ 2681#
    ///'90 Calypso 325ic (70K miles)
    ///'72 Chamonix 2002 (Restoration project)
    ///'87 Alpine 535is

  20. #945
    Join Date
    May 2019
    Location
    Minsk, BY
    Posts
    1
    My Cars
    F02 n63, F10 n20
    I've seen that TestO can work via ICom adapter, is it possible to use testo via E-Net cable without real Comport? (for F-series 5 and 7)

  21. #946
    Join Date
    Jan 2018
    Location
    Belgium
    Posts
    4
    My Cars
    V40
    Hello, all, pheno,

    Having bought, a fair while ago, some Chinese ELM-327-cloned OBDII bluetooth adapter, I hadn't been able to establish a diagnostics connection with my previous bike's OBD. Establishing the serial line connection worked, but I could never get to the point where a (K-Line) bus init worked. Most of the ELM327's AT- commands wouldn't work. So this OBDII- connector didn't work with my (in the meantime sold) K1300S in the past, and it doesn't work now either with my Honda VFR800F.

    So now I'm looking for a working OBDII adapter with which I will be able to work (and use testo). However, there are a lot of uncertain adapters, some of which aren't even ELM327- based, but own designs (claiming to have a compatible AT- command set). Apart from interrogating my bikes over the raw serial line, I want this diagnostic adapter to also work with testo. Hence my question : do I need an ELM327-chip-based OBDII adapter ? I imagine I do, because testo will most probably be communicating with the OBDII connector(s) using the ELM327's AT- command set, wont it ? Or is any compatible (/claimed compatible) ELM327- command set OK ?

    I guess anything below 20€ is most probably some form of an ELM-clone, below 30€ is still "fairly suspect". But as from around 35€, I guess I should be able to buy a decent OBDII adapter ? Some hints (and links) of known working OBDII (bluetooth) adapters are always welcome...

  22. #947
    Join Date
    Nov 2007
    Location
    Finland, Europe
    Posts
    524
    My Cars
    E61 520d LCI
    Quote Originally Posted by sudolea View Post
    Hello, all, pheno,

    Having bought, a fair while ago, some Chinese ELM-327-cloned OBDII bluetooth adapter, I hadn't been able to establish a diagnostics connection with my previous bike's OBD. Establishing the serial line connection worked, but I could never get to the point where a (K-Line) bus init worked. Most of the ELM327's AT- commands wouldn't work. So this OBDII- connector didn't work with my (in the meantime sold) K1300S in the past, and it doesn't work now either with my Honda VFR800F.

    So now I'm looking for a working OBDII adapter with which I will be able to work (and use testo). However, there are a lot of uncertain adapters, some of which aren't even ELM327- based, but own designs (claiming to have a compatible AT- command set). Apart from interrogating my bikes over the raw serial line, I want this diagnostic adapter to also work with testo. Hence my question : do I need an ELM327-chip-based OBDII adapter ? I imagine I do, because testo will most probably be communicating with the OBDII connector(s) using the ELM327's AT- command set, wont it ? Or is any compatible (/claimed compatible) ELM327- command set OK ?

    I guess anything below 20€ is most probably some form of an ELM-clone, below 30€ is still "fairly suspect". But as from around 35€, I guess I should be able to buy a decent OBDII adapter ? Some hints (and links) of known working OBDII (bluetooth) adapters are always welcome...
    If you're using INPA/Ediabas and TestO then forget about ELM- clones. Just search for 'BMW INPA DCAN' cable.
    E61 520d LCI

    Check out TestO - free datalogger for BMW. Includes support for: AEM, PLX, 14point7, Innovate (through SDK)

  23. #948
    Join Date
    Jan 2018
    Location
    Belgium
    Posts
    4
    My Cars
    V40
    Bummer, I already bought a cable before your answer. Now I wonder if my (ELM- based) cable would work with testo ? And what I also ask myself : isn't the cable you mention (looking at its name) only for DCAN- equipped communication to the ECU ? Because I intend to give testo a try for my K-Line-equipped motorbikes, wouldn't I need a K-Line variant in that case ?

    I also asked myself where I can learn more about the communication "under the hood" ? Because I fail to put all the pieces together between communication of OBDII software over ELM327 -like chipsets/cables, compared to the EDIABASlib communication over this kind of cable you mention.

    The former runs serially, most probably with AT- commands "under the hood", so as to obtain the correct signals "on the other, i.e. OBDII-, side of the chip" ? After which it starts interrogating the different OBDII services. Or am I wrong on this ?

    But for the latter : could you point me to some document of how this latter (EDIABASlib) software communicates with the car/bike ? I fail to put together the pieces of how both end up in obtaining the needed information of the OBDII- side. A link would already be quite OK, I can't expect a lengthy, exhaustive (/time-consuming) explanation !

  24. #949
    Join Date
    Jun 2019
    Location
    India
    Posts
    1
    My Cars
    BMW F30 320D
    Quote Originally Posted by pheno View Post
    If you're using INPA/Ediabas and TestO then forget about ELM- clones. Just search for 'BMW INPA DCAN' cable.
    I have an F30 320d (N47 Engine). Can somebody please list the steps in using an ENET (Ethernet) cable with Testo?
    I assigned a static IP address to the laptop as suggested for ISTA, but was unable to get communication up and running with my motor. Help!

Page 38 of 38 FirstFirst ... 132829303132333435363738

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •