Page 21 of 21 FirstFirst ... 1112131415161718192021
Results 501 to 524 of 524

Thread: (Almost) free DIY ADS interface

  1. #501
    Join Date
    Nov 2014
    Location
    Latvia
    Posts
    10
    My Cars
    E36 325tds
    Ok, I just tested it on other engine, it works great, thank you!

  2. #502
    Join Date
    Oct 2016
    Location
    USA
    Posts
    2
    My Cars
    BMW
    Hello,
    I built the interface from the very first post in this thread, but can only access the ABS unit (ABS MK20) and nothing else on my EU 1997 e36 316 compact. All other modules just gave errors when trying to open. Even the battery and ignition indicators doesn't come on but the ABS unit error codes and brake pedal on/off signal shows just fine. Could it be a problem with my circuit or the Inpa installation I have? The version is inpa-6.4.3-full. Or should I build the improved "MK2" version? I have the pin 15 insert in my car and haven't found any OBD2 socket.

    I'm using a Dell laptop with a real serial port and Windows XP with no service pack, FIFO buffers set to 8.
    Last edited by murrama; 10-23-2016 at 09:47 AM.

  3. #503
    Join Date
    Oct 2016
    Location
    USA
    Posts
    2
    My Cars
    BMW
    I tried another laptop (Toshiba Pentium 2 from 1998, XP), and the battery and ignition indicators and the ABS module worked, but nothing more. The battery and ignition indicators didn't work on the first laptop but they worked on this. Strange... Maybe I should just build the MK2 version.

  4. #504
    Join Date
    Dec 2007
    Location
    Queensland, Australia
    Posts
    4,284
    My Cars
    E70 3.0sd E21 323i
    Some Dells need to use a special ADS32.dll file as their serial ports are not conventionally wired. Unless you have made an error with installing the software, INPA is unlikely to be the problem as this is one of the most functional versions ever released.
    Last edited by David Mc; 11-22-2016 at 06:37 PM.

  5. #505
    Join Date
    Apr 2014
    Location
    UK
    Posts
    1,054
    My Cars
    1995 BMW 328
    Serial ports are fine on Tosh Satellite 1800, Dell D400 (and 610 but not 600 IIRC)
    No warranty of any kind implied or given and no liability for any loss, damage or injury, no matter how incurred accepted.

  6. #506
    Join Date
    Jan 2014
    Location
    serbia
    Posts
    42
    My Cars
    e36 325i
    does anubody hawe link with instalation manual for inpa usb i cant find .or install video on youtube,last time i install with some poland guy video byt cant find again

  7. #507
    Join Date
    Jan 2014
    Location
    serbia
    Posts
    42
    My Cars
    e36 325i
    Can this interface read webasto auhilary heater? I read somewere that webasti can read everu interface through K line but i dont know how to

  8. #508
    Join Date
    Apr 2014
    Location
    UK
    Posts
    1,054
    My Cars
    1995 BMW 328
    Got bored

    Made diagram from the one at the front of the thread as al those floating earths needed something doing..........


    1 - Final.jpg


    Then thought I would be helpful with the track cutting for a second one


    3.JPG


    And here's how the bits layout on the other side


    2.jpg


    This one I inserted 2 LED for fun. The red X are the extra track cuts to make this work with LEDs. The red lines are where the track cuts are (more or less) on the other side. If I recall correctly the changes for LED adding do not impact the wiring to and from Serial and Diagnostics. D is for diagnostic and S is for serial. Numbers are the pins


    WiresResTranOhm - FINAL.jpg


    And complete


    4.JPG
    Last edited by E36328Coupe; 04-16-2018 at 03:32 PM.
    No warranty of any kind implied or given and no liability for any loss, damage or injury, no matter how incurred accepted.

  9. #509
    Join Date
    Feb 2017
    Location
    UK
    Posts
    1
    My Cars
    E36
    Hello guys!
    I've made my ADS interface but had some problems:
    Firstly I used BC558A as my PNP transistor in INPA and DIS I could only read Instrument cluster module, as I not sure what model my transistor is I switch collector with emitter. Still only instrument cluster works. I found in this topic someone post simplified version and said that transistors should be hFE > 100, my BC558A is probably less so replace it with BC560C. Now when I put transistor in correct position, INPA doesn't work. But if I put it reversed still only instrument cluster works. Connection with instrument cluster works both ways, I can enter tests, read/delete errors. Could you help me find what probably be wrong? My car is E36 early '95 with only pin 20, there is no pin 17.

  10. #510
    Join Date
    Sep 2007
    Location
    EST
    Posts
    4
    My Cars
    1996 BMW E36, 316i
    Hello all.

    I did build the ADS from first post of this thread.
    It works pretty perfectly. Can connect to dashboard, ABS, AIRBAG, ECU etc.

    Found that i have code: 42 Knock sensor 2



    Problem is that the com port plug and the laptop com port socket area gets extremly hot.
    I dont think that its normal.

    Its a old Dell laptop.

    One guy here decided to put 10kOhm resistor into RI line.
    Maybe it will help?

    Im worried, i dont want to damage that laptop and/or its com port.
    The laptop was sitting on engine but it was not so hot. Almost cool..
    I repeat: only the area around laptop com port socket gets very hot.


    Any ideas what it could be?
    Last edited by PLATINUM316; 04-02-2017 at 05:05 AM.

  11. #511
    Join Date
    Apr 2014
    Location
    UK
    Posts
    1,054
    My Cars
    1995 BMW 328
    I use a Dell D400 and based my diagram above on first post and can access all modules. No heat issues
    Check your circuit wiring
    No warranty of any kind implied or given and no liability for any loss, damage or injury, no matter how incurred accepted.

  12. #512
    Join Date
    Aug 2017
    Location
    Ukraine,Lugansk
    Posts
    2
    My Cars
    1992 BMW 3 series coupe
    Hello, please tell me, I've assembled the HansV ADS interface scheme, see a lot of things, ABS, air conditioning, dashboard, central locking and something else, but does not see the DME (Siemens ms 40.1) wires from the diagnostic pad to the DME whole, Inpa just Hangs on reading DME, DIS also does not see DME.
    Can anyone tell why so? And what to do to see the DME? Thanks in advance !!!what to do to see the DME? Thanks in advance !!!

  13. #513
    Join Date
    Aug 2017
    Location
    Ukraine,Lugansk
    Posts
    2
    My Cars
    1992 BMW 3 series coupe
    Thanks for the help, figured out for yourself, the problem was with the tole computer due to Windows 7, the roofing felts due to the non-working com-port! I took another computer and it all worked! Thanks for the scheme of HansV !!!

  14. #514
    Join Date
    Oct 2008
    Location
    Coos Bay Oregon
    Posts
    516
    My Cars
    09/95' 325ic
    I'm having a hell of a time getting the Tiny ADS interface to work with my 95 M50 325i Convertible. Does anyone know where I can get a working, unmodified version of INPA which will play nice with my car? Every working download I find has been modified in some way so it works well on modern versions of windows and/or USB adapters. I've got an old XP machine with a real serial port right to the motherboard. I've read everything on every forum and thread I could find. I've edited the .ini files accordingly. It's the Tiny ADS adapter which is inside the 20-pin connector so I know I didn't screw up any wiring. Best I can get is Battery On and Ignition On indicators but every task results in communication errors. I've been at this for a couple months now.

  15. #515
    Join Date
    Dec 2007
    Location
    Queensland, Australia
    Posts
    4,284
    My Cars
    E70 3.0sd E21 323i
    You don't need to edit EDIABAS.ini unless you are using INPA as a basis to support DIS. There is also a lot of misinformation circulating about OBD.ini - this file is not required for INPA v4.4.7(aka v3.01)/EDIABAS v6.4.3, it is only required for later versions of EDIABAS (i.e. v6.4.7 and up). The problem with your car is that it is a pre-EWS model and INPA does not contain the necessary files for these cars, you will have to use DIS v44 in order to get coverage.
    Last edited by David Mc; 11-12-2017 at 03:23 AM.

  16. #516
    Join Date
    Oct 2008
    Location
    Coos Bay Oregon
    Posts
    516
    My Cars
    09/95' 325ic
    Quote Originally Posted by David Mc View Post
    You don't need to edit EDIABAS.ini unless you are using INPA as a basis to support DIS. There is also a lot of misinformation circulating about OBD.ini - this file is not required for INPA v4.4.7(aka v3.01)/EDIABAS v6.4.3, it is only required for later versions of EDIABAS (i.e. v6.4.7 and up). The problem with your car is that it is a pre-EWS model and INPA does not contain the necessary files for these cars, you will have to use DIS v44 in order to get coverage.
    My car does have EWS. I know 1995 is an odd year for EWS but my master key has a chip and build date is 09/95 so I know it was one of the last 325i's of the E36 generation.

    Edit~~ I just noticed your PM. Thank You

  17. #517
    Join Date
    Dec 2007
    Location
    Queensland, Australia
    Posts
    4,284
    My Cars
    E70 3.0sd E21 323i
    OK, obviously a MY1996 (build date actually commenced in 1995). You should be fine with INPA v4.4.7/EDIABAS v6.4.3 (make sure you only have one instance of INPA installed).

  18. #518
    Join Date
    May 2017
    Location
    Germany
    Posts
    6
    My Cars
    1995 E36 328i
    Thank you so much for posting this DIY! After a lot of struggling getting INPA to run, I managed to connect to my gauge cluster on the workbench

  19. #519
    Join Date
    Apr 2014
    Location
    UK
    Posts
    1,054
    My Cars
    1995 BMW 328
    Quote Originally Posted by David Mc View Post
    You don't need to edit EDIABAS.ini unless you are using INPA as a basis to support DIS. There is also a lot of misinformation circulating about OBD.ini - this file is not required for INPA v4.4.7(aka v3.01)/EDIABAS v6.4.3, it is only required for later versions of EDIABAS (i.e. v6.4.7 and up). The problem with your car is that it is a pre-EWS model and INPA does not contain the necessary files for these cars, you will have to use DIS v44 in order to get coverage.
    This is incorrect, there are some files out there that allow for the lack of EWSII so you can use an ADS interface to connect to the 325 engine with INPA.

    Search for Mistreku.zip
    No warranty of any kind implied or given and no liability for any loss, damage or injury, no matter how incurred accepted.

  20. #520
    Join Date
    Dec 2007
    Location
    Queensland, Australia
    Posts
    4,284
    My Cars
    E70 3.0sd E21 323i
    I have those files, which are an edited version of factory INPA files and have limited application. They are designed to run primarily on Tool32 rather than INPA as in order to create them, the usual INPA/EDIABAS job telegram protocol is interrupted.
    Last edited by David Mc; 11-28-2017 at 08:21 PM.

  21. #521
    Join Date
    Oct 2008
    Location
    Coos Bay Oregon
    Posts
    516
    My Cars
    09/95' 325ic
    I've had INPA+Tiny ADS Interface working perfectly on an old PC of mine since I last posted (Thank You SO Much, David MC). Unfortunately I'm entirely unable to achieve my goal of reading error codes for the GM 4L30 Auto Trans in my 95' E36. Has anyone else successfully done this? Do I need some special files? I've searched forever and have totally hit a wall.

  22. #522
    Join Date
    Jun 2014
    Location
    Bandung
    Posts
    6
    My Cars
    1994 E36 320i

    Thank You

    Found this thread while i was searching for ads adapter. It is 2018 and i can confirm that the schematic from beneromous works great (post #1) for my RHD 94 E36 MT (m50) iím able to read all the modules with DME also (MS 40.1)..thanks guys..



    Last edited by lorensiuswlt; 03-29-2018 at 04:44 AM.

  23. #523
    Join Date
    Apr 2018
    Location
    The Netherlands
    Posts
    1
    My Cars
    1994 BMW 325i
    Im trying to make your stripboard version of the serial<->obd connector:


    https://www.bimmerforums.com/forum/s...terface/page21
    post #508


    The problem is I cant figure out where pin 17/20 should go, i think it might be A6.
    But there is no 22kOhm resistor on your stripboard picture.


    Could it be that you linked multiple resistors to mimic a 22kohm with these:?
    1K->1K->10k->pin17/20->10k


    And is it ok to have pin 17/20 in between the resistors instead of after a 22kohm?

  24. #524
    Join Date
    Apr 2014
    Location
    UK
    Posts
    1,054
    My Cars
    1995 BMW 328
    Quote Originally Posted by klaas View Post
    The problem is I cant figure out where pin 17/20 should go, i think it might be A6.
    Previous post updated.

    (I did link multiple resistors as it was cheaper for the quantity of other I have bought not to buy 20K or 22K. You coulduse a 22k from C3 - H6 I think)
    Last edited by E36328Coupe; 04-17-2018 at 02:12 PM.
    No warranty of any kind implied or given and no liability for any loss, damage or injury, no matter how incurred accepted.

Page 21 of 21 FirstFirst ... 1112131415161718192021

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •