Results 1 to 14 of 14

Thread: New z3 owner, advice needed

  1. #1
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    3,300
    My Cars
    99' Cosmos ///M3

    New z3 owner, advice needed

    Well unfortunately my e36 m3 got rearended recently and was totaled.

    I just picked up a 2000 Z3 2.3 to replace it for the time being until i'm ready to upgrade to an e46 m3. I must say the power isnt bad at all, and its an absolute blast to drive.

    I'ts overall a very clean car that i got a geat deal on(has 92k) miles, but I noticed after driving it more the engine is abnormally loud upon revving. There is no squealing, or ticking, just a loud mechanicalish sound when revving(almost like when a car is low on oil).

    This sound comes:
    -When revving and revs coming down
    -clutch in or out
    -at all rpms
    -is much worse when car is cold

    Also, the power steering seems to be having issue, this may or may not be related? At a stop, much worse when cold, turning the wheel stresses the pump and gives that distinct dry power steering pump noise.

    Im guessing to target the pulleys, my question is though, which ones? And also, any other ideas on what this noise could be or if im making a pretty good guess?

    Id really like to fix the issue this week as i plan to drive it to OC next weekened, the car is perfect otherwise and drives awesome! OH one more thing, the car came with oem chrome wheels, anyone want to trade for any non chrome wheels??????????
    Last edited by FriedKalamari; 03-21-2010 at 11:53 PM.

  2. #2
    Join Date
    Jan 2008
    Location
    Fort Worth, TX
    Posts
    3,168
    My Cars
    E36M3/E46M3/E39M5/E63M6
    Maybe a stupid question, but did you actually check the fluids levels?
    E36/8 2000 M Coupe Cosmos Black/Black
    Shark, Conforti CAI, B&B Exhaust, H&R, Bilstein, AKG Subframe/Diff, UUC TME Red/Caps, Swapped Front Hats, Ice>Link.
    ================================================== =======================

  3. #3
    Join Date
    Dec 2006
    Location
    Batavia, IL
    Posts
    4,397
    My Cars
    00 M Coupe, 08 335xi

  4. #4
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    3,300
    My Cars
    99' Cosmos ///M3
    Quote Originally Posted by TexaZ3 View Post
    Maybe a stupid question, but did you actually check the fluids levels?
    yeah, all look good.

    Quote Originally Posted by SunzOut View Post
    Sounds like vanos rattle.
    any way to check or diagnose?

  5. #5
    Join Date
    Dec 2006
    Location
    Batavia, IL
    Posts
    4,397
    My Cars
    00 M Coupe, 08 335xi

  6. #6
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    3,300
    My Cars
    99' Cosmos ///M3
    Quote Originally Posted by SunzOut View Post
    if you rev the engine, does the noise come from the top/front of the engine.
    just checked it, it does indeed come from the top area of the engine, you can also faintly hear the uneasy noise during idle...

  7. #7
    Join Date
    Dec 2003
    Location
    Northern Va
    Posts
    11,563
    My Cars
    E36/8, K12R, E91
    Vanos or maybe just a bad idler pully (known to go - I just replaced mine with half the mileage).
    2002 Alpine White w/ Black 368 (<OO \(||][||)/ OO>)
    Power: Custom Exhaust w/ High Flow cats, CSL headers, built, low-compression Supercharged and aftercooled S-54, ViPEC standalone ECU, Vortech V2 Si trim
    Driveline: Euro 6 speed, 3.64 diff w/ 40% Lockup, Rogue Octane SSK, UUC Red TME kit, UUC Stage 3 LTW Flywheel/M5 Clutch, SS Shift Knob
    Suspension & Brakes: TC Kline True Match Coilovers 500f/500r w/ adjustable camber plates, Racing Dynamics sways, Custom front sway endlinks, ATE fluid, UUC/Willwood BBK 6 piston f - 4 piston r , Slotted E46M3 Rotors, Stainless Lines, Strong Strut, IE Subframe & adjustable rear trailing arm bushings
    ICE & Misc: Projector Z's w/DDE & 5k HID, 19'' Gold HRE C20's, Custom Aux pwr outlet, footwell lighting, ACS Splitters, Areo Sideskirts, Custom gauge pods, Z8 Start, Pioneer AVIC Z3, Clarus Components, 10" RE Sub in a Mister-X Enclosure, Alpine PDX 4X150 + 1X600 Amps
    Coming soon: and a visit to Randy Forbes

  8. #8
    Join Date
    Apr 2005
    Location
    Burlington/Freehold NJ
    Posts
    11,392
    My Cars
    Z3, 528i, M5, X5, Jetta
    Quote Originally Posted by clintjg View Post
    Vanos or maybe just a bad idler pully (known to go - I just replaced mine with half the mileage).
    +1
    1999 528i - Titanium Silver over Silverstone/Black Leather, Sport
    2000 Z3 2.3 -Topaz Blue over Sand Beige, Sport
    2003 M5 - Imola Red over Imola Red/Black, Sport
    2004 X5 4.8is - Estoril Blue/Black
    2018 M2 - Long Beach Blue/Black

  9. #9
    Join Date
    Mar 2008
    Location
    Potomac, MD
    Posts
    420
    My Cars
    04 M3 vert, 07 A4Q 2.0
    Some one makes a kit that changes the worn out oring of the vanos. If you were on the e36 board, they talk about this all the time.

  10. #10
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    3,300
    My Cars
    99' Cosmos ///M3
    whats the best way to solve this vanos issue? anyone perform this fix? seems like theres alot of ways to do this whether it be the whole unit, a kit fix, or replacing the solenoid...

  11. #11
    Join Date
    May 2002
    Location
    SW Florida
    Posts
    12,151
    My Cars
    99-01 M Cpe & Rdts, X5M
    The whole unit. Your solenoid can be tested separately, but my money says it's good.

  12. #12
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    3,300
    My Cars
    99' Cosmos ///M3
    Quote Originally Posted by Randy Forbes View Post
    The whole unit. Your solenoid can be tested separately, but my money says it's good.
    fml....

    cheapest place to get it?

  13. #13
    Join Date
    Dec 2003
    Location
    Northern Va
    Posts
    11,563
    My Cars
    E36/8, K12R, E91
    dr.vanos,

    I'd verify the pully first though.... $50 vs. $500+
    2002 Alpine White w/ Black 368 (<OO \(||][||)/ OO>)
    Power: Custom Exhaust w/ High Flow cats, CSL headers, built, low-compression Supercharged and aftercooled S-54, ViPEC standalone ECU, Vortech V2 Si trim
    Driveline: Euro 6 speed, 3.64 diff w/ 40% Lockup, Rogue Octane SSK, UUC Red TME kit, UUC Stage 3 LTW Flywheel/M5 Clutch, SS Shift Knob
    Suspension & Brakes: TC Kline True Match Coilovers 500f/500r w/ adjustable camber plates, Racing Dynamics sways, Custom front sway endlinks, ATE fluid, UUC/Willwood BBK 6 piston f - 4 piston r , Slotted E46M3 Rotors, Stainless Lines, Strong Strut, IE Subframe & adjustable rear trailing arm bushings
    ICE & Misc: Projector Z's w/DDE & 5k HID, 19'' Gold HRE C20's, Custom Aux pwr outlet, footwell lighting, ACS Splitters, Areo Sideskirts, Custom gauge pods, Z8 Start, Pioneer AVIC Z3, Clarus Components, 10" RE Sub in a Mister-X Enclosure, Alpine PDX 4X150 + 1X600 Amps
    Coming soon: and a visit to Randy Forbes

  14. #14
    Join Date
    Jan 2003
    Location
    San Francisco
    Posts
    3,300
    My Cars
    99' Cosmos ///M3
    Quote Originally Posted by clintjg View Post
    dr.vanos,

    I'd verify the pully first though.... $50 vs. $500+
    I dont know that it's the pulley anymore. I checked out the car more closely today and it has that marbles rolling around the engine sound even just at idle.

    one question i do have though, if i could care less about the noise, any reprocutions for not fixing it?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •