Page 1 of 2 12 LastLast
Results 1 to 25 of 38

Thread: EEP_2...wtf?

  1. #1
    Join Date
    Feb 2008
    Location
    San Diego
    Posts
    467
    My Cars
    Z//Coupe

    Exclamation EEP_2...wtf?

    Started my car this morning and the code EEP_2 code showed up in the instrument cluster all gauges we're dead. Turned the car off and restarted and code went away and instrument gauges we're working fine. Anybody have any idea what this means? Couldn't find much anything in regards..help whats the EEP 2 code?

    Mods: Dinan stage 2 chip, Dinan CAI, Bilstein sport, HR Springs, Rougue RSM, Supersprint DTM exhaust, 17'" Keskin KT1 wheels, Stewart Water pump, Wheelskins leather steering wheel, Leather Z stuff, ProjectorzII, Tuner Pulley Kit, Ireland Engineering Radiator, M Bumbper, M Side Gills, M steering wheel, M Rear View Mirror, Factory Fogs lights.

  2. #2
    Join Date
    Sep 2006
    Location
    Tyrone, Ga USA
    Posts
    9,847
    My Cars
    2010 135i M Sport 6MT
    looking through the bentley right now. so far i see that eep = the main circuit board controlling the instrument cluster.

  3. #3
    Join Date
    Jan 2009
    Location
    Suburban Chicago
    Posts
    1,179
    My Cars
    '04 Z4 3.0i roadster
    Maybe it was "Eep Hour!" (Garcia reference!)

  4. #4
    Join Date
    May 2007
    Location
    Tarzana, ca
    Posts
    1,849
    My Cars
    1999 M Roadster, 4Runner
    its the noise you make when you find out how much a new circuit board costs.

  5. #5
    Join Date
    Sep 2006
    Location
    Tyrone, Ga USA
    Posts
    9,847
    My Cars
    2010 135i M Sport 6MT
    from what i have dug up on other forums it means you have a bad instrument cluster. you will have to have it replaced and the bentley manual outlines what to do to make your milage show back up on the new cluster. if you get a used cluster make sure that it has less milage then your car since the process of restoring the milage takes the higher of the two values.

  6. #6
    Join Date
    Feb 2008
    Location
    San Diego
    Posts
    467
    My Cars
    Z//Coupe
    Thanks 2K! Well it hasn't reappeared since, hopefully it NEVER comes back..the last thing I'm looking forward to is having to change my instrument cluster :/

    Mods: Dinan stage 2 chip, Dinan CAI, Bilstein sport, HR Springs, Rougue RSM, Supersprint DTM exhaust, 17'" Keskin KT1 wheels, Stewart Water pump, Wheelskins leather steering wheel, Leather Z stuff, ProjectorzII, Tuner Pulley Kit, Ireland Engineering Radiator, M Bumbper, M Side Gills, M steering wheel, M Rear View Mirror, Factory Fogs lights.

  7. #7
    Join Date
    Sep 2006
    Location
    Tyrone, Ga USA
    Posts
    9,847
    My Cars
    2010 135i M Sport 6MT
    Quote Originally Posted by gio14 View Post
    Thanks 2K! Well it hasn't reappeared since, hopefully it NEVER comes back..the last thing I'm looking forward to is having to change my instrument cluster :/
    atleast it looks like an easy swap!

  8. #8
    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    3,874
    My Cars
    2001 M Roadster
    This just came up for me tonight. Sure enough, once the car warmed up I restarted her and it went away. Anyone have any clues as to what causes this?

    I am fairly certain I have a very occasional short that I think is somewhere near the head lamps. When it rains sometimes the turn signal will do the fast blink thing indicating a lamp is out and if I jiggle the lamp fitting it stops. Maybe these are related?

  9. #9
    Jeremy's Avatar
    Jeremy is offline ǝoɥsuʍolƆ ǝnƃɐǝ˥ ɹoɾɐW BMW CCA Member
    Join Date
    Aug 2007
    Location
    Phoenix, AZ
    Posts
    12,119
    My Cars
    2002 Smurf Hearse
    I JUST got the same EEP 2 indicator on Monday. Same thing, gauges we're dead. Shut it off, restarted, and it's been trouble free since. I dunno...
    jeremy [AT] coupecartel [DOT] com

    1 of 1 | 2002 Laguna Seca Blue/Black M Coupe | LK61201
    "I don't know the key to success, but the key to failure is trying to please everybody.."



  10. #10
    Join Date
    Feb 2011
    Location
    Boston 'burbs
    Posts
    2,209
    My Cars
    '01 Z3.0 R; '13 MB Coupe
    Where do the letters show up, on the mileage screen?


    Mods: Remus 76mm exhaust, CDV delete, ASA AR1 18in staggered wheels, Turner 12 mm spacers, custom red tails, Kenwood deck/Sirius/BT/USB, ZHP knob, Redline boot, LeatherZ armrest, Amsoil all around, red needles, Akebono Euro brake pads, 34k original miles!

  11. #11
    Jeremy's Avatar
    Jeremy is offline ǝoɥsuʍolƆ ǝnƃɐǝ˥ ɹoɾɐW BMW CCA Member
    Join Date
    Aug 2007
    Location
    Phoenix, AZ
    Posts
    12,119
    My Cars
    2002 Smurf Hearse
    Quote Originally Posted by BlackjackM View Post
    Where do the letters show up, on the mileage screen?
    jeremy [AT] coupecartel [DOT] com

    1 of 1 | 2002 Laguna Seca Blue/Black M Coupe | LK61201
    "I don't know the key to success, but the key to failure is trying to please everybody.."



  12. #12
    Join Date
    Sep 2009
    Location
    Twin Cities, Minnesota
    Posts
    293
    My Cars
    Z3 96, Cooper 08
    Quote Originally Posted by JWin View Post
    I am fairly certain I have a very occasional short that I think is somewhere near the head lamps. When it rains sometimes the turn signal will do the fast blink thing indicating a lamp is out and if I jiggle the lamp fitting it stops. Maybe these are related?
    Also I've read on here that the trunk wiring loom can get shorted out. May want to look at that wiring, too.

  13. #13
    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    3,874
    My Cars
    2001 M Roadster
    I'm surprised how little information is available on this issue. Now that's cooled off in TX it's a [near] permanent fixture on my dash. I'm about to - though afraid to - buy a new damn cluster. Has any other information on this come out?

  14. #14
    Join Date
    May 2002
    Location
    SW Florida
    Posts
    12,334
    My Cars
    99-01 M Cpe & Rdts, X5M
    When the cars were new, instrument clusters were being replaced under warranty all the time. I guess you'd have to do some ten - twelve year old searches for posts on the matter (try roadfly.com, as that's where most of us signed on before 2002).

    My black car received a new cluster when the service interval lights counted down to an "oil service" about two weeks after the oil was serviced (while still under BMW maint.).

    The cluster is easy to change, removing only two (2) screws (be extremely careful not to scratch them up, or anything else) and a few painful facial contortions. It can be slipped out to the left with the steering wheel still in place. It's possible to release the two (three?) cable connectors blindly, and they cannot be interchanged accidentally, having different number of connections. There is a coding plug you transfer from the old one to the new one, but beyond that I have no more useful information, as I've never needed to replace one myself. I only pulled my own 01 cluster out to put a bulb in the "SPORT" socket (illuminated by Daniel's controller).

  15. #15
    Join Date
    May 2008
    Location
    CNJ
    Posts
    1,159
    My Cars
    '97 Z3 1.9 DASC Auto
    Just doing a quick look around the net and a few things keep being repeated:

    1. Power source on the back of the onboard computer needs fixing
    2. "CPU" dead (needs replacing)
    3. 2 NiCd batteries in cluster need replacing
    4. Ground for instrument cluster in inner fender well needs tightening

    These supposed fixes seem to point to a power or ground issue of an internal processor.

    It would be interesting to run clean power and ground to the cluster and then a cooling spray on various components to see what happens. Cold days were almost always mentioned when the cluster stops working.

    Might try resoldering the EEPROM legs on the cluster as well.

    More reading/hints:
    http://www.bimmerfest.com/forums/sho...d.php?t=160260
    Last edited by Monolith; 11-13-2012 at 02:16 PM.
    Mods: DASC, NickG Stage II DME software, 30# injectors, RRFPR removed, DISA Simulator, Secondary Air Pump relocated, bypass cooling hose removed, Fogged airbox, Bosch silver sparkplugs (F6DSR), Magnecore sparkplug wires (KV85), SeattleCircuit mpg adjuster circuit; Textar CeramicFusion brake pads; S/E/M auto trans selector with Euro software TCU; Royal Purple trans (MaxATF) & diff fluids (MaxGear); Koni FSD struts/shocks; Rogue RSMs; Strong Strut; Butt Strut; Sumitomo HTR A/S P01 225/50/16 on Style 88's; hardtop; Footwell lighting; Interior lighting On/Off switchable; Euro intermittent wipers; Padded LeatherZ arm rests; Sisa Cabrio Design Wind Deflector; Interior proximity sensor

  16. #16
    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    3,874
    My Cars
    2001 M Roadster
    I've read through German, French and Mexican forums (on top of the usual suspects) and didn't get quite as much info as you seem to have found, Monolith. I didn't even find out there were batteries in the damn thing.

    @Randy - I'm squeemish about sensitive plastic things. I removed the steering wheel last time I pulled it out to give me room to not break anything...

  17. #17
    Join Date
    May 2008
    Location
    CNJ
    Posts
    1,159
    My Cars
    '97 Z3 1.9 DASC Auto
    I'd take my list with a grain of salt. I didn't confirm any of the stories, just tried to find how some people "fixed" it. The guy trying to replace the "batteries" ended up destroying his cluster while taking it apart and just buying another one.

    It's interesting to note that the odometer gets overwritten on the cluster. The mileage is stored in the EEPROM (which some say originates the EEP errors). If you follow my link, one fellow with the MB suggested wiping the EEPROM and reprogramming it will cure the problem.

    Ran across a German site that will fix the EEP errors for 139 Euros.
    Last edited by Monolith; 11-13-2012 at 03:39 PM.
    Mods: DASC, NickG Stage II DME software, 30# injectors, RRFPR removed, DISA Simulator, Secondary Air Pump relocated, bypass cooling hose removed, Fogged airbox, Bosch silver sparkplugs (F6DSR), Magnecore sparkplug wires (KV85), SeattleCircuit mpg adjuster circuit; Textar CeramicFusion brake pads; S/E/M auto trans selector with Euro software TCU; Royal Purple trans (MaxATF) & diff fluids (MaxGear); Koni FSD struts/shocks; Rogue RSMs; Strong Strut; Butt Strut; Sumitomo HTR A/S P01 225/50/16 on Style 88's; hardtop; Footwell lighting; Interior lighting On/Off switchable; Euro intermittent wipers; Padded LeatherZ arm rests; Sisa Cabrio Design Wind Deflector; Interior proximity sensor

  18. #18
    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    3,874
    My Cars
    2001 M Roadster
    Quote Originally Posted by Monolith View Post
    Ran across a German site that will fix the EEP errors for 139 Euros.
    I saw that, but the cost of fix and shipping is likely close enough to the cost of a new unit to not even bother.

  19. #19
    Join Date
    May 2008
    Location
    CNJ
    Posts
    1,159
    My Cars
    '97 Z3 1.9 DASC Auto
    They probably just reflow the solder on the EEPROM and send it back.

    Here's a link describing the failure as an EEPROM (mileage) failure:
    http://www.fixya.com/cars/t6141447-a...ncing_eep_1_ob

    Here's a data sheet showing how the EEP1, EEP2, EEP3 nomenclature is used as storage locations for EEPROMs (just click on the document image for PDF):
    http://www.datasheetarchive.com/inde...ser-highscore#
    Last edited by Monolith; 11-13-2012 at 06:25 PM. Reason: Automerged Doublepost
    Mods: DASC, NickG Stage II DME software, 30# injectors, RRFPR removed, DISA Simulator, Secondary Air Pump relocated, bypass cooling hose removed, Fogged airbox, Bosch silver sparkplugs (F6DSR), Magnecore sparkplug wires (KV85), SeattleCircuit mpg adjuster circuit; Textar CeramicFusion brake pads; S/E/M auto trans selector with Euro software TCU; Royal Purple trans (MaxATF) & diff fluids (MaxGear); Koni FSD struts/shocks; Rogue RSMs; Strong Strut; Butt Strut; Sumitomo HTR A/S P01 225/50/16 on Style 88's; hardtop; Footwell lighting; Interior lighting On/Off switchable; Euro intermittent wipers; Padded LeatherZ arm rests; Sisa Cabrio Design Wind Deflector; Interior proximity sensor

  20. #20
    Join Date
    Feb 2001
    Location
    Palo Alto, CA
    Posts
    648
    My Cars
    '01 MCoupe, '16 550i
    Did you guys ever figure this out?

    My cluster has started doing this after my service shop insisted on doing a computer upgrade for my DM-TL fault as they thought the "available upgrade" would magically cure the CEL.

    Now my cluster shows the EEP_2 error intermittently. It seems temperature related and more frequent on cold mornings. After the error displays, I have to go through the cluster reset function in order to get the speedometer to read accurately again. Otherwise it reads ~20mph higher than true road speed.

    I wonder if I need to bite the bullet and get the cluster repaired.
    Pani
    2001 Laguna Seca Blue M Coupe

  21. #21
    Join Date
    May 2008
    Location
    Austin, TX
    Posts
    3,874
    My Cars
    2001 M Roadster
    Quote Originally Posted by Pani View Post
    Did you guys ever figure this out?

    My cluster has started doing this after my service shop insisted on doing a computer upgrade for my DM-TL fault as they thought the "available upgrade" would magically cure the CEL.

    Now my cluster shows the EEP_2 error intermittently. It seems temperature related and more frequent on cold mornings. After the error displays, I have to go through the cluster reset function in order to get the speedometer to read accurately again. Otherwise it reads ~20mph higher than true road speed.

    I wonder if I need to bite the bullet and get the cluster repaired.
    Basically, your coupe is broken forever and you should sell it to me and look for another.

  22. #22
    Join Date
    Sep 2001
    Location
    So. Cal
    Posts
    2,003
    My Cars
    05 M3, 01 Z3M, Jeep ZJ
    A bit off topic, I think the instrument clusters on the s54's is the only CAN-BUS related item in the car. Kinda funny they blended the old e36 tech with the newer e46 stuff to make it all work.

    dont mind me <whistles>



    Current:
    2001 S54 M-Coupe
    2011 Mini Cooper Countryman S
    94 Grand Cherokee Laredo 4.0L/242 TC (Daily)

    Past:

    95 325i Convertible/Boston Green
    01 330Ci Convertible/Steel Grey/Stick
    05 Infiniti G35 Premium/Tech

  23. #23
    Join Date
    Aug 2013
    Location
    Buffalo, NY
    Posts
    8
    My Cars
    Z3

    How do you reset cluster

    Can you describe how to reset the instrument cluster?

    Quote Originally Posted by Pani View Post
    Did you guys ever figure this out?

    My cluster has started doing this after my service shop insisted on doing a computer upgrade for my DM-TL fault as they thought the "available upgrade" would magically cure the CEL.

    Now my cluster shows the EEP_2 error intermittently. It seems temperature related and more frequent on cold mornings. After the error displays, I have to go through the cluster reset function in order to get the speedometer to read accurately again. Otherwise it reads ~20mph higher than true road speed.

    I wonder if I need to bite the bullet and get the cluster repaired.
    - - - Updated - - -

    I have the eep_2 error and I'm trying to figure this out, can anyone teel me how to reset the cluster?

  24. #24
    Join Date
    Jan 2010
    Location
    Boynton Beach, FL
    Posts
    1,633
    My Cars
    98 M Roadster
    Quote Originally Posted by Monolith View Post
    3. 2 NiCd batteries in cluster need replacing
    What purpose do the batteries serve? Some kind of memory function?

  25. #25
    Join Date
    Jan 2011
    Location
    Nottingham, UK
    Posts
    975
    My Cars
    E31, E36/7, E61
    And another EEP-2 code. First time I have seen this.

    All clocks dead, apart from the speedo, and EEP-2 displayed on the odometer.

    Switched off and restarted and all working and reset.

    I will monitor the situation and get INPA on the case when I get time, will post any results here. Fingers crossed for now.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •