Page 1 of 2 12 LastLast
Results 1 to 25 of 36

Thread: Engine Swaps & Wiring Fun

  1. #1
    MauiM3Mania's Avatar
    MauiM3Mania is offline Observer/Master Skeptic Moderator
    Join Date
    Jan 2002
    Location
    Central Pacific
    Posts
    8,890
    My Cars
    88M3 99M3 04M3 ITBx16

    Engine Swaps & Wiring Fun

    Quote Originally Posted by sidewayz328is View Post
    Does anyone know a source that tells you exactly what pins on the X20 to swap when putting a S50B32 into a US car? Or, could someone post it here...
    Sideways328IS... to avoid thread drift, lets bring your discussion into this new thread.

    I don't believe there is a "how to" that covers all the possible varieties of chassis wiring/engine wiring combinations. To verify that the two are indeed 'in alignment', you need to review the ETM (Electrical Trouble shooting Manual) of both and make the needed pin assignment changes.

    To be safe, you want to review each and every pin so that a signal goes to the wrong place.

    What year/model is your car and same for your engine/wiring harness? Hopefully someone will have what you need.

    Scott

    Project | 88M3 AW 43k miles OEM Shift Knob
    Auto-X | 99M3 Cosmos 60k S50B32 284░ euro 6Spd 3.91
    Sat/Sun | 04M3 TiAg 65k non-sunroof 3 pedal
    Daily | 01X5 3.0 Schwarz 5spd manual

    Forum Rules
    New Member Info

  2. #2
    Join Date
    Dec 2002
    Location
    Lake Tyler, TX
    Posts
    5,694
    My Cars
    88 E30 M3 S65
    Agreed. I was the one that figured out the MZ3 harness was different (or if somebody knew I never found anything on the net stating as such). Alex found out that later MZ3s have EWSIII. Agree that the best bet is to get confortable with the ETM. I never read electrical diagrams before so there was a learning curve, but if I can do it ANYBODY can.
    It's not speed that kills, it's the speed difference that does. Obviously you aren't going fast enough.

    Turning Benjamins into noise since 1997

    I read a list of the 100 things you MUST do before you die. Funny, "Yelling 'HELP'" didn't make the list!

  3. #3
    MauiM3Mania's Avatar
    MauiM3Mania is offline Observer/Master Skeptic Moderator
    Join Date
    Jan 2002
    Location
    Central Pacific
    Posts
    8,890
    My Cars
    88M3 99M3 04M3 ITBx16
    Quote Originally Posted by gobuffs View Post
    Agreed. I was the one that figured out the MZ3 harness was different (or if somebody knew I never found anything on the net stating as such). Alex found out that later MZ3s have EWSIII.
    Hey, we found out (prolly later than you) about the MZ3 harness too! LOL.

    Scott

    Project | 88M3 AW 43k miles OEM Shift Knob
    Auto-X | 99M3 Cosmos 60k S50B32 284░ euro 6Spd 3.91
    Sat/Sun | 04M3 TiAg 65k non-sunroof 3 pedal
    Daily | 01X5 3.0 Schwarz 5spd manual

    Forum Rules
    New Member Info

  4. #4
    Join Date
    Dec 2002
    Location
    Lake Tyler, TX
    Posts
    5,694
    My Cars
    88 E30 M3 S65
    Quote Originally Posted by MauiM3Mania View Post
    Hey, we found out (prolly later than you) about the MZ3 harness too! LOL.

    Scott
    I am sure somebody else knew it before I "discovered" it.
    It's not speed that kills, it's the speed difference that does. Obviously you aren't going fast enough.

    Turning Benjamins into noise since 1997

    I read a list of the 100 things you MUST do before you die. Funny, "Yelling 'HELP'" didn't make the list!

  5. #5
    Join Date
    Jan 2007
    Location
    Oakville, Ontario, Canada
    Posts
    761
    My Cars
    '05 M3 ZCP
    Thanks for starting this thread Scott. I've been searching the forums and reviewing ETM's trying to get a handle on the wiring but I feel like an idiot.

    The chassis is a 98 328is for which I have sourced the ETM here:
    http://www.bmwtechinfo.com/etm/data/e36/e36_98.pdf

    There are 3 round connectors on the chassis harness next to the fuse panel (X20, X6031, X69)

    The harness is from a LHD euro 3.2 M3 which I sourced from Germany. I do not know the exact year. It only has 2 round connectors on it, the smaller of which only has 3 pins.

    I have found the X20 pin assignments on another thread and credit for this goes to the OP:

    Euro 3.2 X20 pinouts:

    1 Not used
    2 Not used
    3 Not used
    4 Air Con SW/BL
    5 Air Con SW/BR
    6 Air Con VI/GR
    7 Enable signal from EWS II module pin 4 to Motronic pin 66
    *8 Check engine light
    *9 Oil temperature sensor to Instrument cluster X16 pin 13
    10 Reverse light switch
    11 Coolant Temp sensor pin 2 to Instrument cluster X17 pin 17 BR/GE
    12 Coolant Temp sensor pin 1 to Instrument cluster X17 pin 18 BR/VI
    13 Fuel Pump Relay Terminal 87 to Fuse F18 GN/VI
    *14 Road speed signal from Instrument cluster to motronic pin 42
    15 I am cranking' signal from Starter terminal 30h to OBC pin 8
    16 Diagnostic Connector pin 15 (Diagnostic Data Link RX) WS/GE
    17 Diagnostic Connector pin 20 (Diagnostic Data Link TX) to EWS II module pin 2 WS/VI
    18 Starter terminal 50 to EWS II module pin 1 SW/GE
    19 Diagnostic Connector pin 7 to Instrument cluster X17 pin 15 (service reset) WS/GN
    20 Engine speed o/p from Motronic pin 47 to Instrument cluster X16 pin 20 SW
    21 Ignition Switch terminal 15 to Ignition coils & Motronic pin 56 GN
    *22 Live in Run & Start from Ign switch term 15 via fuse 26 GN/WS
    23 Oil Pressure switch to Instrument cluster X17 pin 19
    24 Fuel Rate output from Motronic pin 46 to Instrument cluster X16 pin 21 & OBC WS/SW
    25 Charging Voltage (Alternator D+) to Instrument cluster X17 pin 6 BL

    Another member posted the pinouts for the X69 connector on the euro harness:

    10 Oil temp switch
    11 Fan control relay (from DME)
    12 Oil level signal (from DME)

    I know I have to match up the euro X20 pins to the chassis X20 pins. I do not know exactly which ones have to be moved, what I have to do with the 3 pins on the euro X69 or what I have to do with all the pins on the chassis X69 and X6031. I would also like to know how to wire the oil temp for the cluster and the CEL.

    All help is appreciated!

  6. #6
    MauiM3Mania's Avatar
    MauiM3Mania is offline Observer/Master Skeptic Moderator
    Join Date
    Jan 2002
    Location
    Central Pacific
    Posts
    8,890
    My Cars
    88M3 99M3 04M3 ITBx16
    I think you would do best by determining what year/model the engine and harness is from and locate the appropriate ETM.

    Then go down the lists and compare to establish what needs to be shifted about.

    My bud/tech and I put in more than a few hours scouring over the two ETMs. After the install and a half dozen or so pin assignment swaps, the engine fired up within a second of the key being turned.

    The last thing you want to do is send a wayward signal to the DME or wherever it doesn't belong.

    Project | 88M3 AW 43k miles OEM Shift Knob
    Auto-X | 99M3 Cosmos 60k S50B32 284░ euro 6Spd 3.91
    Sat/Sun | 04M3 TiAg 65k non-sunroof 3 pedal
    Daily | 01X5 3.0 Schwarz 5spd manual

    Forum Rules
    New Member Info

  7. #7
    Join Date
    Jan 2007
    Location
    Oakville, Ontario, Canada
    Posts
    761
    My Cars
    '05 M3 ZCP
    The engine was built in 96 but was RHD so I sourced a LHD harness from Germany. I don't know its prod. date and have no way of getting it.

    The X20 connector should not be too difficult. I think there are a few pins that have to be moved and I know what they are.

    My main concern is the other 2 connectors on the car (X69, X6031) and the other connector on the engine harness (X69). What do I do with these?? Do I have to move wires from one connector to another?

    If anyone can help me out with this part I would really appreciate it!

  8. #8
    Join Date
    Aug 2004
    Location
    Queens NY
    Posts
    7,292
    My Cars
    99 M3 Euro, 09 Fit
    the thing that sux is that my swap is going to be started soon and the wiring is a PITA
    99 Techno S50B32 6-speed ///M3 (Complete)
    Mods: SOLD


  9. #9
    Join Date
    Dec 2002
    Location
    Lake Tyler, TX
    Posts
    5,694
    My Cars
    88 E30 M3 S65
    Quote Originally Posted by MIMI1 View Post
    the thing that sux is that my swap is going to be started soon and the wiring is a PITA
    wiring is not that hard. If I can figure out ANYBODY can.
    It's not speed that kills, it's the speed difference that does. Obviously you aren't going fast enough.

    Turning Benjamins into noise since 1997

    I read a list of the 100 things you MUST do before you die. Funny, "Yelling 'HELP'" didn't make the list!

  10. #10
    Join Date
    Aug 2004
    Location
    Queens NY
    Posts
    7,292
    My Cars
    99 M3 Euro, 09 Fit
    Quote Originally Posted by gobuffs View Post
    wiring is not that hard. If I can figure out ANYBODY can.
    any tips?
    99 Techno S50B32 6-speed ///M3 (Complete)
    Mods: SOLD


  11. #11
    Join Date
    Dec 2002
    Location
    Lake Tyler, TX
    Posts
    5,694
    My Cars
    88 E30 M3 S65
    Quote Originally Posted by MIMI1 View Post
    any tips?
    cozy up and learn how to read an ETM for both the chassis and the engine. check, double check, recheck the double check, and recheck again for good measure BEFORE starting.
    It's not speed that kills, it's the speed difference that does. Obviously you aren't going fast enough.

    Turning Benjamins into noise since 1997

    I read a list of the 100 things you MUST do before you die. Funny, "Yelling 'HELP'" didn't make the list!

  12. #12
    Join Date
    Aug 2004
    Location
    Queens NY
    Posts
    7,292
    My Cars
    99 M3 Euro, 09 Fit
    Quote Originally Posted by gobuffs View Post
    cozy up and learn how to read an ETM for both the chassis and the engine. check, double check, recheck the double check, and recheck again for good measure BEFORE starting.
    ETM is short for?

    99 Techno S50B32 6-speed ///M3 (Complete)
    Mods: SOLD


  13. #13
    Join Date
    Dec 2002
    Location
    Lake Tyler, TX
    Posts
    5,694
    My Cars
    88 E30 M3 S65
    Electronic Troubleshooting Manual.
    It's not speed that kills, it's the speed difference that does. Obviously you aren't going fast enough.

    Turning Benjamins into noise since 1997

    I read a list of the 100 things you MUST do before you die. Funny, "Yelling 'HELP'" didn't make the list!

  14. #14
    Join Date
    Nov 2004
    Location
    Arlington Heights, IL
    Posts
    2,190
    My Cars
    Z1, M3 LTW, 228

    Hopefully....

    You'll get some support from the vendor that sold you the engine. In a perfect world.

    Bruce... you under-estimate your skills...

    But, I'm grinning as I recall the last time you and I were shoulder to shoulder trying to de-bug my *&*@$# brake light problem.

    (come to think of it, I don't think I've gone out and bought a back up brake light switch as they certainly don't seem to last forever now, do they?)

    Alex.
    Alex Lipowich
    xyobgyn on AOL

    For Sale: E36 325 MTechnic with S54 on stock DME TBA

    Trying to make the world a better place with 5 or now 7 extra throttle bodies at a time.

  15. #15
    Join Date
    Apr 2004
    Location
    Oklahoma
    Posts
    5,083
    My Cars
    996, 914, X5
    Quote Originally Posted by sidewayz328is View Post
    Thanks for starting this thread Scott. I've been searching the forums and reviewing ETM's trying to get a handle on the wiring but I feel like an idiot.

    The chassis is a 98 328is for which I have sourced the ETM here:
    [FONT=arial,helvetica,helv][SIZE=2] http://www.bmwtechinfo.com/etm/data/e36/e36_98.pdf
    I've pulled the ETM for the 93 E36 chassis I have, but cannot find any pin assignments for the X20 connector. I can find the pin assignments for Data Link, X16, X17, and several other connectors, but cannot find X20.

    Any suggestions anyone?

  16. #16
    Join Date
    Mar 2001
    Location
    FL
    Posts
    6,534
    My Cars
    E36
    Pin layouts for X20, X69, and X6031 will vary depending on the year, model, and OPTIONS your particular car has.

    (For instance: ASC, Automatic transmission, etc)

    Jmitro: did you just try doing a Ctrl+F in the .pdf for "X20"? That's what I did and just cross-checked every instance it came up on both corresponding engine and chassis diagrams. After a few minutes it can get easy for your eyes to miss them.
    Last edited by jvit27; 02-26-2009 at 07:37 PM.
    '04 Jet Black + Cinnamon ///M3 coupe (SMG)
    V-CSL, BBS CH, Íhlins R&T, Brembo GT, Supersprint, Z4M seats, Avant-2

    '99 Estoril Blue + Dove Grey ///
    M3 coupe
    Technique Tuning Stage 1 Turbo, TC Kline DA,
    Rallyroad Brembo BBK, Recaro SRD, ZF 6spd, BMW Traffic Pro 4771, ZKW FX-R

    Gone but not forgotten:

    '99 M3 Estoril Blue/Dove Grey (bought new), '95 M3 Arctic Silver/Black (3.5 HFM setup), '97 318ti Arctic Silver/Red Millpoint (M-Tech Dinan), '02 325XiT Black/Black/5MT (wintermobile), '98.5
    "M3 RS" Cosmos Black/M-cloth (GrpN S50b32), '02 M3 Alpine White/Impulse/SMG (sunroof delete), '04 X5 4.8iS Estoril Blue/M-texture, '02 M3 Alpine White/Black/6MT (CSL wh0re), '97 M3 Techno Violet/Modena (Eurosport Twinscrew), '04 M3 Alpine White/Black/SMG (garage queen)




  17. #17
    MauiM3Mania's Avatar
    MauiM3Mania is offline Observer/Master Skeptic Moderator
    Join Date
    Jan 2002
    Location
    Central Pacific
    Posts
    8,890
    My Cars
    88M3 99M3 04M3 ITBx16
    As I recall, we had to review the entire set of wiring diagrams to determine what pin/wire did what at the X20. A real fun project, but needed if you wanted to be assured you had the correct signals going to the correct device or source.

    Project | 88M3 AW 43k miles OEM Shift Knob
    Auto-X | 99M3 Cosmos 60k S50B32 284░ euro 6Spd 3.91
    Sat/Sun | 04M3 TiAg 65k non-sunroof 3 pedal
    Daily | 01X5 3.0 Schwarz 5spd manual

    Forum Rules
    New Member Info

  18. #18
    Join Date
    Dec 2002
    Location
    Lake Tyler, TX
    Posts
    5,694
    My Cars
    88 E30 M3 S65
    I was never able to find a pinout in the ETM for the X20 as well. You have to search and look and trace and search and trace..... Took me a few days to get it done. Actually I printed the pages and followed every wire going thru the fusebox to see if I needed it or not. What wasn't needed I put a big "X" over it. The I said, ok, if I an in the car and I want to start it, figure out how that happens on the ETM. Worked for me.
    It's not speed that kills, it's the speed difference that does. Obviously you aren't going fast enough.

    Turning Benjamins into noise since 1997

    I read a list of the 100 things you MUST do before you die. Funny, "Yelling 'HELP'" didn't make the list!

  19. #19
    Join Date
    Apr 2004
    Location
    Oklahoma
    Posts
    5,083
    My Cars
    996, 914, X5
    Quote Originally Posted by jvit27 View Post
    Pin layouts for X20, X69, and X6031 will vary depending on the year, model, and OPTIONS your particular car has.

    (For instance: ASC, Automatic transmission, etc)

    Jmitro: did you just try doing a Ctrl+F in the .pdf for "X20"? That's what I did and just cross-checked every instance it came up on both corresponding engine and chassis diagrams. After a few minutes it can get easy for your eyes to miss them.
    I tried the control F for "X20" but no matches came up. Looks like I'll be doing it by hand. Alex told me the X20 connections would be different for each chassis and options. Questions is......is the Euro 3.2 X20 pin assignments the same across the board for all motors? Ie, what's listed above will work for my motor?

    Quote Originally Posted by gobuffs View Post
    I was never able to find a pinout in the ETM for the X20 as well. You have to search and look and trace and search and trace..... Took me a few days to get it done. Actually I printed the pages and followed every wire going thru the fusebox to see if I needed it or not. What wasn't needed I put a big "X" over it. The I said, ok, if I an in the car and I want to start it, figure out how that happens on the ETM. Worked for me.
    whoa, whoa. i'm way to lazy to do all that . Damn wiring, I guess I'll be doing it all by hand.

  20. #20
    Join Date
    Mar 2001
    Location
    FL
    Posts
    6,534
    My Cars
    E36
    Quote Originally Posted by jmitro View Post
    I tried the control F for "X20" but no matches came up. Looks like I'll be doing it by hand. Alex told me the X20 connections would be different for each chassis and options. Questions is......is the Euro 3.2 X20 pin assignments the same across the board for all motors? Ie, what's listed above will work for my motor?
    I would guess they are all very similar, if not the same? as long as it's an M3 ETM and not an MZ. Euro cars did not have OBD, CEL, traction control or automatics (but they did have SMG). Cant say for certain though as I only have the 1998MY ETM's.
    '04 Jet Black + Cinnamon ///M3 coupe (SMG)
    V-CSL, BBS CH, Íhlins R&T, Brembo GT, Supersprint, Z4M seats, Avant-2

    '99 Estoril Blue + Dove Grey ///
    M3 coupe
    Technique Tuning Stage 1 Turbo, TC Kline DA,
    Rallyroad Brembo BBK, Recaro SRD, ZF 6spd, BMW Traffic Pro 4771, ZKW FX-R

    Gone but not forgotten:

    '99 M3 Estoril Blue/Dove Grey (bought new), '95 M3 Arctic Silver/Black (3.5 HFM setup), '97 318ti Arctic Silver/Red Millpoint (M-Tech Dinan), '02 325XiT Black/Black/5MT (wintermobile), '98.5
    "M3 RS" Cosmos Black/M-cloth (GrpN S50b32), '02 M3 Alpine White/Impulse/SMG (sunroof delete), '04 X5 4.8iS Estoril Blue/M-texture, '02 M3 Alpine White/Black/6MT (CSL wh0re), '97 M3 Techno Violet/Modena (Eurosport Twinscrew), '04 M3 Alpine White/Black/SMG (garage queen)




  21. #21
    Join Date
    Apr 2004
    Location
    Oklahoma
    Posts
    5,083
    My Cars
    996, 914, X5
    allright, after a few hours, here's what I got using the 93 E36 ETM:

    1.
    2.
    3. brake light switch to X8500 BR/GR
    4. compressor control relay (air con?) SW/BL
    5. DME to pressure switch SW/GR
    6. climate control VI/GR
    7. On board computer/DME pin 66 SW/VI
    8. DME to check engine light GR
    9.
    10. Reverse light switch BL/GE
    11. coolant temp sensor to cluster BR/GE
    12. coolant temp sensor to cluster BR/VI
    13. fuel pump relay/ front power distribution GN/VI
    14. Road speed output to DME pin 42 SW/WS
    15. starter to OBC/CRC SW/GN
    16. datalink connector pin 15 WS/GE
    17. datalink connector pin 20 to X183 WS/VI
    18. starter relay SW/GE
    19. datalink connector pin 7 to cluster WS/GN
    20. Engine speed to cluster SW
    21. Engine Control system/DME and ignition switch GN
    22. datalink connector pin 16, HOt in Run and Start GN/WS
    23. oil pressure switch to cluster BR/GR or BR/GN
    24. Fuel consumption to DME pin 46 WS/SW
    25. alternator D+ to cluster pin 6 BL

    what do you guys think? most of mine match up, except for numbers 3,5, and 9. I think 7 matches except I can't find it in the ETM for my chassis year.

  22. #22
    Join Date
    Apr 2004
    Location
    Oklahoma
    Posts
    5,083
    My Cars
    996, 914, X5
    here's an update to my information above with some added stuff.

    My chassis wiring harness was blank in the #7 position, so I modified an unused pin, and connected the light green EWS #4 wire to the X20 #7 position.

    For the ignition/start wiring (if using an aftermarket starter button).......
    1. ignition wire from panel (hot in run and start).....to large green wire from ignition tumbler position 15. Gives power to coils via the DME
    2. starter wiring (momentary power for the starter)......to EWS #3 (large green/black wire).
    3. starter control via EWS....large black/yellow wire from EWS to large black/yellow X20 connector

    the car started right up after building fuel pressure and fixing a fuel leak.

    edit...got interrupted by my daughter.
    My motor/harness is from a RHD car from the UK. Slight differences I found...
    My euro motor X20 pin #9 (oil temp to cluster X16) is unused. This wiring was instead in the X6031 connector

    also, my individual chassis X20 was not identical to what I found in the ETM....for example, ETM lists X20 pin 3 as "brake light switch", but my X20 pin 3 was blank.
    Last edited by jmitro; 03-17-2009 at 10:27 PM.

  23. #23
    Join Date
    Aug 2004
    Location
    Queens NY
    Posts
    7,292
    My Cars
    99 M3 Euro, 09 Fit
    after staring at etms for the past 6 hours this is what i came up with only euro side for now

    this is for a 98 or so euro engine



    if something is not right correct me
    99 Techno S50B32 6-speed ///M3 (Complete)
    Mods: SOLD


  24. #24
    Join Date
    Mar 2007
    Location
    Breckenridge, CO
    Posts
    25
    My Cars
    BMW Z3 Coupe
    Does anybody have the etm for a 1998 M3 S50b32 (euro)? Please email to Shane@RougeRacing.com

  25. #25
    Join Date
    Jan 2007
    Location
    Dominican Republic, Santo Domingo
    Posts
    47
    My Cars
    BMW Z3 M COUPE
    i! i saw on a thread that you made a S50 conversion.. i did one aswell into my us mcoupe.. i have everthing on the car the EWS aligned etc... but when i try to fire the car it starts and dies.. I have over 1 year trying to figure out whats wrong without luck.. can you please provide me the wiring diagram or at least point me where i should start looking?

    heres a link of what the car is doing

    [ame]http://www.youtube.com/watch?v=W0x33PKLuU8[/ame]

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •