Page 4 of 4 FirstFirst 1234
Results 76 to 93 of 93

Thread: X5 FAQ, common problems and model year changes

  1. #76
    Join Date
    Sep 2012
    Location
    derbyshire
    Posts
    2
    My Cars
    bmw x5
    hi there im new and ive just open a part time garage, ive got a bmw x5 on a 53 reg its a 3.0i petrol with twin vanos we put it on code readed and took all the codes off service one and other faults, basically we did a full service and few other parts started it was fine no engine management light or any other lights, took it for a run and then let it ticking over fine, but then came to switch it back on and the engine management light came back on so code scanned it again and it came up with 1-6 misfiring and both o2 sensors but i have heared that it can be down to the vanos's and wondered if it would be that plus there is also a rattle that i have also seen that could be down to the vanos seals gone

    any help would be good

  2. #77
    Join Date
    Oct 2012
    Location
    Mentor Ohio
    Posts
    11
    My Cars
    03 BMW m3 , 03 BMW x5
    I'm having trouble getting my wife's BT to get strong signal. I took tcu from 05 e46. I put one of these tcu in my 03 e46 m3, I added antenna and mic. The prewiring was all there including cream fakra connector. Work greats paired easy. So I tried same thing in her 03 x5. I can't find that cream colored fakra conn. I could only find light blue one. I put that in the coded blue terminal on the tcu. Then the pin harness in other end. Also found black fakra with purple clip with male and female together. I unplugged it and attached a BT. Antenna to female end. Left male end hanging there. I was able to pair put signal strength seems good but quality is poor. Do I need to do something with eject box? There's nothing there but a small harness and another male black & purple fakra conn. can u please help? I've checked all forums and can't find anything were a cream colored fakra is missing

  3. #78
    Join Date
    Oct 2009
    Location
    mill creek, wa
    Posts
    501
    My Cars
    01 e38x3 95 e540/6
    I still have a ton of electrical issues with my 04 3.0 ... cant figure them out ...

  4. #79
    Join Date
    Nov 2012
    Location
    San Jose
    Posts
    2
    My Cars
    2006 BMW 750i
    I would love to get your input on this 03-E53 4.6is that I'm 90% sure I'm going to purchase tomorrow morning...it's right under 70k miles for $17,500. Clean car fax & autocheck, the current owner is the 3rd, has had it only 6k miles...he says only a brake light comes on and that only the pads need to be changed out. It's amazingly clean but from reading your posts and what's online I'm a bit worried there maybe some underlying issues I cannot see. Im not sure he will allow me to do a PPI on his e53 but I'm going try regardless...What can you suggest I can do to put me at better ease? All your info is greatly appreciated!

  5. #80
    Join Date
    Apr 2010
    Location
    Arlington, VA
    Posts
    1,721
    My Cars
    E39 M5, E70 35d
    Quote Originally Posted by MobetterBMW View Post
    I would love to get your input on this 03-E53 4.6is that I'm 90% sure I'm going to purchase tomorrow morning...it's right under 70k miles for $17,500. Clean car fax & autocheck, the current owner is the 3rd, has had it only 6k miles...he says only a brake light comes on and that only the pads need to be changed out. It's amazingly clean but from reading your posts and what's online I'm a bit worried there maybe some underlying issues I cannot see. Im not sure he will allow me to do a PPI on his e53 but I'm going try regardless...What can you suggest I can do to put me at better ease? All your info is greatly appreciated!
    Your not sure the seller will allow a PPI? Then walk away, its a simple/necessary precaution when purchasing a vehicle.

    Those V8's can be a headache if not maintained well
    National Capital Chapter #465420 ///M Registry
    2000 ///M5 | Oxford Green Metallic II (430) | Caramel Nappa Leather (M3CR) | BMW Individual Black Birch Trim
    Tuning Tech Tune by Frank Smith (http://www.tuningtechfs.com/)
    SuperSprint Headers
    SuperSprint X-Pipe
    DINAN Exhaust
    Storm Motorwerks Products
    Slimmbones Products

    2011 X5 35d | Alpine White | Beige | Sports Pkg | Cold Weather Pkg | Technology Pkg | 3rd row option
    2003 X5 4.6iS | Black Sapphire | Black Sport |


    Previous:
    2006 X3 3.0i | Silver Gray | Terracotta | M-Sport | SOLD

    2000 323Ci | TiAg | Gray | 5MT | SOLD

  6. #81
    Join Date
    Dec 2012
    Location
    NEW YORK
    Posts
    2
    My Cars
    2001 BMW X5
    my 2001 x5 cranks and wont start .i unplug the fuel pump and put it back and after a few min it start ran for a good hour .i shut it down and after about 2 hrs i drove it to the store let it run when i was getting ready to leave it shut down again. is this the fuel pump or a fuel filter.i do not know where the fuel filter is.

    my 2001 x5 cranks and wont start .i unplug the fuel pump and put it back and after a few min it start ran for a good hour .i shut it down and after about 2 hrs i drove it to the store let it run when i was getting ready to leave it shut down again. is this the fuel pump or a fuel filter.i do not know where the fuel filter is.
    Last edited by cityrock; 12-02-2012 at 10:07 PM. Reason: Automerged Doublepost

  7. #82
    Join Date
    Aug 2010
    Location
    FL/MA/CA
    Posts
    22
    My Cars
    1995 318i

    2006 X5 3.0i Pre Purchase Inspection

    I just signed on a 2006 X5 with 108k miles for $13,900 pending a PPI and I want your help to determine if it is a great vehicle. I have owned a 1995 318i for a number of years and have kept it running with the help of this forum. I don't have the time/$$ to put a lot of work into this vehicle after I purchase it and want to make sure I catch everything possible during the PPI.

    I've included a link to the vehicle below and some pictures as well. Can someone tell me what they think of this deal and what areas I should have the mechanic (a independent shop that only does BMWs) focus on during the pre-purchase??

    http://www.dedhamauto.com/used/BMW/2...52044668a5.htm

    Thanks! I wouldn't be a BMW owner without the help of this forum

  8. #83
    Join Date
    Dec 2012
    Location
    Georgia
    Posts
    2
    My Cars
    2001 BMW X5
    My tailight(pass sd) just doesn't work even though I've been to (european motors)a shop several times. My frustration led me to examine it myself only to find out they rigged it with wires as a quick fix, when compared the drive side has no wires whatsoever. I tried soldering it for better contact but to no avail. Does anyone know where I can get one for a decent price/

  9. #84
    Join Date
    Jan 2013
    Location
    London Ontario
    Posts
    4
    My Cars
    2003 BMW X5 4.6is S3-R
    My 2003 X5 4.6is S3 Dinan,

    My X5 Dinan S3 is at Intermittent times going into Engine Fail Safe Mode. The Oil Temperature is within Specifications, the Cooling System is well within Safe Operational Temperature, the Rpm's start to act like a Malfunctioning MAF Sensor, or a TPS.

    I keep coming across this Subject and there are varying accounts of possible causal Factors, and possible Solutions, that seem to be a lot of guesswork. My X5 has only 60MI and no Warranty Remaining.

    I have not Powerwashed the Engine Bay, or anything has been unplugged (sensors) this is an Intermittent Problem that is quite Frustrating. BMW does not like to give out any Information about their Machines, to aid in Diagnosing this Problem.

    The MIL Light is Illuminated, and on one occasion it has Flashed a couple times. I would Appreciate a BMW Automotive Technician to aid in my cause!! I am a Licensed Technician but my Weaker Skill Set impedes my efforts in Electrical Diagnostic Skills. I am a General Automotive Technician, so I am mainly Mechanical Minded.

    Please Help!!!!

  10. #85
    Join Date
    Mar 2013
    Location
    McAllen, Texas
    Posts
    7
    My Cars
    2006 325i , 2007 X5

    X5/E70 Fail to start, press the start button and not even a crank, please leads...

    Friday my X5 fail to start short after i took it out of the driveway, put the key in, press the stop pedal, press the start button and nothing, just a humming noise as always when you press the button without depressing the stop pedal like when you are going to reset some service on the car obd.

    i read the same issued happen on several bmw but i have not seen a fix or root cause of the problem, any feedback? i get no error message on the key, on the screen sometimes i get the yellow message to press the pedal (even when i am pressing), sometimes the 4x4 malfunction message... i all ready took the battery out, took to advance and autozone for testing and both say it was ok but they charge it for one hour anyway, reinstall and nothing, same thing... went to the dealer and worthless with this guys, i rater ask my son.... yes will get better help.

    i noticed that the break pedal is very stiff, but might be normal as i have might have lost the vacuum as vehicle has no engine power, the steering wheel column dont move, i just hear a click noise when i move the toggle switch to move up/down, front/back and also the steering wheel wont lock...

    any feedback guys??? help. thanks

  11. #86
    Join Date
    Feb 2008
    Location
    South africa
    Posts
    28
    My Cars
    bmw 325isport shadowline
    Hello ppl. I recently purchased a 2003 x5 e53 3.0d.. No1 has mentioned the diesel, not sure If u guys got them as I'm in south Africa.. Anyway, car goes really well except sometimes wen I switch of, it warns me of tyre defective, remote battery etc.. Wat could cause that.. Unfortunately the pixels on that screen is slightly worn so I don't get the full warning..

  12. #87
    Join Date
    Jan 2004
    Location
    (northeast) Indiana
    Posts
    17,727
    My Cars
    97 740iL & 06 X5 4.4i
    Quote Originally Posted by Ivan2terrible View Post
    Hello ppl. I recently purchased a 2003 x5 e53 3.0d.. No1 has mentioned the diesel, not sure If u guys got them as I'm in south Africa.. Anyway, car goes really well except sometimes wen I switch of, it warns me of tyre defective, remote battery etc.. Wat could cause that.. Unfortunately the pixels on that screen is slightly worn so I don't get the full warning..
    (if my grammar, spelling, or sentence structure is screwed up....don't blame me...it's my dang bluetooth keyboard...I try to catch & correct the mistakes...but I may not catch all of them.)

    Q {BMW CCA Member #191509}
    1997 740iL (Arctic Silver) 3/97 mfg date <<~>> 2006 X5 4.4i (Sterling Gray) 12/05 mfg date
    (SOLD)
    1999 540iT (Orient Blue) <<~>> 1995 525iT (Alpine White)
    1991 735iL (Schwarz) <<~>> 1985 325e (Bronzit)

  13. #88
    Join Date
    Feb 2014
    Location
    U.K
    Posts
    2
    My Cars
    Bmw x5 2005 3.0d
    Hi guys. Looking for some advice on my 2005 X5 3.0d. When the engine is on idle, white smoke starts to come from the underside and I believe this is the exhaust for the heating system? I was told this was fine as long as it happened very rarely but it seems to be happening on every other small journey. Is there anything I can do to fix this problem, like have the heating system serviced or change a filter?

  14. #89
    Join Date
    Dec 2015
    Location
    Westfield ma
    Posts
    3
    My Cars
    2002 BMW X5 4.4i
    Hi, I have a 2002 x5 4.4i. Have put in a new timing chain, tensor. But now it crank but won't start, I have a code P0001. Any idea how to fixed.

  15. #90
    Join Date
    Feb 2016
    Location
    sydney, NSW, Australia
    Posts
    5
    My Cars
    BMW X5 2003 4.6 is

    Best and worst cars

    Quote Originally Posted by chilliwilli View Post
    Well at least you're comparing a Japanese (Lexus/Infiniti) luxury variant to the X5...still apples to oranges, imo, however a more realistic comparison. Would be interested in hearing which vehicle bimmerlova chose. Of the Japanese variants mentioned so far, at higher mileage, my suggestion would be an Acura MDX/RDX or Lexus SUV. I don't have enough experience with Infiniti to recommend to anyone...including the new FX45 i owned for a few months before dumping for another E53 4.6iS.

    ...Ditto on less electronics for reliability.
    Best cars I've owned (about six) were Toyota Landcruisers-80 and 100 series. 60 series was rubbish. Lexus LX470 X4 and the best LX570 X1. The worst was a 2 year old Range Rover Sport supercharged with 30000kms on the clock. Electrical, overheating, brakes and rotors wearing out too early. The best part of that car was the 4.6 S/C Jag motor. The rest just a heap OS.
    Just bought a 2003 BMW X5 4.6 is, really looking forward to picking it up in a couple of days.
    I'll be hanging around this site quite a bit from now on.

  16. #91
    Join Date
    Feb 2016
    Location
    Sc
    Posts
    2
    My Cars
    Brimmer
    I have a 2005 bmw x5 but it won't start. It will crank but won't start?

  17. #92
    Join Date
    Oct 2009
    Location
    CT
    Posts
    927
    My Cars
    530i
    Check out this YouTube playlist dedicated to E53 X5 common repairs and DIY videos. It covers a range from basic common problems to some more complex repairs:

    https://www.youtube.com/playlist?lis...BoZOPEauRHskow

  18. #93
    Join Date
    Nov 2016
    Location
    Alabama
    Posts
    1
    My Cars
    318ic
    2001 x5 3.0 will not crank,start. THE starter is good,yetc it seems to me we are not getting a signal from the key. Did a ews delete,still is the same. Anyone have any suggestions?

Page 4 of 4 FirstFirst 1234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •