Page 2 of 5 FirstFirst 12345 LastLast
Results 26 to 50 of 109

Thread: 1972-1981 (E12) knowledge base

  1. #26
    Join Date
    May 2011
    Location
    yuba city ca
    Posts
    338
    My Cars
    1983 320i 1979 528i
    i have a jumpy idle with my car. goes from 800 to 2300 rpms. rapidly.... HELP!!

  2. #27
    Join Date
    Nov 2012
    Location
    South Africa
    Posts
    1
    My Cars
    1977 BMW 525i

    1977 BMW 525i (E12) Repair Manual

    Hi Guys

    Thanks for the incredible posts.

    I just recently bought a 77 BMW 525i A/T as a restoration project, I am a novice. To the BMW brand. I was hoping to find info on where to find the E12 525i repair manuals and/or wiring diagram.

    Please any help would be appreciated.

    Kind Regards
    BMF Yellow

    Hi Guys

    Thanks for the incredible posts.

    I just recently bought a 77 BMW 525i A/T as a restoration project, I am a novice. To the BMW brand. I was hoping to find info on where to find the E12 525i repair manuals and/or wiring diagram.

    Please any help would be appreciated.

    Kind Regards
    BMF Yellow
    Last edited by BMF Yellow; 11-08-2012 at 06:54 PM. Reason: Automerged Doublepost

  3. #28
    Join Date
    Nov 2009
    Location
    Arlington, VA
    Posts
    23
    My Cars
    1978 BMW 530i
    It is great to see this thread as there are very few e12 guys out there. I've owned my 78 530i for over three years now and have learned a ton. I'm happy to try and answer any questions and of course, I've always got questions of my own.
    1978 BMW 530i e12, 2010 MINI JCW Clubman,
    1987 Volvo 245

  4. #29
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    2
    My Cars
    1976 BMW 530i
    Hi there.

    We have had our '76 530i in the family since it was new. First my grandfathers, then my fathers and now my brother's and mine. Unfortunately, it has been quite the money pit recently. We have just discovered that three of the fuel injectors have gone. We were just wondering how intensive this project would be as a DIY?
    We have very little knowledge of working on cars but have the time and patience to do a good job.

    Thanks everyone!!

  5. #30
    Join Date
    Nov 2009
    Location
    Arlington, VA
    Posts
    23
    My Cars
    1978 BMW 530i
    1976530i, the L-Jetronic fuel injection system in the e12 530i is pretty basic but also very fussy. There are several components to test and sometimes it can be difficult to narrow it down. I recommend starting at firstfives.org on the FAQ page. There are numerous posts about solving common problems with the e12 including a great explanation of the L-Jetronic FI system.

    If you know for sure the problem is the injectors, they shouldn't be too hard to replace with minimal mechanical skills but the injectors themselves will be pretty expensive. Another option is converting your FI system to Motronic used in the e12 528i and e28s. That would be much more extensive and would be very difficult for a novice mechanic to do, but if you do your research and find someone who knows the cars well that you can consult, it's possible.

    I'm considering swapping out the 3 liter engine and replacing it with a 3.5 liter M30 from an e28 or e34. This costs several grand but gives a nice boost of power and requires much less maintenance in the long run.
    1978 BMW 530i e12, 2010 MINI JCW Clubman,
    1987 Volvo 245

  6. #31
    Join Date
    Feb 2013
    Location
    Canada
    Posts
    2
    My Cars
    1976 BMW 530i
    Thanks for the reply DCMotoring!!

    We actually had the car in the shop a month ago, $1000+ in work on the exhuast/intake system no changes to the way the car ran, had the mechanic dig further and he discovered three injectors were gone would be $1000+ again, lost faith in mechanic and felt ridiculous to keep throwing money at it so was going to try and change ourselves. Fortunately, Bav Auto had the injectors on clearance so we got them for a really good deal. Good to hear they shouldn't be too hard to fix.

    Very jealous of that! All the best with the build!

  7. #32
    Join Date
    Jun 2009
    Location
    Portland, Oregon
    Posts
    139
    My Cars
    03 530i, 79 528i, 94 gti
    Quote Originally Posted by 1976530i View Post
    Thanks for the reply DCMotoring!!

    We actually had the car in the shop a month ago, $1000+ in work on the exhuast/intake system no changes to the way the car ran, had the mechanic dig further and he discovered three injectors were gone would be $1000+ again, lost faith in mechanic and felt ridiculous to keep throwing money at it so was going to try and change ourselves. Fortunately, Bav Auto had the injectors on clearance so we got them for a really good deal. Good to hear they shouldn't be too hard to fix.

    Very jealous of that! All the best with the build!
    My 79 had a similar issue. Mine ran but not well so I started investigating. After cleaning everything up and replacing all the filters and such, I found that it was only running on 5 cyl. So long story short it turns out the #6 injectors pintle cap had melted over the hole and wasn't allowing fuel through.
    So while driving on 5 I blew the head gasket. So I changed it. Well I put it back with a lower mile head. 180 deg. out and filled it up with coolant. So I yarded it all back apart and now it sits. That was 1 1/2 years ago. Hopefully next winter I will have the time to put it back together.

    So I learned a ton in the process and am happy to help any way I can. I also know the name of a fabulous website dedicated to e12's if you like. I don't think it's ok to post it in the forums. Please let me know otherwise.

    Joe

    Hi all,

    I have a 79 528i that I have owned for 3 years now. I'm the 2nd owner and it has a whopping 485k+ original mile. The car is totally original, on its 3rd head gasket, 2nd set of valves and Trans refresh. It's a true survivor.

    I have learned a bunch in the last 3 years and would be happy to share anything I have learned. Feel free to message me or just reply here.

    I'm currently driving an 2003 530i sport (e39) and learning all about them.

    Thanks, Joe
    Last edited by joekeefer; 02-28-2013 at 08:07 PM. Reason: Automerged Doublepost

  8. #33
    Join Date
    Jun 2013
    Location
    Lawley, South Africa
    Posts
    1
    My Cars
    1976, 525, E12, BMW
    Hi, i need a e12 525 1976 wiring diagram. Any assistance will be appreciated.

  9. #34
    Join Date
    Jul 2013
    Location
    mr
    Posts
    20
    My Cars
    yes
    Thanks for posting and offering your[img]http://www.****.info/hu7m.jpg[/img] assistance

  10. #35
    Join Date
    Aug 2013
    Location
    gainesville,fl.
    Posts
    2,585
    My Cars
    1977 320i
    Anyone I. South Florida...there's a 78 530i at the lkq yard in ft.lauderdale now...fyi.


  11. #36
    Join Date
    Jan 2009
    Location
    In the Darkness, where fear and knowing are one
    Posts
    671
    My Cars
    1987 Fiero GT
    Why do I keep getting reply notifications for replies that I don't see here?

  12. #37
    Join Date
    Aug 2013
    Location
    gainesville,fl.
    Posts
    2,585
    My Cars
    1977 320i
    I have a question that needs answering.
    I recently acquired an e12 cylinder head. It is an m10... or at least it is a 4 cylinder. Also it says 82... like my head says e21 77... meaning I have a 1977 320i. I wanted the manifold to replace my reactor.
    Trying to figure out what car this came from. No e12 were produced after 6/81( I think) ...but no US e12 had a 4 cylinder. Only one was a euro 518 ...which we didn't get.
    So where did it come from. Is the 518 right? Did they make an 82?


  13. #38
    Join Date
    Jul 2008
    Location
    Cypress, Tx
    Posts
    277
    My Cars
    See signature...
    Ours...

    His disciple,
    Sherman, Sr.

    TexFest LSB&F IV... Oct. 12-13-14, 2012

    '79 528i - 1st 5er
    '86 535i - Snob (My DD)
    '88 ///M5 - The Beast
    '91 ///M5 - ///M-unization Donor
    '92 ///M5 - Her DD
    '95 525iT - ///M Donee
    BMW POWER bi-turbo

  14. #39
    Join Date
    Nov 2009
    Location
    Newark, NJ, USA
    Posts
    17
    My Cars
    1974 Bavaria, 1978 530i
    Hello, guys I am new to this forum I am looking to get some help with a new member of the family. A 1978 530i (E12) I just picked up this car from the BMW dealership in Maywood by route 17, the car is beautiful but when I went to pick it one the car did not want to start so the salesman told me that this has never happen and that they were going to look in to it. Well the next day they called me to tell me that the car started with no issues, so off I go to pickup my new baby. Driving it home for about 20min the car shot off, now warning, nothing it was like I have turned off the ignition and it did not want to turn on again so I had to tow the car back to the dealership.
    The next day the salesman tried to turn on the car and nothing, then he walk to the service center about 30 feet away and when he came back with the mechanic the car turned right up. The mechanic can not replicate the issue. The have tried for a day and nothing.
    Any help you can provide will be grate or maybe direct me where to look...
    Thank you guys in advance...

  15. #40
    Join Date
    Jul 2008
    Location
    Cypress, Tx
    Posts
    277
    My Cars
    See signature...
    Sounds like some loose connection or faulty main relay.
    His disciple,
    Sherman, Sr.

    TexFest LSB&F IV... Oct. 12-13-14, 2012

    '79 528i - 1st 5er
    '86 535i - Snob (My DD)
    '88 ///M5 - The Beast
    '91 ///M5 - ///M-unization Donor
    '92 ///M5 - Her DD
    '95 525iT - ///M Donee
    BMW POWER bi-turbo

  16. #41
    Join Date
    Nov 2009
    Location
    Newark, NJ, USA
    Posts
    17
    My Cars
    1974 Bavaria, 1978 530i
    Any idea on what relay should I be looking at. When the car is spray with starting fluid the car seems to want to start, but it does not.

  17. #42
    Join Date
    Jul 2008
    Location
    Cypress, Tx
    Posts
    277
    My Cars
    See signature...
    The main and fuel pump relay are built into one unit.
    It sits up next to the fuse box.
    His disciple,
    Sherman, Sr.

    TexFest LSB&F IV... Oct. 12-13-14, 2012

    '79 528i - 1st 5er
    '86 535i - Snob (My DD)
    '88 ///M5 - The Beast
    '91 ///M5 - ///M-unization Donor
    '92 ///M5 - Her DD
    '95 525iT - ///M Donee
    BMW POWER bi-turbo

  18. #43
    Join Date
    Nov 2009
    Location
    Newark, NJ, USA
    Posts
    17
    My Cars
    1974 Bavaria, 1978 530i
    Thank you Swatterssr, my mechanic replaced all fuses and fuel pump relay and she is now in working order.

  19. #44
    Join Date
    Jul 2008
    Location
    Cypress, Tx
    Posts
    277
    My Cars
    See signature...
    You're welcome.
    His disciple,
    Sherman, Sr.

    TexFest LSB&F IV... Oct. 12-13-14, 2012

    '79 528i - 1st 5er
    '86 535i - Snob (My DD)
    '88 ///M5 - The Beast
    '91 ///M5 - ///M-unization Donor
    '92 ///M5 - Her DD
    '95 525iT - ///M Donee
    BMW POWER bi-turbo

  20. #45
    Join Date
    Nov 2009
    Location
    Newark, NJ, USA
    Posts
    17
    My Cars
    1974 Bavaria, 1978 530i
    I have a new question. I just got the car so don't know much about it. I am using the car as an everyday drive to work 38m round trip. I am in NJ so it is now around 30 degrees out the car is not running hot but the dial is going past the second mark. I checked the antifreeze reservoir and it was dirty with gunk in there so I flushed out the system and added a car cooling system cleaner I am now running it for 3 days as the instructions said. Tomorrow I am going to be flushing it again.
    Now my question is what else can I do to make sure the car does not over hear when summer comes around.
    Is the 1978 530i Auto known for over heating? I know some bimmers do.
    Thank you in advance guys.

  21. #46
    Join Date
    Nov 2009
    Location
    Newark, NJ, USA
    Posts
    17
    My Cars
    1974 Bavaria, 1978 530i
    I have a new question. I just got the car so don't know much about it. I am using the car as an everyday drive to work 38m round trip. I am in NJ so it is now around 30 degrees out the car is not running hot but the dial is going past the second mark. I checked the antifreeze reservoir and it was dirty with gunk in there so I flushed out the system and added a car cooling system cleaner I am now running it for 3 days as the instructions said. Tomorrow I am going to be flushing it again.
    Now my question is what else can I do to make sure the car does not over hear when summer comes around.
    Is the 1978 530i Auto known for over heating? I know some bimmers do.
    Thank you in advance guys.

  22. #47
    Join Date
    Jun 2009
    Location
    Portland, Oregon
    Posts
    139
    My Cars
    03 530i, 79 528i, 94 gti
    Just make sure the thermostat is good, and that the water pump works. The radiators will eventually need replacing. My 79 still has the original one but I have a new replacement.

  23. #48
    Join Date
    Jul 2008
    Location
    Cypress, Tx
    Posts
    277
    My Cars
    See signature...
    You can, as I've done, upgrade to an E28 radiator, waterpump, and fan and clutch. Also as has been stated, make sure all components are in good working order and you should be OK.
    His disciple,
    Sherman, Sr.

    TexFest LSB&F IV... Oct. 12-13-14, 2012

    '79 528i - 1st 5er
    '86 535i - Snob (My DD)
    '88 ///M5 - The Beast
    '91 ///M5 - ///M-unization Donor
    '92 ///M5 - Her DD
    '95 525iT - ///M Donee
    BMW POWER bi-turbo

  24. #49
    Join Date
    Apr 2014
    Location
    ashland oregon
    Posts
    1
    My Cars
    bunch of german ones....
    just picked up this nice lil 78. sat around in the po's family for awhile and needs a bunch of freshening up. needed valve stem seals and the "started" the job. Got it back to my shop and started going through it. All of the chassis electric works as it should, just need to finish up a really bad shadetree mechanic's funk up......here we go

    gotta say I'm a sucker for lipstick red




  25. #50
    Join Date
    Nov 2009
    Location
    Newark, NJ, USA
    Posts
    17
    My Cars
    1974 Bavaria, 1978 530i
    joekeefer and swatterssr thank you very much for the suggestion, as I was asking the question I realized I had a leak from the water pump so yes it needs replacement. I got a 1988 528e that I purchased about 2months ago I don't know why... I think it was the same reason as roxrcool I am also a sucker for lipstick red.
    Well the e28 has a new radiator, fan clutch an water pump would they all fix with out any modifications?

    roxrcool, the exterior is the same color as mine, LOVE THE LIPSTICK RED!!! wish mine would have been like that... : (

    - - - Updated - - -

    Ok guys let me hit you with another one....
    My oil pressure light is coming on after 30min of driving when I am at a stop, that is the problem.
    One of the suggestions was to replace the Oil pressure switch, so I did that and nothing changed.
    Another on was to change the oil and filter so my mechanic recommended 10W50 Full Synthetic, then I found online that 20W50 what BMW Recommended for the M30 engines. That did not do anything Light keep coming on after 30min or so of driving.
    Found another post that said to install a gauge, were the oil pressure switch is. After replacing the switch I realized there was a small plastic hose that went through the fire wall, so I took the panel under driver side and found an oil pressure gauge. Now the gauge was leaking a bit so I tighten the connections.
    At idle the dial goes pass 5 and the oil pressure light comes on, at 60mph it goes up to 40, I am not sure what the numbers represent on the gauge. Here are some pics.
    First one is for when the car is idle the dial goes in between 5 and 10, The second one is for my oil pressure light on and the 3rd one is for when the car is at 60mph the dial goes to 40.
    BMWOilPressureGauge_at_Itel.jpgBMWOilPressure_Itel.jpgBMWOilPressure_at_60mph.jpg

    Now I took a look at the oil pan and there is a small leak by the back next to the transmission. I drop the sub-frame and I am ready to install a new gasket.
    Since I have the pan out do you guys think my problem is the oil pump? Should I replace it?
    Last edited by BavariaRR; 04-14-2014 at 11:50 AM.

Page 2 of 5 FirstFirst 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •